Why has my Geo In Home Display started showing gas when I have no gas supply?

Show first post

58 replies

Hi @Blastoise186 and thanks for the quick follow-up. The code appears to be 29-1. There's no gas at the property or in the village for that matter.


Userlevel 7
Badge +1

Thx. I’ll check my Confluence site when I get home as that’s where I’ve got the sheet.

Once I have that, I’ll update you.

Userlevel 7
Badge +1

Ok, I’m back. Thanks for waiting! :)

29-1 usually means the IHD isn’t being allowed to access data from the gas meter. In cases where there is a gas meter installed, it’s just a case of the supplier pinging a few commands to grant that access to the IHD.

In your case however, something is making the IHD think that there is a gas supply on your Site even though there isn’t. This can also be fixed by having the site remotely reconfigured to remove gas service from the system.

Please give the support team a shout and let them know. If you include this thread and my response as part of that, it should make things a bit easier to explain.

Rather than start a separate thread, can I just say I am suffering the exact same issue which started on Monday morning having worked correctly since the IHD was installed Mid-December. Error code is the same 29-1

You say reach out to the SSE support team, but all I can find is a section of the website that sends you down various dead ends and with no option to call or email a human being.

Unfortunately having taken nine months to get SSE to admit I was on an obsolete (and more expensive) tariff, my heart sinks at the thought of more calls with 45 minutes on hold, only to get someone who doesnt have a clue.

You sound like a really helpful guy - do you have a definite way of getting to speak or email support? If ive missed something obvious I really do apologise.


Userlevel 7

SSE’s support team contact details can be found here@MikeMilf - they also have a Facebook and Twitter team. 


Although in your case I’d hold off. You say the IHD was installed mid-December. If that's alongside the meters getting fitted at the same time, we tend to advise leaving things for the first 6 weeks to make sure all the right data and settings are set up. 


Thanks for the response but the link to Support you provided just hangs. Have tried it multiple times

You say to wait for six weeks so I will, but it worked perfectly following installation, only to start looking for a non-existent gas reading on Monday this week.

Edit - got through to that support link finally and its exactly the same one I looked at yesterday

If you choose Contact Us > Gas and Electricity there is no option for faulty equipmnent only Emergencies or General Enquiries, neither of which seems appropriate

This is my greivance with SSE. The website lets you do the basic things like submit a meter reading, but anything else grinds to a halt. My online account still doesnt reflect the fact I have a smart meter and calls to the switchboard get an incredibly blank response





Hi there,

Has this problem been resolved for anyone?

I have exactly the same 29-1 problem with the IHD suddenly trying to connect to gas when I dont have any gas… it has previously been working fine.

It’s diminished the effectiveness of the IHD as I can’t see the running total on the right hand side at the same time as seeing the today’s figures on the left.

(We’re also with SSE waiting to be moved over to OVO.)

Many thanks

Hi Kevin

Im afraid not.

I have just resolved a formal complaint issue with SSE, and I have to say the complaint handler was nothing but rude and dismissive. When I mentioned about the IHD issue, she couldnt have cared less and just said maybe it will sort itself out when you get your next bill.

Yeah right….in the same way my online account is still not linked to my smart meter some seven weeks after installation?

Needless to say trying to speak to SSE about the IHD display usually involves forty minutes on hold, and eventually results in speaking to someone as much use as a chocolate teapot!

You could probably put a big dent in the unemployment figures for this country if the major companies actually employed enough people to man their phones…..but that would dent their millions or billions in profits wouldnt it


FYI, I logged a ticket directly with the Geo. Here is an extract from their response:

The In Home Display is showing gas on the right hand side due to a configuration issue, we are working with our industry partners to try and identify the root cause. 

I wouldn’t hold my breath, but at least they acknowledge the problem and seem to be investigating.



Well done mate - youve acheived somthing more than I did at least 😉

We had our Geo fitted in November. About a month later ours now also has half the screen wasted with “Awaiting Data” for gas. Our village has no gas (this property has no gas). These smart meters are not too smart! 

ours came from SO energy and their phone line support was, oh sorry, turn it off wait a few hours and turn it back on! Still nothing. Is this definitely something the energy company has to do, and push a new config somehow? Do I just keep contacting them and complaining till they do something? 

Thanks in advance for any advice


Userlevel 7
Badge +1

Yeah, sounds like the Comms Hub thinks there’s a gas meter that’s meant to be attached to the network. Your supplier just needs to reconfigure it to disable gas completely.

Thanks Blastoise186, you make it sound so simple! :) However, I don’t know of any suppliers that have managed to reconfigure the Comms Hub to disable the gas completely...(?).

Hi everyone. I’m having the same issue with my single fuel meter, except that I’m a British Gas customer. My smart meter was installed on 7th Jan 23, it worked fine for the first week, then suddenly split screen appears showing electricity and gas with “awaiting data”. BG have been hopeless, promising they would fix it. A month on, still no joy. I’m starting to think it’s a issue affecting the entire infrastructure and that either GEO or one of the backbone providers (Capital PLC / CGI IT UK Limited) has corrupted the data. I guess the only option is to wait.



I have a Geo Trio Touchbutton IHD which was installed by an SSE installer but after we migrated to Ovo.  A few weeks ago it stopped showing data (“Waiting for Data”) and no amount of reboots brings it back.  Coincidentally this was not long after it suddenly started showing a Gas display as mentioned in a few other threads (we don’t have gas, it doesn’t even come to our village).  Any clues please?  All I can find is help for IHD installed by Ovo.

Userlevel 7
Badge +1

I could do with the Status Codes from the System Status menu. :)



Userlevel 7
Badge +1

Just 28-1 right?

It’s not paired properly to the electric meter. You need to get Support to pair the IHD again.


Okay, many thanks.


Hi guys

Similar problem as above

I had a Geo smart meter installed on the 2nd Feb 2023 with only a electricity supply and on the 26th Feb, the IHD is now awaiting for Gas data with the same 29-1 error code.

I have solar panels installed and would like to see my current export/import reading on the left and my current daily usage on the right as I've been seeing for the last 3 weeks. The effectiveness of the smart meter has been decreased significantly because I can't see all the information I want at a glance.

Leaving it off overnight and plugging in closer to my electricity meter has made no difference.

Any updates or fixes?



Userlevel 7
Badge +2

Not sure about your gas data @DeeloGB but I don’t think you’ll be able to see export on this. There are very few (if any) IHD’s which can show this

Userlevel 7
Badge +1

You need to get the Comms Hub reconfigured to disable Gas services completely. It sounds like that functionality got enabled somehow. 29-1 means the IHD thinks there’s meant to be a gas meter, but that the gas meter isn’t responding.


Not sure about your gas data @DeeloGB but I don’t think you’ll be able to see export on this. There are very few (if any) IHD’s which can show this

I've been seeing the above and below for 3 weeks. Definitely shows when I'm exporting to the grid and when I'm importing from the grid. 

Will have to see if I can get Comms Hub reconfigured.


Userlevel 7
Badge +2

Is this a Geo II @DeeloGB ? I read that these were being made compatible but I’ve never seen one showing export 


Is this a Geo II @DeeloGB ? I read that these were being made compatible but I’ve never seen one showing export 

Yeah, it's a Geo Trio II, if that's the same thing