Solved

Why has my Geo In Home Display started showing gas when I have no gas supply?


Hi,

It’s a trio touch button in-home display and it was fine for the first few months.

 

I only have electricity and that’s what it displayed until a few days ago.

Now it has a split screen showing gas and various gas options.

Gas Usage is 0.0 of course, but I’d like to make the electric display full screen again.

 

Unplugging it overnight didn’t help.

I also tried deleting settings and then data.

 

icon

Best answer by Jess_OVO 19 May 2022, 12:13

View original

18 replies

Userlevel 7
Badge +1

Hi @Panikos ,

Do you get any error codes or status codes by any chance? If you could also show us a photo of the system status screen, that would be extremely helpful. 

Thanks!

Hi, there are two errors on the status screen as you can see from the photo.

Before this happened there wasn’t an icon on the status screen for gas at all and all were green

 

Userlevel 7
Badge +1

Ahh ok, I see you’ve got the CAD features set up as well. That means if needed, I can call in some extra help from a Geo rep who stops by here a lot.

To me though, this suggests a problem with the Comms Hub above your electric meter. Could you show me photos of the electric meter as well please? I might be able to gather further clues from it.

Thanks, I will grab a photo of the meter, but I should say at this point that I’m not quite an Ovo customer yet. I’m still with SSE until they finish transferring my account over. So if it is the meter itself I should get onto them.

 

When it first happened I assumed it was a glitch in the in-home display

 

 

Userlevel 7
Badge +1

No worries. This forum is open to everyone, regardless of whether you’re an OVO member and we’ll always help you out as best we can. The only real difference is that because we know OVO’s platforms better than we do everyone else’s platforms, we can sometimes help a little bit more if you’re with OVO than we can otherwise.

I have ways of doing a certain level of diagnostics and @kevinmcintyre09 has been helping us out recently with Geo IHDs as he’s that Geo rep I mentioned. OVO uses Chameleon so not many of us have Geo experience yet. But no doubt Kevin will be able to give us a lot of tips to fill in the void. This might be a good one for him as well actually. :)

Userlevel 7

Really strange to see this error popping up on your Geo IHD, @Panikos.

 

I wonder if it could signify some communication issues between the device and your electricity meter. Any ideas @kevinmcintyre09?

 

Not sure if it might be a bit OVO-specific but we do have some advice on checking this connection on this similar thread,
 

 

Have you reported the error message to the SSE Support Team yet, @Panikos?

Thanks both for the welcome and I’m taking a look at that link now. I hadn’t realised the speed the lights flash gives more information.

Meanwhile I think I really should report it to SSE  since it’s looking like it’s  a meter issue and presumably they can access it directly/send commands.

Trust me to get a rogue one.

I’ll report back

 

Userlevel 2

Hi @Panikos Could you message me directly, with WiFi Mac address, as it looks like you have our IHD with WiFi.

 

Generally all IHDs only reflect what they are being told about the smart metering network.

 

If you go to the menu, then settings, look for WiFi menu. Once you are in this screen there is a button that says something like WiFi info, select that and you see some further WiFi info. One of them will be the WiFi Mac address.

 

Cheers,

 

Kevin

Userlevel 1

I've just come back from holiday 21st May and my IHD is exhibiting exactly the same behaviour (Electric and Gas). I don't have gas and indeed can't have gas in my flat as the properties in the block are not piped up for it.

It seems a software update has been rolled out that has now instructed the IHD and Smart meter to show duel fuel tariffs.

A bit pointless when I only have one fuel. (Electric). Hopefully a future update will correct this anomaly

 

Andrew, I never saw that coming.   I got onto SSE support (since not changed over yet) and I was waiting for their response.

 

I’d started off thinking it was the IHD, but then was convinced it was the meter sending out the wrong info and now come full circle.

 

I do see it as a bug and maybe they will correct it, but now we know it’s a relatively harmless one.

 

Thanks all for your help.

Userlevel 2

Our IHDs only show gas if we are told there is gas as part of metering system config. It is not the starting point for an IHD to assume there is gas.

I am not entirely sure what would happen if we were told there was a gas meter and told again there was not.

 

As you can imagine the meter config should not change.

 

 

Userlevel 1

Our IHDs only show gas if we are told there is gas as part of metering system config. It is not the starting point for an IHD to assume there is gas.

I am not entirely sure what would happen if we were told there was a gas meter and told again there was not.

 

As you can imagine the meter config should not change.

 

 

Fair enough. However where I live the postcode area is specific to our apartment complex. None of the apartments have gas, so I guess whoever reconfigured the meter in the past few days has sent out the wrong data specifically to show dual fuel.

Most of the apartment's including ours are on economy 7 tariffs, regardless of energy provider. When my account was moved from SSE to OVO back in December the meter was wrongly configured to a single rate tariff but then subsequently corrected a couple of weeks later.

I hope a similar thing will happen again.

Userlevel 2

@Andrew CS and @Panikos can you both message me with your WiFi mac address. This can be found by  going to the menu, then Settings, WiFi network, then WiFi info. If you have WiFi in your devices.

 

If no WiFi menu, then just the serial numbers from the bottom of the device, just remove the stand to see it.

 

We can have a look with our DCC adaptor and see if we can learn anything more.

 

Also can you both let me know which supplier you are with.

 

Cheers,

 

Kevin

Userlevel 1

@Andrew CS and @Panikos can you both message me with your WiFi mac address. This can be found by  going to the menu, then Settings, WiFi network, then WiFi info. If you have WiFi in your devices.

 

If no WiFi menu, then just the serial numbers from the bottom of the device, just remove the stand to see it.

 

We can have a look with our DCC adaptor and see if we can learn anything more.

 

Also can you both let me know which supplier you are with.

 

Cheers,

 

Kevin

Hi Kevin,

I have the non WiFi IHD display serial no: TL520340648182

I was formerly with SSE and was migrated over to OVO in December. 

Userlevel 7

Did you manage to get to the bottom of this one, @kevinmcintyre09  and @Andrew CS.

 

We’re keen to hear if there’s a wider issue at play or whether our Support Team managed to get to the bottom of things.

Userlevel 1

Did you manage to get to the bottom of this one, @kevinmcintyre09  and @Andrew CS.

 

We’re keen to hear if there’s a wider issue at play or whether our Support Team managed to get to the bottom of things.

Unfortunately not. My In Home display, still shows a split screen with a Gas section saying waiting for data and all the sub menus relating to gas greyed out.

No surprise really as I don't have gas or a gas meter.

Userlevel 7

How strange, @Andrew CS.

 

I’d recommend reaching out to our Support Team to flag this if you haven’t already. Have you been logging in to your online account to check the smart meter usage data we’re receiving?

Userlevel 1

Yes the meter is logging my dual rate economy 7 tariff readings correctly with my account.

Reply