Tutorial

SMETS2 In Home Displays (IHD): which type do I have and how can I spot and fix issues? DIY tutorial series

  • 11 September 2020
  • 29 replies
  • 29790 views
SMETS2 In Home Displays (IHD): which type do I have and how can I spot and fix issues? DIY tutorial series
Userlevel 7

Updated on 04/05/21 by Jess_OVO

 

S2 In Home Displays - your guide

 


How to identify the IHD models


It’s important to understand what type of IHD you have before trying to troubleshoot any issues.

We have used three different types of S2 IHDs so far. Currently we are sending the new Chameleon IHD6 (referred to as simply IHD6) to members with S2 meters. You can find a description of these below.

These are the different types:

IHD6-CAD-PPMID - also known as the IHD6


This device looks similar to a Pipit, as it's got a black front, white back and a touch screen. If in doubt, check the device has the word "Secure" written at the bottom of the screen - if it doesn't, then it is an IHD6 and perfectly compatible with S2 meters.
 


 

IHD6-CAD-PPMID


IHD3-PPMID TYPE2 - also known as IHD2


This has the same appearance as the old S1 Chameleons (IHD3-CAD), except the S2 IHDs have an on/off button on the back of the device, and will have 'IHD3-PPMID TYPE 2' written on the bottom.
 

IHD3-PPMID TYPE2

IHD3-CAD-PPMID TYPE1 - also known as IHD3.


They have the same appearance as the standard IHD2 but will have 'IHD3-CAD-PPMID' written on the bottom.  

Benefits of connecting your IHD to WiFi


The IHD does not connect to your online account or OVO app (download for Android or iOS). However, connecting to WiFi on IHD6 allows us to make any firmware updates to the IHD remotely. It also allows you to see when an IHD stops working and better troubleshoot any issues, as it provides information the IHD is displaying.

Engineers are advised to pair the WiFi up on every job they do, however sometimes this is not possible and it is not mandatory.

Is the IHD showing too high consumption?


This is a known issue with the firmware on some electric meters installed towards the beginning of the S2 roll out. This has been shown to cause members' IHDs to show high usage. Firmware updates are being performed on a number of S2 meters.

If you’re seeing high usage, reach out to our
Support team 


 
What to do if you’re having an issue with your IHD


First, check whether there is an issue with the HAN (rather than the IHD itself). You can do this by checking how regularly the HAN light is flashing on the comms hub. See this SMETS2 smart meter guide if you’re not sure how to do this.

 

Another indication would be that there is no consumption data for electricity meter, gas or both showing on the device. If there is a possible HAN/WAN issue then complete a smart meter health check.

If the IHD is showing missing data for one or both fuels and the meter comms are fine, you should perform the following checks.


1 - Check the distance to the electricity meter, has the IHD been moved? 

 

Try to keep the IHD within a max of 6 metres from the electricity meter. The signal will decline significantly with walls.

2 -  Has the IHD shown data previously or has anything changed e.g. obstructions?

 

If the IHD was previously showing data, check if anything has changed in the home that could have caused the loss of communication.

3 - Is the IHD showing the correct time?

 

If it's not showing the correct time, the IHD is not paired.

4a - IHD2 and IHD3: Check WiFi symbol - is it flashing/solid?

  • No WiFi symbol & incorrect time > Needs to be paired by our Support team 
  • WiFi symbol flashing > Our Support team may be able to sort by unpairing and pairing the device
  • WiFi symbol solid > No issue with WiFi pairing

4b - IHD6: Check the signal bars

Signal bars solid > IHD is paired.
Signal bars flashing > Needs to be paired by our 
Support team 

5 - Try turning off for several minutes before turning back on.


What happens if I’ve broken or lost my IHD?


Please reach out to our Support team to discuss this. We may be able to offer a replacement. 

IHD is showing text in Welsh


Occasionally, IHDs have been known to default to Welsh. Follow these steps to change back to English:

1. Tap the ”OK” button at the bottom of the IHD screen.
2. Tap the right arrow until you see “Gosodiadau Wedi anfon yr” and tap OK.
3. Tap the right arrow 8 times until you reach the option “Dewis iaith Wedi anfon yr” (if this doesn't work, you may need to try the next option: “Clirio Gosodidau Wedi anfon yr") and tap “OK”.
4. Tap the left arrow to select English, then tap "OK".
 
 

A useful tip...

You can tell whether a device is an IHD2 or IHD3

  • On the box the IHD was packaged in
  • On the IHD, next to the device ID

 
Booklets

  • Chameleon (IHD2 & 3) user guide can be found here.
  • Chameleon IHD6 guide can be found here.



Pairing and unpairing the SMETS2 Chameleon IHD3 and IHD6s
 

Our Support team will need to work with you to get your device paired or unpaired from your meters. Contact the team when your device arrives and they will complete some remote processes on your meter and talk you through the steps to follow on your device.
 


Lastly, setting up WiFi on the IHD6


What is the benefit of connecting to WiFi on the IHD?


Connecting to WiFi on IHD6 allows us to make any firmware updates to the IHD remotely, and also allows you to see when an IHD stops working and better troubleshoot any issues. It also gives us the information the IHD is displaying so that we can diagnose any issues that may occur.

To pair to the Wifi, follow these steps:

1. Tap the menu button in the bottom right corner of the screen.

 


2. From the menu screen, tap the right arrow to go to the next page. 

 


3. Tap ‘Settings’.

 


4. Tap the 'Wi-Fi' icon. 

 


5. Tap the button to turn the WiFi on.

 


6. Once the WiFi is on, tap 'Scan' to show the available networks or press WPS Push if the router you’re trying to join supports this function.

 


6A) If choosing WPS Push - press the WPS button on the router when this symbol is displayed. 

 


6B). If choosing Scan - Once you’ve selected the network you wish to join, enter the password and press ‘Join’.

 


7. The device will now connect to the WiFi.

 


8. If the password is correct, the device will show a Connected status. 
 

 

There’s also this really handy video showing how to use an IHD6 model.

 

If you have a ‘Secure Liberty’ S1 smart meter with a Chameleon IHD, see this topic for your IHD guide. If you have a ‘Secure Liberty’ S1 meter with a Pipit IHD, see this topic for your IHD guide. 

 

That’s it, our complete S2 IHD guide. Let us know if you have any questions relating to the info above by leaving a comment! 

 

OVO member but not got a smart meter yet? - Book today!

 

Interested but not yet an OVO member? - Check out our plans!

 


29 replies

Userlevel 7
Badge +4

Bad news @Tim_OVO ! This already monster sized tutorial topic is about to grow even larger! :smile:

It’s worth bearing in mind that not all Wi-Fi Routers support WPS anymore. While a lot of older ones do support WPS, certain newer ones dropped support for WPS partially for security reasons, but also because it wasn’t always particularly reliable or well used. The Scan method will work fine however in all cases! But if you’re having trouble getting your shiny new IHD6 onto your Wi-Fi, I’d like to add a few tips to the guide.

Just as a heads up, I use a pretty overpowered setup which I blogged about a while ago. Some of the features it has might not be present on your router, but this won’t be a problem. You may need to login to your router for some of these solutions.

 

My IHD can’t find my Wi-Fi Network at all, even though it’s close to the router!

 

There’s a couple of things that might help here, assuming you’re definitely in range.

 

Is your Wi-Fi Router/Network actually turned on?

 

It’s surprising how easy it is for this to happen! If you’ve accidentally turned off the Wi-Fi in your settings, please make sure it’s turned back on.

 

Yup, this is a very dead Wi-Fi Network

 

Did you hide the SSID/Network Name?

 

If you’ve hidden the network, this makes using your devices more tricky. I generally recommend setting this to show the SSID/Network Name as it doesn’t do anything useful:

 

Sometimes this shows up as Hide SSID, Broadcast SSID or many other names!

 

Is your 2.4GHz Wi-Fi turned on?

 

Most IHDs like the Chameleon IHD3 and IHD6 only support 2.4GHz Wi-Fi band, rather than the newer 5GHz Wi-Fi band. You can run both at once under the same network name/password though and this should fix the issue.

 

Make sure to have both 2.4GHz and 5GHz on for best results!

 

Why does my IHD6 fail to connect to my Wi-Fi Network?

 

Most likely it’s one of the issues above. The other two likely ones are that you’re trying to connect to the wrong network, or you’re entering the wrong password! Make sure to double check you’re using the right ones. :wink:

 

If you’re using MAC Address Filtering, you’ll also either need to add your IHD to the list of permitted devices or turn MAC Address Filtering off completely. Also…

 

Can your Wi-Fi Router see your IHD? Has it ever seen your IHD connect?

 

Most Wi-Fi Routers should tell you whether your IHD is currently connected. If you don’t see it in the list of connected devices, you might want to check things over again.

 

Yay!

And that should solve most IHD Wi-Fi issues. :sunglasses:

ello,

Where do i find the night time usage on my IDH6 please?

Userlevel 7
Badge +4

Hi there @nmac234 ,

This isn’t quite the right thread for your question, but I’ll answer it for you while it’s here and ask a moderator to move things over later.

I’m afraid there’s no specific option to view night time usage on an IHD6 that I know of. The closest it can do is current usage as of right now, or for the current day so far. If you’re looking for a specific hour, you might want to check your account in MyOVO.

Userlevel 7

 

This is also worth a look, @nmac234 ^

Userlevel 4
Badge

Hi I have the same issue with IHD that others have described in this thread and others. What do I do now?

Here’s the history

  • SMETS2 and Chameleon IHD6 installed 06/01/21; no connection issues and all works fine (except IHD battery seems to last only half a day from full charge; I’ve reported that).
  • Yesterday (02/02/21) the IHD stopped showing any usage information and Meter Information Screen shows “Waiting for Meter Reading” – both for gas and electricity.
  • IHD shows strong HAN signal. I’ve done the IHD hard switch off and restart several times to no effect.
  • Communication hub has both WAN and HAN green lights blinking at 5 sec intervals (which I think is ok).
  • Usage is registering on my online account – or at least it was. See these screen clips taken from my PC just now (the phone app shows exactly the same). Note that electricity figure is missing yesterday.

Is there any more to check before I contact Ovo? And I’m not sure from the thread I’ve quoted that the issues are being fixed.

 

 

 

Userlevel 5

@hecate - I’ve moved your post over here, as there’s a bunch of info for issues like the one you’re facing.

 

I’d just have read through, and see if there’s anything you’ve missed, and if you still can’t get it working, get in touch with our Care Team to help get this one sorted.

Userlevel 4
Badge

Thanks @Ed_OVO as if my magic, the IHD is now connected again, with a message “gas meter initialised” and all displays seem to be working, incuding usage for both fuels

The usage data on my account is still stuck at 1 February for electricity, but has moved forward to 3 Feb (yesterday) for gas. I assume that the account info in the app will catch up eventually...

Userlevel 7
Badge +4

Hi there @hecate ,

I’m glad to hear it’s working for you again, but if you have more trouble, please give us a shout here too. We’ve recently opened a Tech Treehouse on the forum with the aim of helping to squash as many of these issues as possible. If you continue to have issues like this, I might be able to extend an you an invite to it.

Userlevel 4
Badge

Hi @Blastoise186 things have gone backwards!

There were no electricty readings visible on my account after 1 February, though gas was updated ok. And then the new IHD arrived - appeared to connect after making a call to Ovo, though I was on forf 25 minutes. But IHD shows no readings even after 24 hours - and now there are no usage updates at all on my account. I’m getting in touch again of course (need to check meter indicators again) and will update here.

I’m not really happy - time spent reading old meter and sending readings - 5 minutes each month. Time spent on issues with IHD and Samrt Meter in one month 2 hours and counting...

Userlevel 7
Badge +4

Hmm… That’s really not good…

I’ve been thinking about this @hecate and I’m tempted to do something clever. What would you say if I looked into giving your forum permissions a bit of an… Upgrade…

I think you may benefit from having access to the Tech Treehouse, but I need to get your consent before I can request an invite. Would you be OK with that?

Userlevel 4
Badge

Yes fine.

I’m happy to help others too although I don’t often have much time to browse

 

Userlevel 7
Badge +4

Perfecto. I’ll make an offering to the Mods Of The Forums and make them smile. The Mods Smile On The Generous and they reward those who cross their palms with silver. :smile:

Userlevel 7

@hecate when you next log in, have a look at the category menu (top left). You should now see a new area called Tech Treehouse with a padlock.

 

Mod bless,

Tim

:innocent:

Userlevel 4
Badge

@Tim_OVO @Blastoise186 Thanks I can see that and will look later.

Sitrep about ongoing issues. Webchat today with customer service. There are two issues, but still not clear if connected.

1. IHD: attempted reset again; will phone me tomorrow to see if it works. If not will go straight to Smart Meter Team

2. Electricity readings not showing in account since 1 February. This turns out to be because settings were set at monthly for electricity, but daily for gas. That wasn’t how the engineer set it up; she advised daily as otherwise it makes billing hard to understand. And even for non-obsessives, you’d sometime want to take advantage of smart meter to check more often that once a month. So I can see daily electricity readings all through January.

My guess – not discussed on webchat as that was focused on solution – is that the gas meter initialisation (? I think that’s what the message said) which came through on 2 February (and blanked IHD display for a day or so) was somehow linked to the reset of electricity reading interval to monthly.

Userlevel 7
Badge +4

Thanks for the heads up @hecate . It should be fairly easy to restore the submission settings back to whatever you’d like them to be on for both meters. The Support Team can take care of that on request, but it can take a few days to apply the changes.

We’ll catch up with you in the Tech Treehouse when you’re ready. :)

Userlevel 7
Badge +4

I’ve got some extra advice that I’ve learned while using the Kecleon Brothers. It’s not big enough for a whole new topic, but something that’s good to know.

When you’re pairing up a new IHD6 to your meters, the IHD will reboot once it joins the Home Area Network successfully. It does so in a way that might make you think it has crashed, but it actually hasn’t. These gadgets just so happen to be ultra fast at powering off! :wink:

You can safely move the IHD out of range of the meters during the reboot and it won't affect the pairing process, but it can cause a few temporary quirks due to the fact that the full config is only downloaded once the IHD comes back online after rebooting. If you move out of range during this time, it can interrupt the download. As a result, it might look as if your IHD is still in a blank factory fresh state.

The good news however, is that there is a really easy fix. Simply move back in range of the meters again and once the IHD6 reconnects, it will finish the download and complete the setup process like magic in around 90 seconds or so. And if you’re Electric-Only, everything to do with Gas will be removed from the UI completely and hidden away so that you don’t get confused.

Hi my chameleon meter has a continual flashing connectivity signal and keeps resetting itself every minute or so. Is there a fix for this please ?

Userlevel 7
Badge +4

Howdy @Rick1331 !

Yup, there are a few ways to solve this, but in this case the easiest one might be to have the Support Team unpair and re-pair your IHD with your meters. IHDs are known to show this sort of behaviour if they’re struggling to connect to the meters - especially if they’re not paired yet - as I believe it’s part of the self-diagnostic features.

If you still have trouble after that, please let me know and I can walk you through some further troubleshooting. The ultimate last resort fix is to replace the IHD itself, but I much prefer to only recommend that if absolutely nothing else works.

Thanks,  I’ll give them a go 

Userlevel 7
Badge +4

No worries. :)

I have two Chameleon IHD6 IHDs myself that I call the Kecleon Brothers. They prove useful for testing things out and my environment means that the signal from my meter Raichu isn’t strong enough to maintain a signal to them 24/7. But it does mean I can test out these exact scenarios pretty easily.

Another way to check if the IHD is paired yet, is to power it down and then plug it in to charge. If it powers up immediately and offers to run the Tutorial, it definitely isn’t paired yet. If it doesn’t power up and simply recharges the battery, it is most likely already paired and configured.

If you let the team know that you’ve had a chat with me on here and tell them about this thread, that will help to explain the situation a bit more quickly. Keep us posted with how you get on. :sunglasses:

Userlevel 7

Hi @Rick1331 - sorry to hear you’re having some issues with your IHD, good news is you’ve found the right place to try and figure this one out!

 

I’ve moved your post over to our Chameleon IHD guide as there’s some great trouble-shooting advice here which could help.

As @Blastoise186 mentioned, a resetting device could indicate a communication issue. It’s worth making sure the IHD is plugged in close to the electricity meter and there’s nothing that could be obstructing the signal. If this doesn’t get things sorted reach out to our Support Team for a full investigation into the issue. 

 

Don’t forget to pop back and let us know how things go - and in the meantime remember you can always check your usage info on your online account or OVO app (download for Android or iOS).

 

Hope this helps! :thumbsup:  

Hi All

just to let you know,  I left it alone last night with the intention of ringing support team this morning and when I got up this morning it was all working again !! 

Userlevel 7
Badge +4

Yay! That’s great news. Thanks for letting us know @Rick1331 .

If you have trouble again, feel free to stop by and I can try to run through some quick troubleshooting steps just in case they fix issues without needing the Support Team to step in. And I’m always happy to make use of the Kecleon Brothers if needed too. :)

My smart meter usually shows £1,50 ish for electric and a few pence for gas each day. This morning I’ve woken up and it’s showing £10.80 for electric and climbing. I’ve got nothing extra switched on. I’m disabled and live on my own. I’m frantic! Any ideas? There doesn’t seem to be a customer services phone number.

Userlevel 7
Badge +4

Hi there @sue4571 .

Uh oh, that doesn’t sound right at all. I can try to advise on this as the Support Team aren’t around on Sundays. They’ll be back in the morning though and you can contact them using the details over here for Live Chat or you can phone 0330 303 5063. Just in case you’re not aware, it sounds like you might also be eligible for the Priority Services Register as well. You can apply for that either via OVO’s website, by live chat or by phone and it’s a free service.

I’m only a forum volunteer myself so I can’t make any changes to your account or access your account directly. But I think I know what might be happening here.

It sounds possible that your meters could be a bit faulty for some reason, especially if you know you’ve not actually been using more than normal. It’s possible to try to diagnose this with a Creep Test for your electricity meter and a Burns Test for your gas meter. I’ve put a link below which can explain what to do.

If you’re unsure though, feel free to let me know and I can walk you through these tests step by step. Please make sure to shut everything down safely before you do any tests though - especially sensitive electronics like your computer.

If you could also post some photos of your meters and In-Home Display in your next reply, that would also be really helpful.

Thanks!

Reply