Solved

Why have my Aclara SMETS 2 smart meter readings reset to 0 on my OVO online account?

  • 28 September 2020
  • 25 replies
  • 2838 views

I’ve had my smart meter (SMETS2 Aclara) for about a year running pretty much flawlessly, however I have just discovered that last week my meter’s electricity reading has reset itself from 1306 (day reading) back to 0. It has also reset the night counter to 0 and the night reading has not increased since then (still 0 after a week). At around the same time my IHD (Chameleon Type 1) stopped displaying any electricity readings. The new readings have been transmitted and recorded by OVO. Can anyone help with this?

Gas meter readings and display on the IHD are totally unaffected.

icon

Best answer by Tim_OVO 30 September 2020, 14:43

View original

25 replies

Userlevel 7

This is an interesting one, thanks for posting and giving such a clear title and description @JP9000 - let’s get on with fixing it!

 

First port of call is to refer to the SMETS2 Aclara smart meter health check here - that will give you a range of options to see if the meter is still communicating with us, and the IHD (WAN and HAN) and will allow you to check the readings (just in case it’s been checked wrong). 

 

Can you do this and leave a comment below with the latest? 

 

Spoiler alert: if you don’t spot anything that might explain this, it’s likely something that’s changed at our end, so our Support team would be the next port of call. 

 

It would be good to hear from you about those checks first though….

Userlevel 7
Badge +3

Fascinating, @JP9000. I always look forward to such innovative/obscure errors to help brighten the day. :sun_with_face:

Can you please tell us here, the flash-rates of the LED indicators on your Communications Hub?

When did the fault occur?

Does it yet show up on your Online Account usage-graphs?

Thanks

Hi @Tim_OVO  and @Transparent,  and thank you for responding.

 

I have carried out your recommended health check and everything seems in order. The LED indicators all flash at a regular 5 second interval (excluding MESH which stays dark).

 

The fault seems to have occurred either 19/09/2020 or 20/09/2020, and OVO are now receiving new readings  starting from 0 and Economy 7 night readings seem to have stopped completely.

 

Here are screenshots of my readings and usage according to OVO. Note 19/09/2020 on the usage graph is displaying a large negative value, and the change in the readings from 20/09/2020 onwards.

 

Userlevel 7
Badge +3

That’s excellent feedback, @JP9000 

I’m very interested to see that you’re getting a large negative reading on electricity. I’ve reported similar errors on gas readings over the last couple of months. You can view my screenshots over here where we’re discussing errors in the presentation of the Billing System.

Your report is not the same as the rest of us are discussing because you’ve actually had the meter reset itself to something akin to the factory-default condition. This should never happen because it suggests it might be possible to alter the memory in the meter, and send erroneous readings to the Comms Hub.

The Smart Meters actually have some hidden anti-tamper devices which send an alert to the Energy Supplier if anyone were to try this.

I confirm that the LED indicators are doing exactly what they should to show that the data communications are functional. The Mesh indicator is off because you have an SKU1 Comms Hub. That is correct.

Whilst we’re looking into this, please be assured that you will not lose out financially due to this technical fault. OVO have enough data to provide very accurate assessment of your true usage on both tariff rates.

 

@Tim_OVO wrote:

Spoiler alert: if you don’t spot anything that might explain this, it’s likely something that’s changed at our end,

I doubt that, Tim. If the physical ESME has set its display back to 0000, then it’s nothing like we’ve seen before. Something has happened within the electricity meter itself.

Worse still, neither the Comms Hub nor your Billing System has performed a sanity check to alert you that the meter has lost all its settings (including the E7 configuration).

I’m assuming your S2 Team will want the meter recovered “as is” rather than attempt to reconfigure it remotely.

Userlevel 7

Updated on 31/03/22 by Jess_OVO

 

This is a strange one! Firstly as the smart meter usage data has also disappeared from your In-Home Display it might be worth carrying out a smart meter health check for your meter type below to help diagnose any communication issues:

 

 

Whilst smart meters are known to lose communication from time to time, isn’t known to reset the meter reading. We’ve checked in with the Smart meter experts who haven’t seen this error reported before, so sounds like you might be experiencing an account-specific technical issue.

 

It’s possible that the meter readings you’ve seen on your online account or OVO app (download for Android or iOS) are in fact estimated rather than actual readings received from the meter. You could confirm this by taking a reading from the smart meter itself, or by contacting the Support Team. Either way we’ll probably have to raise this to our tech team so it’s worth taking a screenshot of the erroneous readings you’ve noticed and emailing this to the team for further investigations.

 

I hope we can get to the bottom of this one quickly for you so you can get back to enjoying the many benefits that smart meters bring:slight_smile:

 

OVO member but not got a smart meter yet? - Book today!

 

Interested but not yet an OVO member? - Check out our plans!

 

Userlevel 7
Badge +3

That’s a very sensible response at this stage.

@JP9000- this is the moment when you need to tell the OVO Engineers all the things that are site-specific so they can start putting together the evidence before pulling your Electricity Smart Meter back into their Test-lab.

Include anything which comes to mind, including detail on things like:

  • roughly how old is the house wiring?
  • photo of each consumer unit (standard and off-peak)
  • does your house have an earth stake?
  • what loads are connected to Economy-7?
  • how do you heat the house?
  • do you have an electric vehicle?
  • what was the weather like on 19/20th Sept?
  • apart from the Smart Meters and IHD has any other electrical device gone faulty or needed resetting?

I hope that’s enough for you to see the type of background information which is useful at this stage.

Tim’s asking for this by email so that you don’t post specifics about your household here on the open Forum. But we’re obviously able to assist if you need anything clarified. Just let us know.

Thanks for all your advice @Tim_OVO and @Transparent.

I have now sent an email with as much information as I could provide. I will keep you advised as things progress.

Update: After 9 days I finally received a first response from hello@ovoenergy.com.

Frustratingly, this response was essentially asking me to go back to square one and do the health check as requested by @Tim_OVO previously. I appreciate they have to start with the basics as part of the process, but it has taken 9 days for them to, essentially, ask me to repeat myself. I tried to be thorough in my original email to avoid this situation (a full explanation and a link to this thread was provided). :expressionless:

Userlevel 7
Badge +3

I wouldn’t regard that level of response as acceptable, @JP9000 

Customer Services is organised in three tiers. I think you should’ve been escalated to a higher level. The response you’ve received is typical of the first-level checks which would be undertaken to ensure that the symptoms are being properly reported.

There’s also the SMETS2 Engineers who tend to have cases referred to them when the symptoms are particularly unusual and require technical analysis. A meter resetting to 0000 is unheard-of, and I would expect the S2 Team to be involved.

Userlevel 7

Update: After 9 days I finally received a first response from hello@ovoenergy.com.

Frustratingly, this response was essentially asking me to go back to square one and do the health check as requested by @Tim_OVO previously. 

 

 

:confounded:

 

I wouldn’t regard that level of response as acceptable, @JP9000 

 

 

Agree! I’ll PM you now, @JP9000 to get some details from you, find the response and pass on some feedback. 

 

In the meantime, I would recommend jumping the queue and calling or using web chat. Find our details here. The info in this thread is enough for a 17 working day ‘faulty meter’ appointment to be booked, with job notes about the issue. Maybe even a case raised alongside this to our Smart ‘second line’ team, to make sure we feedback the issue to whoever it needs to go to, likely the meter manufactures. 

 

 

Userlevel 7
Badge +3

Whether you choose the webchat route or not, @JP9000 please remember that I think this meter needs analysing - not just replacing!

Now I may just be another humble customer, but it really shouldn’t be possible for a meter to have its cumulative readings reset under any circumstances.

This is a potential security loophole, similar to being able to “clock” a car and then sell it for more money as it’s apparently done fewer miles.

The SMETS hardware and firmware has been designed (and tested!) to ensure that the memory used for readings cannot be over-written. The cumulative readings system is the absolute bedrock of providing correct/accurate billing.

However, in this case it’s more serious; there are other protected memory locations which it might also now be possible to over-write. Although I’m not going to expound on this here on a public-forum, there are consequences of doing so which would threaten the energy-supply for the UK.

It is vital that the OVO S2 engineers first test out your meter in-situ, and then recover it for proper investigation. This will need to involve the manufacturers (Aclara and Toshiba, I presume) and the National Cyber Security Centre. NCSC advised on the necessary steps to prevent the UK energy supply being threatened by a malicious 3rd-party actor.

Please do not accept a standard “faulty meter exchange” until we are sure that the S2 Engineers are tracking these meters!

I’ll PM you now, @JP9000 to get some details from you, find the response and pass on some feedback. 

PM response sent. :slight_smile:

 

Whether you choose the webchat route or not, @JP9000 please remember that I think this meter needs analysing - not just replacing!

Now I may just be another humble customer, but it really shouldn’t be possible for a meter to have its cumulative readings reset under any circumstances.

...

Please do not accept a standard “faulty meter exchange” until we are sure that the S2 Engineers are tracking these meters!

I agree! Meter readings should be tamper/fault-proof and this unique situation needs further investigation.

I’ve had a similar issue with my smart meter (SMETS 2 Aclara). It was installed on the 24th of August and was running fine until the 1st of September, when it reset back to 0. The IHD no longer shows electricity information.

Gas meter readings are unaffected and IHD is showing gas information. 

I have carried out the health check and everything seems to be working as expected, no issues there.

The last reported electricity meter reading was 86 units, then it reset to 0 and has started sending readings as if normal. I’ve attached screenshot below from the app.

 

Half an hour view for the 1st of September, no data available from half 12 onwards till 5ish.

 

I’m not sure if this is normal, as it’s not been 6 weeks yet since the meters have been installed. The meter resetting to 0 doesn’t sound normal to me. 

I’ve spoke to customer services and they’ve not been very helpful. Is there anything I should do or this would resolve itself?

 

Userlevel 7

I’d go and press some buttons on the meter to see what it has stored right now, @dmm7 (it’d be worth writing down what it has, even taking photos). FWIW my Aclara SMETS2 meter only displays whole kWh, but fractional kWh are shown on the IHD.

At least, they were a few minutes ago. Perhaps I’d best go and check mine...

Userlevel 7
Badge +1

Howdy @dmm7 ! I think I know what’s happening here. My own electric meter that I call Raichu is an S2 Aclara SGM1411-B and my two IHDs that I call the Kecleon Brothers are S2 Chameleon IHD6-CAD-PPMID so I think I’ve got a similar setup to you. I’m electric-only though, so I don’t have a gas meter. I previously had an S1 Aclara SGM1311 electric meter that I used to call Pikachu before it was replaced with Raichu, so I know how things should work in these cases.

When any electric or gas meter is replaced for any reason, the reading history from the old meter usually gets archived and removed from view in MyOVO once the new meter is registered to your account - and this usually results in the readings starting from zero again, to match the fact a new meter should always start from zero - but MyOVO will do some additional number crunching in the background to make sure you’re still billed correctly by calculating the next bill using the readings from both meters. I will admit that it does seem a bit strange to be seeing what you’re getting there - it shouldn’t normally reset in the way that’s shown in your screenshots because all the old readings from the meter that’s been removed should vanish once the new meter is registered.

In my own case, Raichu started to submit Smart readings exactly 14 days after the install, but the “reset” occurred after just five days (the meter reading history from Pikachu was also archived at this point and removed from view), allowing me to submit manual readings under Raichu’s MSN in the interim. While six weeks is the target, you can sometimes get lucky and it has been known for some Smart Meters to start submitting much faster than that.

It is also known for the incoming data to be a bit flaky during the commissioning process, but it usually settles down afterwards. Most of what you’re seeing appears to be normal, but I agree that it’s a bit strange to see your reading history appear to reset to zero without old readings being archived first.

It can take up to six weeks for newly installed Smart Meters to fully commission, and Smart readings generally should start coming in sometime during that period or very shortly afterwards - and within eight weeks of install at the absolute most. It’s possible that your IHDs might need to be paired with the electric meter again, or it could just be a case that the electric meter isn’t quite ready to talk to the HAN yet. Keep an eye on things for now, just in case. If you still don’t get any electricity usage data on your IHD within the next week or two, the Support Team should be able to take a look.

With that being said, if you go into the app and tap Account > My Meter Readings, you should be able to see the Meter Serial Number (MSN) for both your Gas and Electric meters. Do these match up with the meters you’ve currently got? If they do, then that confirms the meters are correctly registered on your account, but if not it could be that the records are still being updated. This should sort itself out within a few days.

Userlevel 7
Badge +3

Erm… two points:

1: I’m assuming that the ‘reset to zero’ is occurring at the same time when your correct tariff information is downloaded into your Smart Meter. Until that time, your IHD will have been picking up whatever default setting happened to be in that memory location.

Personally I don’t like the concept of resetting a meter to zero. It keeps a cumulative total and it really shouldn’t matter where it starts from. The fact that it can be reset remotely is slightly concerning. Incorrect use of such a feature (by accidental software glitch) could create havoc with our National Smart Meter Network.

Reliability and integrity are more important than having a neat display.

 

2: I fail to see any reason why resetting the display of the electricity Smart Meter to zero could stop the readings being sent to the IHD from the Communications Hub.

I suggest you report this immediately. It’s possibly indicative of a fault in the software signals that pass through the Intimate Communications Hub Interface (ICHI).

ICHI connectors on a SMETS2 meter

OVO can’t ‘see’ what’s on your IHD, only that the Home Area Network (HAN) is ‘live’. You have to tell them if the display is wrong.

Thanks everyone for their prompt replies.

@Blastoise186 I’ll let the smart meter run it’s course for now and see how it behaves in the coming weeks.

@Transparent As far as I remember before meter had reset, it had the correct Tariff information. After the reset I can no longer see the tariff information on the meter. It shows up as 0s or blanks.

I did go through the event log for the meter and found this code: 0x81BC around 05:15 on the 1st of September. I’m guessing an update of some sort must’ve broken something on my end. Can’t find anything online that would shine light on what the code means. I’ll get the meter reported.

In the meantime I’ll be keeping an eye on the smart meter to see how it behaves in the coming weeks. 

 

 

Userlevel 7
Badge +1

No worries. By “reset” what I actually mean is that the Meter Reading History from the old MSN from the removed meter is erased from your view in MyOVO and archived, so that the new MSN from the new meter takes its place and helps to make sure the readings match up with the meter itself. It’s unrelated to any config/tariff downloads being sent to the meters/IHD via SMETS Commands. Apologies for any confusion.

I’ve managed to look up the Event Code you mentioned and I’m a bit puzzled. According to the Aclara SMETS2 User Manual that I have a copy of, that’s a really weird event code to trigger randomly. Feel free to check it out on SmartMe if you’d like to.

Anyway, according to the user manual, 0x81BC is the Event Code for Strong Magnetic Field Removed which is a Non-Critical event that is recorded in the Event Log as well as triggering Alert WAN i.e. sends an alert back to the supplier with the same message that’s in the event log (unless the supplier chooses to disable the alert). I’m not really sure why your meter has generated that log entry, since that’s usually related to the anti-tamper mechanisms and I don’t think you’d have been playing with neodymium magnets near your electric meter at 5am in the morning… Right? Plus, they’d have to be awfully strong neodymium magnets too…

Also, I don’t think it’s possible to remotely reset the registers back to zero either. There certainly doesn’t seem to be any SMETS Commands for it and I don’t think there ever will be, since that could cause havoc if it did.

Userlevel 7
Badge +3

@Blastoise186 - do you think that 0x81BC : Strong Magnetic Field Removed relates solely to the anti-tamper mechanism?

The current measurement could equally well be using magnetic flux. The error codes don’t seem to specify what part of the meter was adversely affected.

Personally I’ve found that obscure error codes are more likely to occur late on a Friday afternoon, just as Customer Services staff are heading off for the weekend. :wink:

 

Userlevel 7
Badge +1

Hard to say really, it could be unrelated. However, given that it is related to 0x8F75 Unauthorised Physical Access - Strong Magnetic Field which lands in the restricted Security Log and always triggers Alert WAN to the supplier (and probably sets off some giant klaxon alarm I guess :joy: ), I wouldn’t be surprised if 0x8F75 triggered first and was then followed up by 0x81BC.

And I fail to see how things like Geomag will trigger it either. Sure, those things do use neodymium magnets, but I don’t think they’d be that powerful!

Userlevel 7
Badge +1

After re-reading the entire thread that this conversation was moved into (thanks Tim/Jess!), I’m in agreement with @Transparent at this stage. It’s the only logical explanation and while I have potential theories on how it could happen, I won’t be revealing any of them for security reasons.

@dmm7 your thread has been moved to this existing one because Tim and Jess managed to locate a previous question that closely relates to your own. Please feel free to read through the entire thread when you get chance, as I think you’ll definitely find it useful. The previous advice given last year is likely to apply to you as well, so you may want to ask the Support Team to investigate - and I would definitely recommend asking them to read this thread as well, so please include a link to it when you contact them.

This seems to be a pretty rare issue though and I’ve never heard of it before today, which is why I didn’t consider it as a possibility. I’ve definitely learnt something, that’s for sure! I’ll try to remember about this one in case it ever comes up again, but I’m hoping it doesn’t.

Userlevel 7
Badge +3

@Blastoise186wrote:

always triggers Alert WAN to the supplier (and probably sets off some giant klaxon alarm I guess :joy: )

The pity is, I don’t think OVO’s internal software takes any action at all when an error code is activated.

In fact, I’m not even aware that OVO retrieve such data from our Smart Meters. It’s possible that they only send the commands to read the usage registers.

Now that OVO Group Ltd have decided on a much greater separation between OVO Energy and the Kaluza division who write the software, it’s even less likely that such feedback here on the Forum will reach the screens of the software developers.

Bizarrely. there are topics here being avidly read by rival Energy Suppliers who freely browse through our discussions and cherry-pick the better customer suggestions. :confounded:

Userlevel 7

Well this is a strange one, @dmm7 - great to see our community detectives giving some great suggestions.

 

 

As far as I remember before meter had reset, it had the correct Tariff information. After the reset I can no longer see the tariff information on the meter. It shows up as 0s or blanks.

 

Might be an obvious place to start but have you tried checking the meter reading on the meter itself to see how this compares to the readings shown on the ‘Meter Readings’ page of the OVO app (download for Android or iOS) - There’s some great advice in reading the meter manually here.

 

If the readings don’t match this is something that you’d need to raise to our Support Team who are able to raise any tech issues or smart meter issues to the relevant teams - might also be worth sending across your smart meter health check results as well so they’ve got the full picture of what could be causing this.

 

Keep us posted of any developments - we’re always keen to hear how smart meter issues get resolved and happy to help further here where we can! :slight_smile:

 

Hi @Jess_OVO 

The meter readings on the app do match the meter itself, so I don’t think there’s an issue there.

I’ve phoned Support but seems like I’m back to square one. I’ve sent details regarding the health check of the meters and also pointed them to this thread. 

Hopefully they get back earlier than 45 days. Don’t think this will get resolved anytime soon.

I’ll keep everyone posted of any updates.

Thanks again everyone for your help.

Userlevel 7
Badge +3

You won’t be waiting 45 days for answers here on the Forum@dmm7  :slight_smile:

The flash patterns for the Smart Meter indicators are shown in a dynamic graphic over in the SMETS2 Installation Tutorial.

Reply