Firmware issue with my Chameleon In Home Display (IHD) and how I fixed it!

  • 24 January 2019
  • 16 replies
  • 3845 views

Userlevel 3
Since we had smart meters installed for gas and electricity last year, we have lost the electricity readings on my IHD twice. The engineer came round and replaced the electricity meter a couple of weeks ago, but the electricity readings stopped again after a few days. OVO have said that it is a firmware problem in the IHD, and a replacement will be rolled out after January.
Wondering if the IHD can be reset to temporarily fix the problem, I pressed the on/off switch and disconnected the charger (My IHD seems to have a battery in it so it works when disconnected from the supply). I then held the on/off switch pressed for some time while reconnecting the charger.
The IHD came up in a reset condition and reconnected to both meters after a minute or two. It is now showing both gas and electricity readings again. So if it fails in a few days, which I expect, I now know how to get it working again. I presume that there is some sort of software overflow problem which works for a time from reset and then fails. It would be interesting to know if this works for others having similar problems. The unit is a Chameleon and it says "type 2" and "IHD3-PPMID / CA30111" underneath

Tony

16 replies

Userlevel 7
Badge +2
Nice work sorting this @tony1tf

Keep a look out for anyone else with this issue!

If I spot one, I'll send them to this topic!

👏
Userlevel 3
Hi @Tim_OVO

Unfortunately this method is not foolproof. I have also found that deleting settings turns off the IHD. When you switch it back on it finds the meter(s). However, for the last couple of weeks it has only been able to find the gas meter, even when a couple of feet away. So I am still awaiting the new firmware hopefully to get round this problem.

Tony
Userlevel 7
Badge +2

When you switch it back on it finds the meter(s). However, for the last couple of weeks it has only been able to find the gas meter.

This topic might be worth a look @tony1tf
Userlevel 3
HI Tim

Ufortunately that reply referred to the older meters. Smect2 don't have a keypad, and the lights are diffetent. Bizarrely, my IHD has started showing gas and electric readings again in the last two days. I wonder if OVO have managed to do an over the air firmware update?
I find that if I unplug my 'connection lost' IHD it makes a great paperweight, about all it's good for!
Userlevel 6
Badge
I wonder if OVO have managed to do an over the air firmware update?

This update was scheduled for the end of January to start of Feb, so it sounds like it's worked!
Sadly the problem persists. We had a new Smect2 meter installed last month. The IHD worked fine for a few days,. then it lost connection with the meter and now just shows "Waiting for current data" and the wifi fan top left blinks.

According to OVO who I spoke to today there is still a problem with the IHDs and there is a 5 week wait for a replacement!

I have tried Tony's method of rebooting but to no avail. Just get the above message.

Pretty disappointing. What is the point of a smart meter if it does not connect to the IHD?

If there is a reboot method that works I would love to hear about it.

Jo
My display is showing my joint usage yesterday as £75.84 but with 65.63 kWh Usage. If my tariff is only £0.15 per unit and £0.036 per kWh how can these figures be anywhere near correct?.
I am having the same trouble with mine says I'm using £15-£20 a day! But when I go to total bill for period it was I've used less than £10... anyone know how to fix this?
I have exactly the same problem, readings in KWH are correct but price is ridiculous. My question is: Is anybody's Chameleon IDH3 giving the correct price for the KWH consumed, I think gas looks about right but electricity is way off.
Userlevel 5
Badge
Hey, @mattbuk33, @Bencie09, and @andyt63 I've moved you collective posts here.

Please check out @tony1tf's post at the top for the answer you need.

Thanks!
My Gas and Electricity Smart meters were installed a week ago and although my monitor was working perfectly for the following 3 days it then lost it's connection. Since then, I've turned it off and on next to the meters and although signal light in the top left hand corner flashes on and off, I still receive no information...does the IHD3 need re-activating by OVO?
Userlevel 5
Take a look at this topic for more info, @brickbrad, let us know how you get on!
Since we had smart meters installed for gas and electricity last year, we have lost the electricity readings on my IHD twice. The engineer came round and replaced the electricity meter a couple of weeks ago, but the electricity readings stopped again after a few days. OVO have said that it is a firmware problem in the IHD, and a replacement will be rolled out after January.
Wondering if the IHD can be reset to temporarily fix the problem, I pressed the on/off switch and disconnected the charger (My IHD seems to have a battery in it so it works when disconnected from the supply). I then held the on/off switch pressed for some time while reconnecting the charger.
The IHD came up in a reset condition and reconnected to both meters after a minute or two. It is now showing both gas and electricity readings again. So if it fails in a few days, which I expect, I now know how to get it working again. I presume that there is some sort of software overflow problem which works for a time from reset and then fails. It would be interesting to know if this works for others having similar problems. The unit is a Chameleon and it says "type 2" and "IHD3-PPMID / CA30111" underneath

Tony
Hi Tony just read your post regarding the IHD “freezing” as my IHD did the same last night followed your remedy & it worked ok this morning so everything crossed.Thank you for sharing that information.👍👏😊
Userlevel 3
Hi @Barney

You were lucky. My IHD reset only worked for a while - have had many more problems, as discussed in this thread, but after the last meter install and firmware upload all is still OK:

https://forum.ovoenergy.com/smart-meter-booking-and-installations-66/smart-meters-not-worth-the-pain-6858/index3.html#comments

Tony

Reply