Solved

Would my smart meters cause interference with my wi-fi signal?

  • 27 November 2018
  • 9 replies
  • 14699 views

I use a Sony smart tv to view BBC I Player. It used to perform without a problem. Since having a smart meter fitted a month or so ago it continually disconnects from my hub at about 25 minute intervals particularly in afternoons. I understand the smart meter sends messages via ( it’s own Wi-fi ) at this sort of time period.
Has anyone else had this sort of interference. My Tv connects using the 2.4 kHz frequency from my hub.

icon

Best answer by NinjaGeek 27 November 2018, 14:41

Updated on 03/02/21 : The info in this update was provided in this topic thread:

One issue which might occur when you have a Smart Meter installed is poor WiFi performance. Sometimes it can fail altogether.

WiFi can operate in two frequency bands. The earlier standard, still most commonly used, is called IEEE 802.11b and runs at 2.4GHz. The same frequency is used for other wireless domestic products such as door-bells and some remote controls. However, the software protocols for all these devices is different, which is why there is little perceptible interference when two or more are operating simultaneously.

The Zigbee network which connects your Smart Meters and your IHD is another 2.4GHz standard, properly referred to as IEEE 802.15.4.

Unlike doorbells and remote control units, both WiFi and Zigbee are continuously live. Whether they clash or not depends on the channel number which each one uses.

In the UK, WiFi is assigned 11 overlapping channels. In order to avoid degradation of the signal, we normally employ one of channels 1, 6 or 11 because these have no overlap. You can select this manually by logging into your router.

 

c9d98958-13dd-462f-a6c6-8fece827ad24.jpg


Zigbee has 16 channels, which carry much less data and can therefore be non-overlapping.

In the USA there is a convention that any new Zigbee device will be configured to use either channel 15 or 20. These have frequencies which neatly sit in-between the commonly-used WiFi channels.

In the UK there is no such convention, and it's possible that a Zigbee device could use any of the allocated channels. So if your router happens to be sited close to your new SMETS Meter, there is the opportunity for interference to occur.

All is not lost however. Firstly, you could login to your WiFi router and change the channel it uses.

Failing that, Zigbee itself has an inbuilt Channel Agility. Once it recognises that its frequency has a sufficient level of interference that data is being lost or corrupted, then it will switch to an alternative channel.

This process isn't immediate. Both of your SMETS Meters and the IHD will all be using the Channel Agility protocol to find a common channel which suffers least interference. It might take an hour or so before everything gets sorted. In the meantime, don't switch off your WiFi router because this will halt the automatic Agility process. When the router is next re-powered, the interference will start all over again!

Note that there is nothing which OVO's Installation Engineer can do about such problems beyond noting on the job-sheet that WiFi was lost when the Smart Meters were powered up. Zigbee self-allocates channels (eventually) and the Installation App doesn't have a facility for manual channel selection.

Nor are Installers trained or permitted to start logging into your router and manually changing its channel. And you should have it password protected anyway!

 

Not got an OVO smart meter fitted yet? Here’s the S2 smart meter booking platform. You will need your account number, which you can confirm on your online account. If you’re not yet an OVO member, check out our plans and sign up online here

 

Very odd, I have never known this to be an issue. What router do you have?

2.4Ghz isn't that great as a lot of devices now depend on the frequency, You could try splitting the frequency between 2.4Ghz and 5Ghz and connect the TV to the 5Ghz frequency. Or do what I do and plug the TV straight into the router by purchasing powerline adapters which you can buy from Amazon or PC world.

View original

9 replies

Userlevel 7
Badge +2

Updated on 03/02/21 : The info in this update was provided in this topic thread:

One issue which might occur when you have a Smart Meter installed is poor WiFi performance. Sometimes it can fail altogether.

WiFi can operate in two frequency bands. The earlier standard, still most commonly used, is called IEEE 802.11b and runs at 2.4GHz. The same frequency is used for other wireless domestic products such as door-bells and some remote controls. However, the software protocols for all these devices is different, which is why there is little perceptible interference when two or more are operating simultaneously.

The Zigbee network which connects your Smart Meters and your IHD is another 2.4GHz standard, properly referred to as IEEE 802.15.4.

Unlike doorbells and remote control units, both WiFi and Zigbee are continuously live. Whether they clash or not depends on the channel number which each one uses.

In the UK, WiFi is assigned 11 overlapping channels. In order to avoid degradation of the signal, we normally employ one of channels 1, 6 or 11 because these have no overlap. You can select this manually by logging into your router.

 

c9d98958-13dd-462f-a6c6-8fece827ad24.jpg


Zigbee has 16 channels, which carry much less data and can therefore be non-overlapping.

In the USA there is a convention that any new Zigbee device will be configured to use either channel 15 or 20. These have frequencies which neatly sit in-between the commonly-used WiFi channels.

In the UK there is no such convention, and it's possible that a Zigbee device could use any of the allocated channels. So if your router happens to be sited close to your new SMETS Meter, there is the opportunity for interference to occur.

All is not lost however. Firstly, you could login to your WiFi router and change the channel it uses.

Failing that, Zigbee itself has an inbuilt Channel Agility. Once it recognises that its frequency has a sufficient level of interference that data is being lost or corrupted, then it will switch to an alternative channel.

This process isn't immediate. Both of your SMETS Meters and the IHD will all be using the Channel Agility protocol to find a common channel which suffers least interference. It might take an hour or so before everything gets sorted. In the meantime, don't switch off your WiFi router because this will halt the automatic Agility process. When the router is next re-powered, the interference will start all over again!

Note that there is nothing which OVO's Installation Engineer can do about such problems beyond noting on the job-sheet that WiFi was lost when the Smart Meters were powered up. Zigbee self-allocates channels (eventually) and the Installation App doesn't have a facility for manual channel selection.

Nor are Installers trained or permitted to start logging into your router and manually changing its channel. And you should have it password protected anyway!

 

Not got an OVO smart meter fitted yet? Here’s the S2 smart meter booking platform. You will need your account number, which you can confirm on your online account. If you’re not yet an OVO member, check out our plans and sign up online here

 

Very odd, I have never known this to be an issue. What router do you have?

2.4Ghz isn't that great as a lot of devices now depend on the frequency, You could try splitting the frequency between 2.4Ghz and 5Ghz and connect the TV to the 5Ghz frequency. Or do what I do and plug the TV straight into the router by purchasing powerline adapters which you can buy from Amazon or PC world.

Thanks for reading my issue and taking an interest, my router is BT Homehub 5. My key point is that for the last 5 yrs my system has operated very well with only the odd disconnect. Only in the last month after the installation of my N Power smart meter has these half hourly disconnects started. ( just happened 10 mins ago. ) asking my self the obvious question, what has changed I conclude it is the Smart Meter.
Anyway the purpose of my post was to see whether other people have any problems. If BT, SONY and the BBC can’t find another explanation I would sooner have the smart meter removed than resort to the impracticality of hard wiring.
Userlevel 7
Badge +2
@kkennethdunn Or it could be a coincidence. There could be an issue on your line? If nothing else appears to be disconnecting or lights flicking. Then I would think it has nothing to do with the Smart meter.
Userlevel 7
Badge +4
I have an update to this story. When I was at a mate's house this afternoon, an OVO engineer was fitting electricity and gas SMETS2 meters.

Once he completed the process of getting the two meters and the IHD communicating with each other, we noticed that the WiFi was no longer operating.

I checked the WiFi signals using an Analyzer on my phone, and this confirmed that it was indeed still transmitting signals on the relevant band-6 of the 2.4GHz frequency.

We tried resetting the Sky router a few times and it became apparent that it was possible to use the WiFi for almost 1 minute, and then communications failed again. That makes me suspicious we may be seeing interference from the electricity meter transmissions using Zigbee protocols on the same 2.4GHz frequency.

Unplugging the IHD had no effect (as I had expected).

The OVO engineer was very good about this. He confirmed that the loss of WiFi had only occurred once he instigated the Zigbee links using his OVO "O2" App. He obviously isn't authorised to sort out a customer's router(!) but he stayed on-site about 30 minutes whilst the three of us tried various combinations and attempted to login to the router using a wired connection.

About an hour after the OVO Engineer left site, the WiFi then started operating ok... following what was probably the 10th reset/re-boot.

I know that the engineer has flagged up the problem with his OVO team back in Bristol, which may yield some further insights. But I thought I'd better put something here so that @ITGeek123 and others can propose some theories as to what's happening.

Remember, this is a SMETS2 installation - the 14th one which this engineer had done. The SMETS2 meters are manufactured by Aclara (no longer by Secure) and this may also have a bearing on what happens during the commissioning process.

And the electricity meter on that site was less than 1 metre from where the router was positioned with a thick (Devon stone!) wall between them. This may be relevant.

[Can @Tim_OVO or @Darran_OVO please flag up this posting to the Meter Installation team? You can give them my direct contact info if they want to ask further details about the symptoms. Thanks.]
I read the above with interest as I had a SMETSv1 Liberty 100 meter installed earlier this month and ever since then have had big problems with interference across all 2.4GHz channels, in a network which was stable for many months. 5GHz is unaffected but not all our devices support it.

The Liberty 100 uses ZigBee and I wonder whether there is some per-unit configuration which can cause interference. However it's hard to prove whether the source of the interference is the meter, as it is of course always activated!
Userlevel 7
Badge +4
I've done some online searches this morning. There are other community forums reporting similar problems... but not many of them. I deduce that the problem of interference can occur, but it's rare.

There was an interesting solution from a customer here on this BT Forum. He configured his router to use Channel 5 instead of 6. Now that's very marginal, and the recommended WiFi channels are 1, 6 or 11 to avoid overlap with other channels from nearby routers. So if it'd been me, I'd have moved well away from Channel 6!

Let's not immediately put all the blame on the Smart Meter's Zigbee. There are some pretty poor routers being installed, and some could be particularly susceptible to interference than others.

Nevertheless, it is clearly a problem which OVO will now need to investigate because it's going to affect the on-site time being spent by their Installers. Yesterday, it meant that the engineer had to cancel his last job of the day.

There's a more in depth article here which describes how Zigbee (properly called RF4CE) is normally configured to use frequencies which avoid channels 1, 6 and 11 of WiFi. Interestingly, the author points out that channel selection conventions used in the USA may not apply elsewhere in the world.

Might yesterday's problem be related to OVO having changed from using Secure Smart Meters to Aclara, which is a US Company?
Userlevel 7
Badge +4
I have now written a more substantial explanation of interference between SMETS Smart Meters and WiFi operating at 2.4GHz which can be found here.

As @essayer rightly points out, the 5GHz WiFi frequencies are unaffected.
Userlevel 7

Hi @Transparent 

 

I’ve actually taken your comment from this topic, and added it to @NinjaGeek’s best answer. 

 

I’m not sure if any of the advice is different now, what with the roll out and upgrade of these smart meters to DCC, but I doubt it. Let me know what you think...

Userlevel 7
Badge +4

There’s no change in the advice at this stage because we’re still talking about WiFi running at 2.4GHz which is the same as Zigbee uses.

We will need to provide additional advice/comment once we start seeing Communications Hubs being installed with an additional Zigbee band at 868MHz. That is better at passing through obstacles, but has the potential for interference with other devices (not WiFi).

Reply