Dual electricity rates not visible on IHD

  • 23 March 2024
  • 4 replies

I have a GEO TRIO Touchbutton IHD connected to my smart meters. My tariff involves both day and night rates for electricity but I am unable to figure out how to see the different usages and meter readings for these on the IHD - I can only see a total electricity usage.

I can see the two different rates directly on the smart meter and they are also visible on my on-line account. They are just not visible on the IHD - I’ve tried getting OVO to rectify this but no success so far. Any had a similar problem?


Best answer by Firedog 23 March 2024, 20:21

View original

4 replies

Userlevel 7

Join the club. My Chameleon IHD3 only shows the total, not the two registers like my dear old Secure Pipit 500 used to. What I get is

  • IHD: Total Import reading to 3 decimal places;
  • Meter: Both registers and total, but in whole kWh only.

I have to wait until the day after and then check my meter readings history to see the register readings with any precision. It’s infuriating.

Perhaps @Blastoise186 knows whether any of the current IHDs have this capability.


A bit later …

I just looked up the manual for the Trio Ⅱ (Touch Button) and see that the Meters information panel shown on page 20 has a second tab labelled Tiers.

Do you see this on yours? Tiers is the name often used for the different registers, so this may be what you’re looking for. It’s possible that this was a feature added to the Trio Ⅱ model.

Thanks for the input Firedog - have looked on my IHD and there’s no “Tiers” option on my IHD on the “Meters” screen - it just shows :

  • Import Reading
  • Export Reading
  • Meter Type
  • Status
  • MPAN

The import reading appears to be total electricity usage.


Userlevel 7

OK, so it sounds as if you’re in the same boat as me - no readings for the individual registers. Grin and bear it, I’m afraid, unless you’re willing to shell out for a superior device: Sourcing a replacement In Home Display (IHD).

That’s what I was afraid of ……

Thanks for your help anyway!