Why have I lost the yearly view and comparisons on my online usage graphs?

Userlevel 1
  • Carbon Cutter***
  • 4 replies

From day one with OVO I have been able to see annual data and comparisons, rather than daily useage.
It would appear that this functionality has been removed in preference for daily data returned by smart metres. I for one am not intending to micro-manage my energy consumption and am happy to check long term deviations and so spot increasing annual costs so I can budget accordingly.

When questioned I am told this is probably due to issues at my end - wrong browser, clogged cache, and so on. Nonsense.


You tell me that by clicking on usage that the options to see year on year comparisons should appear - they do not.


When I go to the help centre and ask for my annual statement there is a check your yearly energy use box, which when clicked on re-routes me back to my monthly energy use in and endless loop.


So broken links?
Update issues?

Is this something other folk are having issues with?

What was a first rate site seems to be having issues with the latest update and basic functions either broken or deliberately removed … 



Best answer by Jess_OVO 2 June 2021, 13:04

View original

55 replies

Userlevel 7
Badge +1

Howdy @MBA !

Sorry about that! There’s been a known bug recently which did accidentally break the comparison features for a few members. The team has managed to fix it for most members but it sounds like the technical gremlins have managed to escape again. I’ve given @Jess_OVO a shout to see if she can flag this up with the team. Hang in there for a bit and hopefully this can be fixed for you shortly.

It’s worth remembering that MyOVO is custom built in-house by OVO’s own developer team and is constantly evolving unlike most suppliers. While it usually gets better, sometimes the odd bug sneaks in. Apologies for when they do! Forum volunteers like myself are always happy to help though with getting these reported. :)

Userlevel 7

Hi @MBA and welcome to the OVO online community!


Sorry to hear you’re having some issues with the yearly view on your online usage graphs. 


As @Blastoise186 has mentioned we have had a few other users report issues with these recently, although not this exact issue. When accessing the usage page on your online account, there should be the option to switch between yearly, monthly and daily view using the tabs at the top of the screen -


Exact appearance may vary


Really sorry to hear you’re not currently able to access the annual view. Do these tabs not show on your screen or are you seeing an error message or no data when you click on the ‘year’ view?


Would be really helpful if you were able to send over a screenshot to help us work out what’s going wrong and flag this one to the team. :slight_smile:

I also don’t see the tabs to switch between annual, monthly or daily when I request Usage.

Userlevel 1
My image differs from yours in that the three options simply don’t appear
… and it seems that I’m not alone?
There seems to be a load of struck out lines of code related to this bit - tried all the usual things and both the browsers I have respond identically.
The gremlins are at it again.


Userlevel 1

PS nor can I access the annual usage page - as mentioned before.

Userlevel 7
Badge +1

Thanks for letting us know!

I’ll see if I can dig into this using my own account over the weekend. If I can figure this out, I’ll write this up as a bug report on this thread and ask Tim or Jess to pass it back to the team.

It’s possible that there’s some A/B Testing going on where some members get one view and other members get the other - but even then all features should be available in some form.

Hang in there and I’ll see I can do some sekrit magic. :)

Userlevel 7
Badge +1

By the way @MBA , I can’t say for sure but it looks as if you might be using an unsupported setup when trying to access MyOVO.

While it looks like you’re using a modern and up-to-date version of Firefox, it looks like you’re either using Windows 7 with Classic Theme or something older. Some websites may break when accessed in this way and Windows 7 isn’t supported by Microsoft anymore. However, since Mozilla still seems to support Windows 7 right now, that’s good enough for me. It might be worth considering an upgrade to Windows 10 or switching to Linux in the future though. :)

I’ve got access to Chrome, Chromium, Firefox and Edge across a few different Windows 10 and Ubuntu Linux machines. If I can reproduce the same issues on those then I’m happy to call it valid even on Windows 7.

I can also verify that the Yearly page is not available for me, however I can reach it via the new tabs. This suggests that either there’s A/B Testing going on right now, or some new changes that are being slowly rolled out and haven’t yet been made available for everyone.

My guess @darkness is that you could either be on the group who won’t see the new view during the test or the rollout hasn’t reached you yet. I can’t say for sure and I’m not able to confirm any of my theories as I’m only a forum volunteer. However, as this does seem like a possible bug, I’ll write something up shortly. :)

Userlevel 1

You are absolutely right about using a workstation using Windows 7 - but this is irrelevant, as is why I use this on a dialy basis, (it works, is paid for, legacy programs and hatred of Windows 10, amongst other things) but would suggest that any site upgrade should be 100% campatible.

However, this doesn’t seem to be a compatibility issue.

I have just looked at the site on a new Windows 10 running workstation used for video editing (ie up-to-date and powerful) and find exactly the same issue appears on both Chrome and Firefox.

It appears still exactly the same as per screen shot sent.

I haven’t tried any of the 6 other laptops and tablets we’ve got.

So sorry back to you to find the bug!

So machine an OS isn’t the cause?


PS: There also seems to be an issue with logging in and password recognition … but let’s sort the usage graphics first!



Userlevel 7
Badge +1

No worries, totally understandable. It’s just something I tend to mention in case people don’t know. There can sometimes be weird quirks that cause issues in particular versions of something that don’t exist in newer (or sometimes older!) versions but generally if I can pull off the same bug across Windows 10, Android and Ubuntu/Debian on several browsers, I definitely consider it valid. OVO’s website shouldn’t break just because of Windows 7 unless you’re using Internet Explorer (which is definitely not supported!), but sometimes weird quirks about Windows 7 can mess things up. :)

So while OS stuff can sometimes cause issues, it doesn’t look to be the culprit this time.

I’ve so far been able to verify the issue using Swampert, so I’ll write this up real quick. I’ve not had chance yet to try out my other devices, but one test from me and a bunch from other members is definitely plenty to get started. Once Tim and Jess are back, I’ll ask them to feed it back to the teams.

So… Let’s get the show on the road...

What’s the problem?

The option to get to Yearly usage from the sidebar doesn’t work when MyOVO is on the new tabbed view

How can I make it happen?

  1. Login to MyOVO with an account that’s got the new tabbed Usage views
  2. Click Usage from the sidebar
  3. Click Yearly from the sidebar

What should happen when I do this?

I should be able to get straight to my Yearly Usage data

What happens instead?

I get redirected to Monthly and have to click Yearly from the tabs. In some cases, it’s impossible to use either method to reach other views

Is there anything else that may be useful to know?

Yes. This report is based on a forum thread over at 

 so please check there for more details.

In addition, Blastoise186 has verified the report from @MBA and @darkness using Swampert with Windows 10 Home 21H1 64-bit and Google Chrome Version 91.0.4472.77 (Official Build) (64-bit) with User Agent:

Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/91.0.4472.77 Safari/537.36

It’s also reported to affect Firefox on Windows 7 and Windows 10 as per the forum thread and will be verified shortly.

As an update to the above, this bug is further verified using Stunfisk on Windows 10 Pro 21H1 64-bit with Google Chrome as above, Microsoft Edge Chromium Version 91.0.864.37 (Official Build) (64-bit) with User Agent:

Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/91.0.4472.77 Safari/537.36 Edg/91.0.864.37
Internet Explorer mode is disabled on this User Agent and Browser.

Further verified using Stunfisk with Mozilla Firefox 88.0.1 (64-bit) with User Agent:

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:88.0) Gecko/20100101 Firefox/88.0

And finally, verified on Magnetmite with Ubuntu Desktop 21.04 Hirsute Hippo 64-bit on Wayland with GNOME Desktop Environment 3.38.5 with Mozilla Firefox 88.0.1 (64-bit) and Chromium Version 91.0.4472.77 (Official Build) snap (64-bit) with User Agents:

Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:88.0) Gecko/20100101 Firefox/88.0

Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/91.0.4472.77 Safari/537.36

Please ignore the references to X11 in my User Agents. I am actually using Wayland rather than X11 but I guess User Agents don’t really show it yet!

And the final verification was done using Totodile with Google Chrome 90.0.4430.210. Full details are in the User Agent below. I couldn’t test this one using the OVO Energy app as this bug only affects MyOVO.

Mozilla/5.0 (Linux; Android 11; SM-A705FN) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/90.0.4430.210 Mobile Safari/537.36

Additionally, there’s possible indications of active A/B Testing or a recent deployment to MyOVO which may also be interfering with the Usage features and causing missing data. Please see the forum for further info on these

Userlevel 7
Badge +1

Well, there is definitely something going on here and I think I can pull off a few more bugs out of this later. Which is good for me because I’ve been running low on supplies recently!

This is the problem when you’re like me and literally mine out basically every possible bug in OVO’s stuff faster than the Tech Team can keep up with me and faster than the developers can release new features! Blastoise problems obviously, rather than real world problems… :stuck_out_tongue:

I think I know a possible fix as well, but it’s not necessarily as easy to recommend as you might think as I don’t want my fix to break repeatedly. Leave it with me and I’ll break out Totodile, my ultimate bug blasting gadget and I’ll have a think about this.

Userlevel 7
Badge +1

As expected, Totodile smashed it right out of the park and was definitely the easiest reproduction so far. Totodile is the nickname of my phone. The device specs are already known to OVO which speeds things up too.

In this case I'm using Totodile with Google Chrome 90.0.4430.210. Full details are in the User Agent below.

Mozilla/5.0 (Linux; Android 11; SM-A705FN) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/90.0.4430.210 Mobile Safari/537.36

At this point, I've now confirmed the issue exists on basically every non-Apple platform and my theory will be written up in the morning. Good luck!

Userlevel 4

I have the same issue. These console errors may help.


I’m using W10 2021H1, Edge current.

Might also be worth noting that I run AdGuard for Windows with browser integration.

Userlevel 7
Badge +1

Heya @knight !

Ooh! Thanks for that! This stuff can prove really useful!

I don’t think most of those Console messages are relevant in this case other than the two yellow Warn level ones. Although I use AdBlock with Google Chrome on Swampert, I have ways of making sure it doesn’t get in the way of my bug hunting and all my other devices are completely vanilla states which means that nothing can interfere at all.

It seems as if something unrelated might be messing up your internet connection somehow as you shouldn’t be getting most of those red Error level messages. Are you maybe using something like a PiHole to sinkhole stuff by any chance? It shouldn’t cause MyOVO to break as long as you don’t sinkhole any of OVO’s domains.

EDIT: Ohhh ok. I see. AdGuard for Desktop is acting like a PiHole, that explains it. But yeah, as long as it’s not blocking any OVO domains it shouldn’t get in the way. I personally use my UniFi Dream Machine for that job. :P

I’ve quickly reviewed those messages and compared them to what I’ve been getting, I suspect they’re mostly unrelated except for the yellow Warning messages but if you’re seeing the issue as well, that’s another confirmation of the bug. Can you grab your User Agent for me please by any chance? It might come in useful. :)

The easiest way to get hold of that is to simply Google What is my User Agent? and you’ll see it right at the top of the results. If you’re OK with sharing that, it’ll definitely help a lot. Don’t worry about leaking private info, User Agents never reveal anything that can identify you and they only contain basic device info at most.

Tim and Jess should be back in the morning, so I’ll ask them to feed everything back to the Tech Team who were looking into the issue.

Userlevel 4


It seems as if something unrelated might be messing up your internet connection somehow as you shouldn’t be getting most of those red Error level messages. Are you maybe using something like a PiHole to sinkhole stuff by any chance? It shouldn’t cause MyOVO to break as long as you don’t sinkhole any of OVO’s domains.


Well, AdGuard is a very powerful and handy tool. In fact, it is so good, I paid for a family membership. So yes, using AdGuard for Windows provides OS level filtering of unwanted endpoints such as Google trackers :sunglasses:

That’s why I mentioned it as you are correct that the errors on things like Google analytics are because of it. But no, I’m not filtering anything to actually do with Ovo sites so it shouldn’t have any impact.


My user agent is:

Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/90.0.4430.212 Safari/537.36 Edg/90.0.818.66



Userlevel 7
Badge +1

Haha, nice one! I just like to go totally overboard and block that stuff across all my VLANs at once. I’ve literally made it so that anything on ANY of my VLANs that tries to phone home to Facebook or Zoom gets sinkholed immediately, cuz I don’t trust either of them. But my solution is clever to the point where all that stuff gets Connection Refused instead of 404. Let’s just say that the Suricata IDS which Exploud uses for this purpose is… Powerful stuff…

Apparently it’s also blocked about 37mb of Facebook traffic in the last 24 hours too. Mind you, I have also managed to burn through 36.1GB of of total traffic so far today alone and about 219GB of traffic in the last month...

Yup, that User Agent looks good to me. You’re ever so slightly behind on the updates but not by much - I always allow a 14 day grace period to catch up - but Edge Chromium 90 is close enough.

Shouldn’t take too long to fix (hopefully!).

Userlevel 4

Thanks @Blastoise186 , yes there is an Edge update waiting but I’ve had too much on to want to reboot, especially as I had some “fun” updating Windows and Office recently.


I can’t really think of anything you would be doing with the Ovo website though that would make a difference even if I were a year behind. I would hope that the website is written for the widest possible coverage. Indeed, I might expect even IE11 support for a commercial brand. Though I’d certainly give you a “let” for that if you didn’t support it :grinning:

I’ve at least now got the app working after it broke itself a few months ago (actually probably 6-10). Now that I’ve removed it and re-installed it is working again.

Anyway, thanks for the responses and I’ll keep an eye out for the update.

Userlevel 7
Badge +1

You’ll be amazed at what forum volunteers can do. :blush:

Hehehe, the internet changes a LOT you know. And here’s the snag with Microsoft Edge. There’s at least, like… THREE different versions of it!

You’ve got the original Edge Legacy (aka IEdge) which first launched with Windows 10 1507 (aka the day Windows 10 first became a thing) which I kid you not… Was just Internet Explorer with a fancy skin over the top and it still effectively used the Trident and EdgeHTML engines making it IE12 effectively. I’ll probably refer to that one as IEdge in the future, since it’ll be easier for everyone else to know which one I’m refering to.

Then you’ve got the second Edge Legacy sometimes known as Edge 17 which I think came out with Windows 10 1809(?) (correcting myself, it’s actually Windows 10 1803 where Edge 17 first debuted and where it was still primarily using the EdgeHTML engine for the most part) which is the one where Microsoft started to transition to the Chromium engine, but was still very much the same Edge Legacy as before, just with very minor changes. When I refer to Edge Legacy going forward, it’ll be this one in most cases.

And then you’ve got Edge Chromium which is the new Edge that actually runs on the Chromium engine, but can flip back to Trident/EdgeHTML if you really want it to by using Internet Explorer Mode - not that I’d recommend it because you’d also bring back all the nightmares of Internet Explorer! Any references I make to ChrEdge from now on are in reference to this one.

I kinda wish Microsoft had renamed Edge when they rebuilt it as Edge Chromium (or ChrEdge as some people call it). But I guess marketing wins that battle… Again…

Anyway, the User Agent is basically one of the easiest ways for me to not only know what version of Edge you’ve got, but also which Edge you’ve got - IEdge, Edge Legacy or ChrEdge (and that you’re not using the latter with a global Internet Explorer Mode enabled somehow). :rofl::stuck_out_tongue:

My understanding is that OVO considers ChrEdge as a supported browser (provided you’re not using Internet Explorer Mode) based on the use of the same Chromium engine that’s used by Google Chrome, Chromium, Brave, Vivaldi, Samsung Internet, Opera and a few others. My stance is that if you break MyOVO using ChrEdge and I manage to reproduce it in Chrome or Chromium, I will always tag it with my approval as well.

As for Internet Explorer support… Umm… Not sure about that as I don’t work for OVO and I don’t know the official policy on this one. Let me play a Joker Card there and get my minions (aka the OVO Social Media Team) to do the research for me. :joy:

It’s possible that OVO tries to support IE with their stuff, but it’s likely a low priority and I wouldn’t be surprised if any IE-specific bugs get pushed to the back of the queue. With that being said, I’m still happy to assist members with reporting such bugs anyway - subject to the opinions of Tim and Jess who make the final call about whether it would actually get submitted - but I’d also generally recommend affected members try other browsers. If I can reproduce the same issue in one or more supported browsers though, then yup. I’ll definitely ask for it to be escalated.

However, it’s worth bearing in mind that Internet Explorer is a dead browser anyway that’ll be killed off in just over a year from now and no-one really uses it much anymore. It’s also kinda less of a factor of whether OVO is prepared to support IE and more of a case of whether IE will support modem stuff like MyOVO. I personally don’t bother with spending any time creating custom IE hacks for my websites just to get a dead browser to behave on my own sites because I know that no-one uses it to visit them. If it works, great. But if you can’t use my sites in IE and I find it’s working fine in all modern browsers, I’ll simply come back and ask you to use something that’s not IE. I’m just no longer willing to spend that much time fixing things that only affect dead User Agents. :wink:

As for the app though @knight I can safely say that OVO definitely appreciates any and all bug reports related to the OVO Energy apps, especially if they’re raised via the forum (you can go via support as well, but the forum is a little easier)! It’s been one of my focus areas and I can definitely say with full confidence that some of the recent improvements to the app are a direct result of the efforts of myself and other members on this forum - especially SimonD and TomThumb who come to mind pretty quickly!

If you do spot more issues, we’ll definitely be happy to take a bug report from ya.

You’ll have probably noticed for example that it no longer randomly restarts itself and boots you out while you’re using the app. That’s probably one of my best catches to date although it did cause another bug - the dreaded “spinning circle” one. Please feel free to blame me for that one, it’s kinda my fault that I didn’t consider that flaw in my ingenious solution! I’ve since found a fix for that one and it’s currently being considered. I just hope I won’t need to find a fix to fix the fix that broke the fix which fixed the thing that was originally breaking the app and randomly booting members out! (Phew!).

Userlevel 7
Badge +1

BLAM! My sheer genius has allowed me to track down a possible root cause as to why the Yearly buttons on the sidebar don’t work as expected on the new tabbed view, and I’ve also got a suggested fix too.

Given that Monthly seems to work fine in all cases, it looks like the bug with this one is related to where all the links lead to. I can understand why it’s like this if there’s A/B Testing going on and one of the two sides still has the legacy view though, since you don’t want that to break!

However, the bug seems to be related to the fact that in the new view, the Monthly option in the sidebar always initially pulls up the current month (or the previous/most recent month where data is available if there’s no data for the current month yet). Some clever magic seems to dynamically update that link automatically to match the current month whenever the date rolls over. However, Yearly still points at the old URL and this one redirects to Monthly right now in the new view. So in effect, Monthly will lead you to Monthly as expected, but Yearly currently leads to Monthly via a redirect. Easy fix though.

There definitely seems to be logic that’s been applied to Monthly for this, so the fix would simply be to apply the same logic to Yearly - but with a very slight tweak that points at the current year rather than the current month. 30 second fix perhaps?

I don’t know when this fix might be able to go live as it depends on whether anything else might break. But I’ll definitely leave my thoughts here just in case they’re useful. :)

Userlevel 7

Wow - thanks for some really detailed bug reporting there - @Blastoise186, @knight and @MBA :bug: !


I’ve sent the team a link to this thread as you’ve explained the issue better than I ever could, so will pop back once I’ve got an update. 


Hope we can get this pesky issue resolved soon for your all!

Userlevel 7
Badge +1


It’s hard to say if this one’s a bug report or a feature request, so I guess it’s time for a hybrid!

This is related to the thread below, please check there for more info - I’ll also be posting a link in that thread which leads back to this one as well due to them being related.

One thing I have noticed is that the one-at-a-time arrow clicking method in the new Usage views is great for rapidly jumping from one year to another, but it really doesn’t work that well if you want to jump between days or even several jumps in one go. I can use hax to get around it by fiddling with the URL to punch in exactly what I want, but it’s not ideal to fast-jump that way.

It would really help if there were additional options added that would allow me to jump more than one step at a time both in MyOVO and the OVO Energy apps, especially to reduce fatigue from repeatedly clicking the same thing and to reduce server load a little.

Ideally, it would be great to have these added alongside the existing options, so that it preserves backwards compatibility and maintains the ease of rapidly jumping forwards and backwards one step. But a more rapid option for larger jumps would be nice!

Userlevel 7
Badge +1

Haha, they’re gonna love this thread then!

I’ve actually just posted something related too, so just in case I’m fast enough here’s another relevant thread that’s worth a look.


Userlevel 4


However, it’s worth bearing in mind that Internet Explorer is a dead browser anyway that’ll be killed off in just over a year from now and no-one really uses it much anymore.


I’m afraid that is far from true for enterprise environments - and many people use work PC’s for personal use as well. There is no end-date for IE11 for enterprise versions of Windows 10 as yet and it will be supported for as long as Windows versions that originally included it are still under support.

And yes, despite the best attempts from people like myself at getting it deprecated, it is still in use I’m afraid.

But hey, lets not get too hung up on this. My comments were really aimed at saying that commercial organisations generally want to have the widest customer reach and so will generally err on the side of caution when it comes to supported browser versions unless they want to loose customers.

Sticking to well-recognised standard versions of JavaScript is the best approach of course and even IE is reasonably good at supporting that up to a point. Thankfully, Apple have gotten rather better at this as well recently. So using a version of JavaScript standards from a few years back is a good way of maintaining compatibility. Polyfill libraries can also help plug some gaps if needed.


Anyway, great to see a community forum being well used and hopefully the problem will be easy to fix.


A good community forum goes a long way towards customer satisfaction. Though I should say that I’ve never joined before because I’ve never needed any support before - that doubtless says something important about Ovo. :smile:

Userlevel 7

Updated on 27/04/22 by Jess_OVO


Back with an update from the team on this one - they have been working on this feature so sounds like a bug crept in there whilst they were making the changes (hopefully this should have already been fixed).


They did also explain that the usage views available do depend on your meter type - 


Smart users (with exclusively smart meters) will see tabs to toggle between views - they can view daily, monthly and yearly usage.


Traditional users (with exclusively traditional meters) will not see the tabs as they can only view yearly usage.


Mixed meter users (with both types) will not see tabs, but they do see the drop down (within the navigation menu on the left) - they can view yearly and monthly.



Anyway, great to see a community forum being well used and hopefully the problem will be easy to fix.


A good community forum goes a long way towards customer satisfaction. Though I should say that I’ve never joined before because I’ve never needed any support before - that doubtless says something important about Ovo. :smile:


And we whole-heartedly agree with this one - so nice to have so many active community members here to help us improve our online features. Bringing all your technical expertise to the table, we really are incredibly grateful to have you here to share your knowledge and ultimately play a really important role in our journey to Plan Zero - we couldn’t do it without you! :relaxed:

Userlevel 7
Badge +1

Takes a look and smashes the fix to pieces in under 10 seconds flat!

Unfortunately @Jess_OVO that fix may have made it even more broken than before! I’m not sure if it’s just because the fix is still being implemented via multiple Commits and the latest Deployment to MyOVO is based on one of those Commits where the full fix hasn’t been implemented yet but…

Neither of the buttons works right now - Monthly or Yearly. However, going to just /usage without /monthly or /yearly on the end does work as per the previous behaviour - so this seems like a possible regression.

Could you ask someone to flip the switch again please?

On the plus side, the buttons do now at least lead to /monthly and /yearly as intended, so at least that existing bug is technically squashed. But in doing so, caused the HTTP 404 bug. Sounds like they don’t redirect properly!

Userlevel 7
Badge +1

Ah ha! Perfect. That bug has been fixed as well. Nice. XD

Could you double check that everything’s working as well please @knight @darkness and @MBA ? If things are still broken, please give us a shout and I’ll ask for this to be flagged up again.

But if it’s all working fine now, it would be great to get a thumbs up as well, so that we know it’s not just fixed for me.

Sorry it took a while to get these pesky critters squashed!