Having an issue logging into your online account or app?



Show first post

109 replies

Userlevel 7
Badge +2
Getting nothing but a white screen on the app and on the website when I try and login. Followed the instructions to reset my passwordand then it just doesnt work.

(This was prompted by earlier receiving the email saying I had been moved over to the new improved platform)

I check/use the site nearly daily, so this is quite a pain!!

Site wise, same result in Edge, IE, Firefox and Chrome.


@sam_cat Have you tried incognito? It could be stored cache etc


Cleared all cache, edge is a new install/never used to not that.
Just tried incognito and made zero difference.


Running any Java script blocker or Ad blocker? I only use uBlock Origin and I am able to gain access to the site.
Userlevel 2
Yes, but only in Firefox. Other browsers are as the factory shipped them.
Userlevel 2
Saying that, it just magically started working on Firefox.
Userlevel 7
Badge +2
Saying that, it just magically started working on Firefox.

Glad you are up and running.
Userlevel 2
Can confirm its working across the board now. When I first got in most of the older data was missing etc... Gradually over the weekend it started appearing.

At a guess the acceptance and resetting passwords process kicked off a data transfer behind the scenes that didnt make immediate progress meaning I couldn't get in. All sorted now though. 🙂
When I switched to OVO Online Pay Monthly Acct. in June there were computer problems with my sign up email address. So change the email. Now it appears the OVO system will not let me log into My OVO no matter which I use. Get error message: Email or password is wrong.
Customer support sent me a new password request email - that did not work either.
Have been asking for New Password email from OVO system several times and it does not send one.
WHY!!
Why can't OVO delete one of the email addresses off my record so I can access my Acct.
This a repeat of an old issue regarding access to MY OVO acct. why is it happening!!
If this is technical problem why don't customer services transfer me to a technical bod to sort it out?
Anyone else have this issue
Userlevel 6
Sorry to hear about the issues you're having, @DOW.

We can definitely delete your email address off an old account to allow you to log into the new one. Just send the team a PM on Facebook or Twitter with the relevant account numbers, your full name and your DoB.
Hi,
My MyOVO account hasn't been working for over a month now, and it has been at least 3 weeks since I have first reported the issue. I have since phoned OVO like 5 times, mailed them like 3 times and every single time got the answer that they will pass it to the IT team or whatever. To this day the issue has not been fixed. That's unacceptable, since MyOVO is vital.

The issue itself is that every time I log in (from any device) I see "No identifiers.paym in session. Please try again later." and I can't do anything. Mobile app doesn't want to log in at all.

The customer support is a joke and might as well not exist. I don't know if I have to pay anything since I reset my Direct Debit at the end of October (I changed my bank account; had to do that over the phone cause my account doesn't work) and it will go out in December so I probably need to pay for November via a debit / credit card but I have no idea of checking it since OVO is pretty much useless when you have no access to MyOVO.

You are practically forcing me to switch to another electricity supplier, although I don't even know how I would go about that without having access to MyOVO.
Userlevel 2
Sorry to hear you’re having difficulties with logging into your online account, @TRC881

It seems there could be a technical glitch that’s stopping you accessing your account. If you clear your internet history, cookies and cache and reset your password, then you should be able to log in with your customer ID: https://my.ovoenergy.com/password/reset.

If you’re still unable to log in, please can you send us a PM with your full name, account number and DoB, then we can take a look into this!
I cannot access my account User name and password not recognised
I CANNOT ACCESS MY ACCOUNT
I sign in using email and password (also reset the password but instead of going into the site I get this error message: "No Identifiers.paym in sessio, please try again later.

What's going on, I tried yesterday with the same result and now reset my password but still same result ?!?

So frustrating
What's wrong?
Userlevel 6
I've moved your query over here, @marshalldouglas123, as we already had a topic on this. Take a look through the comments, I'm sure they'll help to resolve this issue.
Userlevel 6
I sign in using email and password (also reset the password but instead of going into the site I get this error message: "No Identifiers.paym in sessio, please try again later.

What's going on, I tried yesterday with the same result and now reset my password but still same result ?!?

So frustrating
What's wrong?



@Henry Take a look through the comments for more advice on this.

If you're still unable to login send us a PM with your full name, account number and DoB so we can take a look into this!

Hi, I'm fairly new to MyOVO. When I joined, I signed up for the online account and entered my meter readings. 

I'm receiving OVO account emails, have an OVO ID and an OVO account number.

However, I suddenly can't log into MyOVO online account. Even if I ask for a password reset, MyOVO doesn't email me one, essentially not recognising my email address...which is the one I am currently receiving OVO emails and account statements on.

Does anyone have any ideas? Many thanks in advance.

Jason

How is one supposed to send a PM?

What does "I moved your query" mean?

I use Safari -

Why do I get this error message?

All I want is a hassle free login and see my statements. I it is not possible, please send me my statements by post as in the past. At least that does not require me spending hours trying to figure out how this forum works. Not user friendly at all.
Grrr
Also, what on earth do I do to be able to "look through the comments for more advice on this"
Userlevel 7
Badge +2

Hi @j.jasonmitchell,

Hmmm how odd.

How long ago did you sign up? I believe OVO support team have to create your account associated with the email address you provided. I cannot remember if this takes a few days, My best guess would be check if OVO sent an email when you registered and see if they mention anything about creating an account on their end.

Maybe add some screenshots to this topic of the error you're seeing and the Mods can take a look to see if it's anything they need to raise to their Tech team.

Thanks

06/05/2020

Userlevel 7

@Henry

Eva has moved your comments to this topics (another topic to the one you created), on the same issue - that's what she meant. There's loads of comments on this topic thread, and others on this forum. But this looks like something we need to look at. Pop us a message on FacebookTwitter or our Help Centre has online chat!

I've moved house and taken OVO with me, but logging in with Google Chrome takes me to old account. How do I get to use my new account? I tried putting my new OVO id but it doesn't work.
This had happened last time I moved too and I remember it was quite an effort to change this. I can't remember how to get this changed.
Also OVO makes it very difficult to mail or call for some support. No phone number or email id displayed easily. Can't understand why they make it so difficult.
Regards
Vivek
Userlevel 7
Badge +2

I've moved house and taken OVO with me, but logging in with Google Chrome takes me to old account. How do I get to use my new account? I tried putting my new OVO id but it doesn't work.
This had happened last time I moved too and I remember it was quite an effort to change this. I can't remember how to get this changed.
Also OVO makes it very difficult to mail or call for some support. No phone number or email id displayed easily. Can't understand why they make it so difficult.
Regards
Vivek

 


Hello @Vivek

If you message us on FacebookTwitter or our Help Centre has online chat, we should be able to assist you further.

 

Have my Ovo ID but it is impossible to set up the account. If you click "First time logging in" it takes you to the password reset page. I have never logged in before so how can I reset my password? There's no way for me to do anything.

Tried calling but impossibly long queues and there is no way to contact anyone directly via this website except for this forum.
Userlevel 7

Have my Ovo ID but it is impossible to set up the account. If you click "First time logging in" it takes you to the password reset page. I have never logged in before so how can I reset my password?

Stick your email address in that 'password reset' section to get an email - this will let you assign a password which you can use along with your OVO ID to log in!

Let us know how it goes @Brickhouse
Me too. The App just sends me round in circles. It doesn't recognize my password so I have to reset it each time. But I reset to the same then I can get in!
Userlevel 6
Hey @Graham Burley - I've moved your post over here where customers have been troubleshooting app issues with us!

Reply