Solved

Why won't the Geo Trio II In Home Display (IHD) from my old supplier connect to my S2 smart meter network with OVO?

  • 14 January 2021
  • 39 replies
  • 607 views

Userlevel 2
Badge

Hi,

Since moving to OVO from EDF on Jan 5th, the Geo Trio II IHD supplied by EDF will not connect to the SMETS2 smart meter also supplied by EDF.

Even after resetting, it just sits there and say trying to connect. There appears to be a strong 5 bar WiFi signal and the IHD is less than 2 metres from the smart meter with no obstructions in between.

When I look at the IHD the screen says

      Meter Network Not Connected

             Status 22-0

      Not connected to meter network. If the problem persists, please contact your supplier.

I have contacted OVO support and answered their initial questions but they also suggest seeking help here on the forum.

Any ideas ?

thanks and regards, Kevin

 

 

icon

Best answer by kwick1 16 February 2021, 11:49

 

OVO uses Chameleon branded IHDs, rather than Geo branded IHDs. So it’s possible that your Geo Trio II might not work properly anymore. I’d recommend keeping it around as a spare anyway. The good news is that OVO can supply you a Chameleon branded IHD completely free of charge. As you’ve got a SMETS2 meter, you’ll want a Chameleon IHD6.

Please let the Support Team know that you’ve had a chat with me on the forums and provide a link to this thread. Once the agent catches up, they’ll know what to do next.

 

There’s four main ways you can get hold of an IHD from OVO. In all cases, the first one is always free:

  1. If you don’t yet have smart meters when you join OVO and OVO install them for you, the engineer will bring an IHD along with them and get it paired up as part of the installation job.
  2. If you already have smart meters in your new house when you move in, but no IHD yet. OVO will happily pop one in the post for you, free of charge
  3. If you switch to OVO from another supplier and need a suitable IHD, OVO can check which one you need and send one out
  4. If your existing IHD breaks/isn’t compatible/gets stolen/goes missing, OVO will send you another one for free - provided you didn’t deliberately break it (such as smashing it with a sledgehammer for example)
  5. If you fancy having more than one IHD, OVO can consider reasonable requests

All of these cases except the first one require you to put a request in via the Support Team and you will have to pair your new IHD after it arrives. If an engineer sets up your smart meters, they’ll pair up the IHD for you.

 

Hi again @Ajk 

I think @Blastoise186 has covered all the ways to get hold of an OVO IHD6 but when you do request it, just make sure of a couple of things:

  1. Double check the new IHD6 requested is set up to match your account details. Mine came with the wrong information and doesn’t match the correct tariff I am on nor the fact that I have a dual tariff ECO7 account. Hence all my IHD readings for cost (£) are incorrect and there is no separation for Day/Night usage even though my online web account is correct. Been told it is a known s/w issue for some users and to wait for an update? 
  2. I’d recommend having your account set to collect data at 30 min intervals. I think default is monthly and they need your specific agreement to change to 30mins. It took me 3 calls to support to get this corrected even after I had been told it had already been set up. Slightly frustrating but done now.

I’m not complaining and my minor issues are getting sorted and the support has been friendly and responsive. Perhaps a couple of teething troubles on my switch though.

regards, kwick1

View original

39 replies

Userlevel 7
Badge +3

Hi there @kwick1 ,

Can you snap a few photos of your meter and IHD please? We’ll see what we can do.

I’m tempted to suggest asking the Support Team for an IHD6, but let's see if we can figure out your current one first.

Userlevel 2
Badge

Geo Trio II photos

Hope the link above works, thanks Kevin

Userlevel 7
Badge +3

 

Thanks @kwick1 , that worked perfectly.

Hmm… I see what the problem is here. It’s possible that your meter is currently being transferred from EDF to OVO. Because it’s a proper SMETS2 meter, this is a simple case of waiting for some back office processes to go through and that should complete within a few weeks.

However, OVO uses Chameleon branded IHDs, rather than Geo branded IHDs. So it’s possible that your Geo Trio II might not work properly anymore. I’d recommend keeping it around as a spare anyway. The good news is that OVO can supply you a Chameleon branded IHD completely free of charge. As you’ve got a SMETS2 meter, you’ll want a Chameleon IHD6.

Please let the Support Team know that you’ve had a chat with me on the forums and provide a link to this thread. Once the agent catches up, they’ll know what to do next.

Userlevel 2
Badge

Many thanks, Kevin (kwick1)

Userlevel 7
Badge +3

No worries. :)

If you’d like, you can even have both the IHD6 and the Geo Trio II hooked up to the HAN at the same time, since they shouldn’t clash with each other. Assuming your Trio II hasn’t somehow unpaired itself, it should just be a case of pairing up a shiny new IHD6 and letting it run alongside the Trio II.

I think you can have up to four IHDs active at once if memory serves. So if one of the two breaks, you might be able to keep using the other one.

Hi All

We had our meters upgraded last week and received a new Geo Trio II IHD. The engineer who fitted the meters left us saying it takes 24 hours to show any data. We duly waited 24, then 48 and then 72 hours. Nothing changed. We had 28-1 “connected but no data” in the status display initially. Being a IT systems Engineer I gave it the good old “turn it off and on again” and now it wont go past “connecting to smart meter”. 

I've had a look at the electric meter and can see the WAN and HAN lights, WAN is flashing green every 10 seconds but HAN flashes Red. I am a little surprised that a power cycle caused this, I am more minded that the engineer didn't fully set this up correctly as it was his last job of the day and he wandered off for a smoke after looking at our gas meter. 

Hopefully this is a simple fix, can anyone tell me the process for pairing or how to check pairing? Ive got it all working on WiFi and have the geo home app installed. This of course shows no data as I guess it piggy backs off the IHD for data.

I'm keen to get this working as the other half was on the fence about smart meters and this has really put her off ovo as it isn't working as advertised.

Userlevel 7
Badge +3

Welcome to the forum @Trixxz , :sunglasses:

I just wanted to double check something quickly if that’s OK. OVO usually gives out Chameleon branded IHDs such as the Chameleon IHD6, rather than Geo branded ones. Could I ask if you’re with another supplier by any chance? I can definitely answer this one, but I just wanted to double check so that I can give the right answers.

If you could also snap a few photos of the meters and your IHD and add those to your next reply, that would be great too.

As for your query, it definitely sounds like the IHD wasn’t paired to the HAN properly, something which is backed up by page 15 of the user manual listed on SmartMe. This should be an easy fix however. Please contact the support team of your supplier and ask them to pair a new IHD to your HAN. They’ll walk you through the steps from there.

If you’re with OVO, you can find contact details right here.

The other thing to note is that it can take up to 6-8 weeks for everything to fully commission and activate post-install, since there’s a lot of back office processes that need to take place. Once those are done, you should see things start to become more reliable.

Userlevel 7

Two Geo Trio questions in the space of a few days. I’ve combined these together BTW peeps. 

 

@Trixxz are you a current EDF customer by any chance? 

Userlevel 2
Badge

@Trixxz  I’m with OVO having switched from EDF and have been told by OVO support team that the Geo Trio II will not work with the OVO network. They’ve ordered a Chameleon IHD6 for me and will walk me through linking it to the S2 when it arrives. I’ve also been told they are in short supply and there may be a delay.

I’ve given up on the Geo Trio II for now but will follow your progress with interest. My EDF installer didn’t demonstrate anything (said he wasn’t allowed to C19) nor leave any info about a Geo Home App? I can’t find any network parameter setting in any of the menus on my Geo Trio II IHD???

Userlevel 7
Badge +3

I did manage to locate the geo Home app on the Google Play Store, which you can find over here if you’re looking for it.

Having looked at the details however, the app will only work if you’re using a geo branded IHD that’s working properly. If you do manage to get the Trio II working again, there’s a possible chance that the app might do something useful, but otherwise the app will also be dead.

By the looks of things, I suspect the setup process between the geo Trio II and the geo Home app is probably done almost entirely within the geo Home app. That might explain why you can’t find anything.

For the most part, IHDs from Chameleon should work fine with almost all suppliers which provide Chameleon branded IHDs. Likewise, geo IHDs should play nice with any supplier which provides the geo ones. There’s not really much in the way of cross-compatibility though.

Userlevel 2
Badge

Just to close this off, I received my new IHD6 yesterday, phoned the OVO help line and activated it. It started to synchronise right away and is receiving data.

However, there is one further issue which may or may not be a problem. Let me explain.

 

I am on a ECO7 dual tariff for Day and Night. My online OVO account accessed by web or app is set up correctly and is recording kWh against the separate tariff rates. BUT the IHD6 is set up with just a single tariff (which is not my correct tariff) and only records one meter reading. This single reading appears to be the sum of the Day and Night kWh readings.

Is this incorrect or working as designed? I can still get my correct readings through the online account but it makes the IHD6 pretty useless. My EDF Geo Trio II IHD was able to separate the single meter reading into Day/Night numbers based simply on a time stamp (even though that did not take into account the GMT/BST change). 

 

So, should the OVO IHD6 also be able to separate the ECO7 Day and Night rates? Is it set up incorrectly and how do I correct it?

I have raised a new ticket through OVO help so it’s in hand with them but as ever they ask to check here as well. Should I raise a new forum issue?

regards, Kevin

Userlevel 7
Badge +3

Thanks for letting us know @kwick1 ! I’m glad to hear you’ve got a working IHD now.

In theory, the IHD6 should be able to handle Economy 7, but it may need a bit of time to fully synchronise so that it sets itself up properly. I think it has to be set up by the supplier and there’s no option you can do on your end.

Would you be OK with giving it a few days to see whether it does this? Feel free to have a chat with the Support Team to ask them whether they can force this through as well. If it still doesn’t work, we can probably get that flagged up as a possible bug.

Userlevel 7
Badge +3

On balance however… If you fancy putting a bug report in while you’re here, go for it!

Feel free to create a new thread for that particular issue, as I don’t think one exists yet. You never know… You might even get a reward...

Userlevel 2
Badge

Thanks @Blastoise186 - I’ll give it a few days and see if the help query is responded to. If nothing back I’ll raise a new thread. Cheers kwick1

Userlevel 2
Badge

UPDATE: OVO support called me yesterday and explained that the IHD6 issue I have is a known problem affecting “some” customers on a dual tariff such as ECO7. 

Nothing for me to do but sit back and wait for a s/w update or some sort and the IHD6 will then sync to my correct account details. All a little vague as to why only some customers are affected and no date for resolution but it’s moving.

I can keep up to date via my web account but even the latest bill doesn’t seem to be quite in sync with the opening meter readings. They are looking into that now.

Cheers, kwick1

Userlevel 7
Badge +3

Thanks for letting us know @kwick1 !

One of the easiest ways for the IHD6 to pull down firmware updates is via the internet. If you’re OK with connecting it to Wi-Fi, that should allow the update to be downloaded once it’s ready. If there’s a known issue however… I can probably ask Tim to do some magic tricks...

Userlevel 2
Badge

@Blastoise186 is it not already connected to the internet via the SM2 and it’s mobile connection? 

If not, yes, I’m happy to connect it to my own WiFi network if that helps?

Do I just go into the WiFi settings and search for my network and plug in the password. I don’t want to break the connection to the SM2 that’s already set up though.

Cheers, Kwick1

Userlevel 7
Badge +3

Yup, that’s right.

The easiest way is to search for your network and pop the password in. While other methods like WPS are possible, they’re a bit unreliable and don’t always work.

There’s two different connections that the Chameleon IHD6 (or Chameleon IHD6-CAD-PPMID to give it the full name) is capable of. The HAN link to your smart meters goes over something called ZigBee, which is a bit like Wi-Fi but ever so slightly different. This one is the one that the meters and IHD use to communicate with each other. There’s no way for any of these devices to use the WAN/HAN to reach the internet as it’s all running on closed systems.

And separately to that, you’ve also got Wi-Fi, which the IHD6 can use to pull down firmware updates and enable a few other magic tricks that can’t be done via the HAN. The Wi-Fi features are isolated from the HAN, so they won’t interfere with each other and this won’t mess up the HAN.

If you get stuck, feel free to give us a shout. :sunglasses:

Userlevel 2
Badge

Hi @Blastoise186 , my IHD6 is all hooked up to the internet although I did notice a couple of things.

  1. It would not connect in the 5GHz frequency range (or at least not on my network). Probably not a surprise as the IHD6 must be pretty basic in terms of WiFi and the 2.4GHz range travels better over longer distances and through walls I believe. I have my 2.4GHz turned off normally so have changed that now.
  2. Even once I’d turned on the 2.4GHz WiFi transmitter, the IHD6 still couldn’t find the signal using the search function. I had to know my SSID and plug that in manually as well as the password. Might be an issue for other users? I never use WPS anyway.

So, I guess it’s just wait now for the s/w update? Unless you have any other ideas?

regards, Kevin (kwick1)

Userlevel 7
Badge +3

Thanks @kwick1 !

Yeah, it can seem a bit weird that they’re 2.4GHz only, but at the same time, ZigBee is also 2.4GHz only. 2.4GHz also has a longer range than 5GHz and the HAN doesn’t exactly need high speed networking, so it’s more useful for it to run on 2.4 across the entire IHD.

I’ve been able to use some of the magic tricks my UniFi kit gives me to monitor how the IHD behaves, and it definitely doesn’t ever attempt to use 5GHz for me, regardless of how far I crank Band Steering towards that preference. :sunglasses:

That’s also why I tend to recommend having your Wi-Fi Router set to merge your 2.4GHz and 5GHz networks into one combined network, since it’s more reliable that way and you get the best of both worlds. :wink:

It’s a bit strange that your IHD6 didn’t pick up the SSID though. Did you maybe have SSID Broadcasting turned off on the router?

Other than that, the best thing now would be to wait for the firmware updates

Userlevel 2
Badge

Thanks @Blastoise186 - I had my WiFi bands separated (with 2.4GHz turned off) for another reason but as it’s on now, I might as well recombine them. Two final questions though:

  1. Are there any extra security precautions I should take with the IHD6 connected?
  2. I like to switch off my WiFi router overnight using a scheduler. Will that interfere with the IHD6 at all or will it simply reconnect when it comes back on in the morning?

Cheers for all your help, Kevin

Userlevel 7
Badge +3

No worries!

In that case, I can offer some advice for both questions too.

When it comes to security precautions, there’s always the usual reasonable steps that you’re probably already aware of. However, the IHD6 only really needs to reach the internet and doesn’t have any interest in anything else on your local network. As such, feel free to spin up a dedicated Wi-Fi network for it, with a dedicated SSID, WP2 Personal (and a separate password!) and Device Isolation turned on just for that SSID and then pop the IHD6 onto that one instead of main. If possible, set it so that anything on the IoT SSID cannot access the local network. That should do the trick nicely.

I will admit that I overengineer my setup and have an entire totally isolated IoT network (both wired and wireless) that’s on a different VLAN to all my other stuff and locked down with a few firewall rules, mainly because I can do magic tricks. It’s super mega secure of course, but a bit overkill for some!

As for turning off the Wi-Fi overnight, as long as the router itself remains on, you should be good. It’s always best for the router itself (and any attached modems) to remain on at all times, otherwise you’ll cause the local exchange to think your line is faulty and destroy your speeds! But having it set to shut down the Wi-Fi overnight is perfectly fine and won’t affect the IHD.

It might complain about losing the Wi-Fi and prompt you about it, but it’ll just reconnect once the Wi-Fi comes back on in the morning. Other than that, it won’t cause any issues.

Userlevel 2

Hello

I'm with british gas  and have a smets2 smart meter and a british gas in home display which is made by the company Geo.I understand that if i switch to ovo you will be able to connect to my smart meter because it is a smets2.However would my in home display still work.

Thanks

Userlevel 7
Badge +3

Howdy @Ajk !

Would you like the good news first… Or the really good news first?

Well, I’ll give you both!

As long as your current smart meter is a SMETS2, you can definitely switch to OVO or any other supplier freely and your meter will remain smart no problemo. In fact, I can double check that for you too if you’d like me to. Feel free to snap some photos of your smart meters and In-Home Display and I can take a quick look to confirm.

As for your IHD, that might be a bit fiddly because it’s from Geo (possibly a Geo Trio II perhaps), but OVO uses Chameleon branded ones instead, such as the Chameleon IHD6. While it might be possible to continue using your existing Geo IHD, OVO would also be more than happy to send you a shiny new Chameleon IHD6-CAD-PPMID in the post free of charge as a welcome gift.

And the best news there? You can have up to four IHDs running at once, so you’d be more than welcome to have both your existing Geo Trio II and a Chameleon IHD6 active side-by-side.

I hope this helps. Feel free to reply back if you’d like any more help with this

Userlevel 2

Hi Blastoise

A new in home display would be great. Hear are the photos of my smart meters and display you asked for so you can double check the compatability. Thanks

 

Reply