Solved

Why won't my Geo Trio II In Home Display (IHD) connect to my S2 smart meters with OVO?

  • 14 January 2021
  • 86 replies
  • 19809 views


Show first post

86 replies

 

 

@Blastoise186 , there isn’t anything else showing in system status

Userlevel 7
Badge +1

In that case, I suspect something isn’t paired properly, possibly the electric meter. I’d recommend focusing on that rather than the IHD.

@Blastoise186 thanks for your time, I’m not qualified to be touching anything in the electric meter, wouldn’t know where to start. Looks like the smart meter is a waste of time for me, other than transmitting information over to OVO

Userlevel 7
Badge +1

Simply let OVO know. They’ll do the rest :)

Userlevel 7

Hey @Macca,

 

Sorry for the issues you’re having.

 

When you log into your Online Account and check meter readings, does it show we’re in communication with both smart meters?

 

If not, you’ll need to do a smart meter health check:

 

 

If we are in communications, then it’s the In Home Display that’s the issues. Although this is frustrating, please be assured all your billing will be correct, you’ll be able to see all your usage information online. We also have a live billing system so your account balance will update every time we get a meter reading. You can find out more about this topic here:

 

 

We have a great guide all about IHDS, it also contains a ‘health check’ you can forward to Support so they can diagnose the issue:

 

 

Hope this helps. 

Switch on the geo trio IHD

It reports 'connecting to smart meter' 

Wait a few mins, screen goes black, no lights, buttons dont work

Power cycle the IHD same thing happens

Device less than 1 minth old!

 

FYI, the Gas and Electric meters are made by Landis, and there is some other device made by Toshiba.

Userlevel 7
Badge +2

To pass the time while our resident smart meter expert is underwater somewhere, can I suggest you leave everything plugged in, close together if poss and see if they wake up and connect eventually.  I believe the battery in the IHD is only enough to power it for a very short time. Meanwhile could you post photos of the kit here please. 

Userlevel 7
Badge +1

Please access the IHD menu > System Status > Select each element in turn > Tell me the Status Codes for ALL of them

There is no point in taking a picture, really.

But I did move it close to the meter cupboard and left it on all night, in the vain hope that something different may happen.

The only difference is that the screen stays on, and after a period of reporting 'connecting to smart meter' it briefly reports 'not commissioned'

Buttons are still un responsive

 

Userlevel 7
Badge +1

You need to contact the Support Team in that case. They can assist with commissioning.

Support have re-paired the IHD, though so far, nothing has changed.

GEO smart display i have just replaced my smart display plugged in and says not commissioned how do i commission it ? is that such a difficult question ? .i have no idea how much elec gas i have .how do i commission it as trying to contact sse is near on impossible and when you do get through nothing but rude people on the other end that cut you off or fob you off to other members of the call center *edited by mod*.

Userlevel 7
Badge +2

Our resident smart meter expert is away for a couple of days, but you may find something useful here (sorry if you’ve already looked at this).

Meanwhile are you able to see your smart meter data via your online account? 

Userlevel 7
Badge +5

Hi @seanellison can I just check this is not a second hand unit. The only reason I ask is that these need a complete reset when changing connection. 
Alongside the guide @juliamc has given, there’s also another which might help. 
 

 

Userlevel 7
Badge +1

Hiya!

Sorry for the wait. SkyNet Blastoise Bot alerted me that this thread still needed my attention so here I am. :)

To be able to get that IHD up and running, you do need to contact your current supplier and ask them to pair it up. There’s no other way to do this without their help I’m afraid.

I’ve just ( few hours ago) had a few hours ago had a geo trio ii touch button meter installed. After I had 2 messages pop up and because I didn’t know what I was doing I’ve managed to delete the gas reading now 😫 anybody have any ideas how I can get it back. I have the electricity reading ok but no gas. 

Userlevel 7
Badge +1

Try taking the batteries and power cable out and putting them back in. :)

You can’t delete that stuff yourself.

I’ve unplugged it for a few minutes but it’s made no difference. Thanks for the suggestion.

Userlevel 7
Badge +1

No worries. It was worth a try! :)

Can you post photos of the display please? I use these to help with diagnostics.

im basacly leaving them in the next couple off weeks so are my parents and sister we all have had a bad responce from the so say customer care .

Userlevel 1

Can someone please help I’ve had nothing but trouble with in home monitor I’ve phoned up loads of times but still no help OVO sent me a new geo IHM and I phoned up to be told I had to leave it for 2 days to update but even though it’s been over 2 days it’s still not working all it’s saying is connecting to smart meter and then not commission 

Userlevel 7
Badge +1

Hi @cathc54 ,

Please can you go into the System Status menu and tell me the Status Codes you’re seeing?

Userlevel 1

We’re will they be I’m so sorry but being 70 I don’t really understand these at all

Reply