Solved

Why have I lost the electricity information on my Chameleon In-Home Display 3 (IHD3)?

  • 20 November 2021
  • 20 replies
  • 186 views

Hello

 

Newbie alert 

I have read through a number of similar questions / replies but not found any solution to my issue, which does seem to be a common issue

All good till last weekend when we lost electricity display on our IHD3, turned unit on and off dozens of times, sat it right next to electric meter, left off overnight, none work

had a next to useless text chat  with ‘support’ who have said it will be investigated but can take up to 46 days, come on guys that is not what we expect these days, I also dont even think anything will be checked, it felt like a fob off reply

It would appear to have become unpaired, I can see electric data on line but only in arrears, really want to see current consumption having just had solar panels fitted 

all displays on IHD suggest working fine, just only showing gas use, that meter is right on the limit of the 15m suggestion, electric only a couple of meters away and even indoors

is there really nothing I can do, I will try calling support for a real chat next week in the hope that they can re-pair, seems a shame this isn’t a customer function though

 

 

icon

Best answer by Jess_OVO 22 November 2021, 15:24

View original

20 replies

Userlevel 7
Badge +5

Hey there @DavidG58 !

Welcome to the forum. :)

I just want to let you know that as a forum volunteer, I can’t access your account or make any changes, so I don’t know what the Support Team has attempted so far. However, it does sound like your case has been escalated to a higher team to investigate further, as 46 days is the target deadline to resolve tech issues like this. It can take a while to do things like retrieve logs, review the data, run diagnostics and attempt to fix the issue remotely. It can sometimes be resolved faster than that however.

In the meantime, you can try a trick that sometimes works. It has mixed results, but I like to try it as it has helped a few times. If you leave the IHD turned on while on battery until it runs out and turns off, give it a full recharge and then power it back up, that sometimes helps.

It seems that a few other members are having similar issues as well at the moment, I would imagine that this will be investigated, especially if it gets worse.

Are you getting meter readings in MyOVO correctly for both meters? If not, then somethings definitely not right (it could be a sign of a comms outage) and OVO will investigate since you’ve already reported a problem.

Unfortunately, you can’t pair or unpair devices from the Comms Hub yourself for security reasons. Smart Meters are considered part of critical infrastructure, so there needs to be measures in place to prevent random unknown devices from attempting to connect to your Home Area Network and compromising the security. The Support Team should be able to help you unpair and re-pair the IHD though if you’d like to try that. They’ll walk you through the process as it’s a bit fiddly if you’ve never done it before.

Morning 

 

Many thanks for the reply 👍

my unit is currently disconnected from the mains charger as I saw that tip mentioned on a similar query , possibly by yourself 

I will update this post later when restarted

all online information is good so I suspect it is only a display issue

 

 

sadly, this hasn’t worked. Powered up as soon as connected back to power lead, all OK except still no electricity display

will call tomorrow and get some more help

Userlevel 7

Sorry to hear that our community volunteer, @Blastoise186’s trouble-shooting hasn’t managed to get the IHD issues sorted, @DavidG58 - Sounds like this might be something that needs a bit more of a technical investigation.

 

In case you hadn’t spotted it already we’ve got a great guide to identifying ongoing smart meter issues using your online account here. If nothing seems amiss here, it’s more likely that we just need to give the IHD a bit of a nudge to get all your important usage data showing. Our Support Team should be able to request a message which is sent from the meters to the device and usually sorts things out.

 

Do keep us posted here - it’s always really useful to hear how these smart meter issues are resolved for others who might have the same issue in future.

Currently struggling to get ‘support’ from customer support

i have been sent and filled in a report list that doesn't relate  to my issue, either misheard or misinterpreted but have given meter details now and hope things will move on

not filled with much confidence though yet 

Userlevel 7
Badge +5

Ah yes. That sounds like the Smart Meter Health Check. It might not sound like much, but the data it provides is actually pretty useful, and it is only part of the puzzle. It gets combined with other data and processes during the diagnostics in order to figure out what to do in order to get things fixed.

Someone will look into this for you. Trust me, the issue I had definitely had someone dedicated to it for several months because I really did manage to stump them!

Just to update, I have been restarting my display daily in the hope that something might have been reset

But am disappointed to report that other than a generic reply to my submission of meter details , quoting an up to 45 day reaction time 😳 I have heard nothing and my display still only shows gas readings 

it does seem that my electric meter has been unpaired from the display somehow, I appreciate I am only one of millions of customers , but really don’t think that a 45 day reaction time is acceptable 

Userlevel 7
Badge +5

I can appreciate the frustration this might cause, but 45 days is actually better to target, than claim something like 10 days and then have to keep extending it repeatedly. The extra time allows for more in-depth checks to be made and a proper investigation to occur if needed.

OVO will be working on this issue in the background, even if there’s no visible evidence. Please hang in there for now, you’ll be notified when there’s any updates.

Separately from this, I’ve engaged my buddy Theunknowntech to try and dig through multiple public data sources to see if we can pick up patterns. He does monitor this forum almost as much as I do, but he mainly posts elsewhere and collaborates with me in many, many different ways - especially when it comes to gathering data. I’m great at bug hunting, but Theunknowntech is better than me at data analysis. Our teamwork is what makes the dream work. :wink:

Obviously, the two of us can’t intervene with regards to your specific issues, but we’re trying to figure out whether there’s a wider issue right now. You’re not the only member flagging this up, so I’m hoping we can spot the trends here and contribute something that helps to pin it down.

Userlevel 7

 

it does seem that my electric meter has been unpaired from the display somehow, I appreciate I am only one of millions of customers , but really don’t think that a 45 day reaction time is acceptable 

 

I really appreciate the frustration that’s been caused by the ongoing issues and time frame given for a solution, @DavidG58.

 

As we often find smart meter communication issues can be intermittent, this longer time frame allows time to monitor the situation in case things are resolved without needing further action. In your case, as it sounds like the issues you’ve described are only affecting your device rather than the meters themselves it would be best to give the team a call. They can talk you through the steps to get a device paired and may be able to escalate any unresolved issues to our smart meter team during the call - Your can reach the team on 0330 303 5063, lines are open 8am - 6pm Monday - Friday.

 

Hope the team are able to get things back on track - do pop back here if you need any more general advice. :slight_smile:

Userlevel 5
Badge

But am disappointed to report that other than a generic reply to my submission of meter details , quoting an up to 45 day reaction time 😳 I have heard nothing and my display still only shows gas readings 

I am with you on this. They are stringing you on claiming it might be an intermittent issue, but realistically it seems pretty constant. There should really be better fault handling, and the IHD and the meter should be able to tell you what is wrong. 

 

Userlevel 1

I had exactly the same issue back in April this year, but I’m with EDF. I concur with others that the electric meter data is not getting to the Chameleon 3. It can’t be that the electric meter is faulty as its data appears in my online energy use page. That suggests to me that the electric meter has a direct connection to the HUB ( as opposed to Zigbee). The IHD can’t have become unpaired because it shows gas data… I got the same 45 days bull**** - software update sir, it takes that long… My best guess it’s a software bug somewhere… EDF replace the IHD and that worked for a while… now I’m on my third IHD- which is dead… And it’s not a range issue- the IHD remains dead even when located in the HUB box so 30cm max. Just my take on things and I’m an experienced electronics engineer of 50 years….

Been on to support today, although they are the same people for billing queries etc. He was able to see my issue had been logged

he rang another section, latest advice now is wait till this time tomorrow and turn IHD off and back on

if the electric readings don’t come back within 48 hours to call them back again 

TBH I don’t have much confidence but will report back in on Wednesday, hopefully with better news 

Userlevel 1

I doub’t it will work. Too many identical issues. Good luck anyway…

 

Userlevel 7
Badge +5

The Chameleon IHD3 is well known for being used with SMETS1 meters. Sometimes it’s also used with SMETS2 as Chameleon has developed versions for both types, but the S1 variant is a lot more common than the S2 variant. The Chameleon IHD6 is generally considered a better match for S2 meters than the IHD3 after all.

I can confirm that it is technically possible to have a wired connection between the Comms Hub and a Smart Electric Meter. However, this isn’t generally used in the UK - and definitely not for S2. SMETS2 meters always use ZigBee and the hardwired connection to the electric meter is used for feeding power to the Comms Hub only. S1 is a bit more complicated, but as I understand it, generally still uses ZigBee across everything. It’s just that each device is paired individually in all cases.

This means that if one of the devices is misbehaving, it shouldn’t usually jam up the entire HAN unless the Comms Hub itself is faulty - that’s basically the only component which can knock out everything if it fails.

I also know that while Chameleon does release firmware updates for the IHD3 and IHD6 every so often, the firmware updates can’t just be rolled out to all devices immediately. There’s a process that it all has to go through via each supplier first, and it’s the suppliers who decide whether to allow those updates to deploy or not. If a firmware bug is causing this issue though, then it should theoretically be fixable in a future firmware update. I don’t have the details I’m afraid - forum volunteers don’t have access to private data like release notes.

I will say this however. There does seem to be quite a trend of IHD3 issues at the moment across multiple suppliers, not just OVO. This would probably indicate that it’s not OVO’s fault but that since OVO has used Chameleon IHD3’s and IHD6’s, it’s one of the suppliers you’re more likely to notice this come up with. A few other IHDs from other brands are also affected as well by the looks of things…

I have my own theories as to what’s going on, but I’m not keen to share them right now as I don’t have anything to back them up with.

Userlevel 1

Good stuff. I’m certain there’s a software bug, either in the Chameleon3, the HUB, or both. It could be that when the SKU1 Cellular is matched/paired with a Chameleon 3, the bug shows up under a very narrow, peculiar set of circumstances. My observation is, that once the IHD goes into ‘waiting for data mode’ ( perhaps it went out of range) AND the peculiar set of circumstances is present, the IHD effectively becomes either unpaired OR the HUB and IHD get locked in a forever loop and can never exit. This is supported by the fact that once my IHDs get into this state, even placing them in the HUB cabinet, it is still unrecoverable. That should NEVER be the case. That is to say that the argument from the supplier that ‘it must be a range issue’  is a complete fob off to avoid dealing with the situation. That is where I am right now. By design, under all circumstances, an IHD MUST be recoverable when in close proximity to its HUB. This is NOT the case. The remaining question is WHY. This is why I have tried tracking down a debugging device that will log Zigbee traffic. Just swapping out an IHD is not addressing the root cause. When a plane crashes, you can’t have some monkey  say ‘it ran out of petrol, put more in next time…..You get what I’m saying here? I belive there’s a similar issue where either the gas usage OR the electric usage cannot be selected on the IHD ( several reports of that, including me). Sure, getting an engineer out to fit a new IHD will cure the problem and the dumb engineer reports as such- faulty IHD. Sad, but X weeks later, the iHD fails again.  Here’s the rub. I’m guessing here, but the ‘faulty’ IHD will get sent back to Chameleon. There, their test department will give a full test and report ‘no fault found’ and put the device back in stock to ship to a random energy supplier. I bet there is no back reporting to the company that sent it in… so the Energy supplier will never get any feedback on that IHD. If that is the case, it beggars belief. I’ve seen it, I know it happens in the electronics industry. Where it doesn’t happen is the Military/ aerospace industry. Every piece of faulty equipment has a 100% traceable history for the obvious reasons.

It would be really good if someone in OVO tech department could get to read this. I doubt for one moment that they would comment, but if my observations are true/accurate, they might sit up and say ‘hey, we’ve been rumbled’…. If it makes them sit up and take notice, and investigate further or modify the way they deal with ‘faulty’ IHDs, then my resaerch/ thoughts will not have been wasted.  

PS Just noticed that my IHD clock is running ~25 minutes slow. Not seen that before. Is it another clue?

@chartman I’m having the same issue! Just came here to start a new topic but then found your’s. Unfortunately, replacing the IHD may not be the solution! Below is my situation:

  • IHD randomly started acting weird one day, going into restart cycles, losing connection etc after a year.
  • I described my issue in detail on this forum (few weeks ago), got some nice tips especially from @Blastoise186 but the problem persisted and the IHD had not showed any electricity data for over 3 days at that point. (I am only on electricity (meter installed last year), no gas)
  • I was advised to contact the customer services and so I did. They asked for the GUID to initiate a remote restart of the IHD and wait for 24 hours. It did not fix the issue.
  • I contacted again suggesting the IHD might be faulty and they agreed that to be the case and told me to wait for the replacement IHD they will be posting soon.
  • I received the new IHD yesterday and called the customer services to pair it with the meter.
  • Went over the process over the phone and the IHD beeped within 30 seconds and started showing correct time suggesting connection with the meter. CS also said everything appears to be fine on their end.
  • Now the sad part: About 24 hours later still no data whatsoever. The IHD sits within 1 metre of the meter. No usage, no past data, no electricity meter data, no account info, nothing. IHD showing 1 bar of reception next to the meter, all LEDs flashing once every 5 seconds as usual on the meter.

Looks like it was not an IHD issue. Somehow the meter is not sending data to the IHD (or maybe sending corrupt data?), but it talks to OVO just fine as I can see hourly usage in my account and CS also verified that.

 

Like you said, it is most likely a software bug somewhere but not sure who will solve this. I will try and see if the Zigbee on the meter is transmitting anything with a HackRF SDR :) There isn’t much on the net regarding debugging as it is proprietary stuff. All in all, back to square one. I now have two useless IHDs… :(

Userlevel 1

Quick clarification here. Your electric consumption figures are collected from the electric meter by the HUB. That data is sent to the DCC and onwards to your supplier. The HUB will also send the KWh to the IHD where it can be converted to £££ using the stored tarrif data. That assumes that that tarrif data has been sent to your IHD (via SMS ) from your supplier.

What is Hack RF SDR???  Even a device that logs encrypted zigbee traffic might be of some use.. I doubt that the second key used is a ‘rolling’ key as is used in car key fobs… That should mean it’s not too difficult to decipher the zigbee traffic ( wishful thinking) As a note to my skillls, I was able ( back in the day) to get the software out of an 8051 that was in the original sky boxes and reverse assemble it, including their PPV. A bit of a waste of time as they never used that PPV system in the end.

PS I assume its a Chameleon 3 … an 1 bar at 1M distance suggests to me the front end RF is buggered ….. you should get a full 4/5 bars at 1M !

HackRF SDR is a Software Defined Radio receiver, It can receive any RF signal from 1 MHz to 6 GHz and log or demodulate too. However, I don’t think the encryption on the signal from the meter would be standard so it would be hard to get anything meaningful. But, with the SDR I can see if the meter indeed has any traffic at the Zigbee bands and I can also see the signal strength. That should show if the RF fronted is alive. However, the IHD does seem to be connected to the meter as it’s a steady 1-bar and not “lost connection”. Confusing!

Userlevel 1

Thing is, Zigbee is 2.4 Gig, So is my wifi. Or is the separation wide enough @2.4G to isolate the Zigbee from the wi-fi. I’ve not looked into that in depth…

I never see ‘lost connection’ only ‘waiting for current data’. Is it a chameleon3? 

Well, it is a Chameleon 6 but essentially very similar problem.

I use the 5 GHz Wifi band. There are 2.4 GHz users around but taking a measurement just next to the meter should give an idea as it will clearly have a higher amplitude than the neighbouring signals. 

Reply