New SMETS2 smart meter: Electricity reporting not working.


My SMETS2 electricity meter, an Aclara SGM1412-B, was fitted 03 April 2019 and has never reported meter readings back to OVO.

The Gas meter, a Uniflo G4SZV-1, was fitted at the same time works flawlessly.

The indoor display, an IHD3-PPMID / CA30111 Type 2, worked for gas and electric for a while but then this dropped to just gas. I've reset it using a process I found on another post somewhere but only the gas came back so no change.

On the electricity meter: The SW, WAN, HAN and GAS lights all flash once every 5 seconds.

There is an exchange with hello@ovoenergy.com trying to resolve this but this is quite frankly glacial in pace with scripted answers coming back which add little to no value. I'm playing along nonetheless.

18 replies

Userlevel 5
Badge
Sorry to hear about your experience so far, @Mark4833, it sounds like our team have everything in hand. If there is anything we can do to help, please send us a message on Facebook, Twitter or email the team on hello@ovoenergy.com.

Thanks!
Still no change
Userlevel 6
Badge
Hi @Mark4833

Have you been in touch with the team? If so, what did they advise?

Unfortunately we don't have access to your account details on the forum so we can't check this.

Thanks
Smart meter not being smart is with the smart meter team, no change.

The IHD3 not working is due to be fixed by a smart meter upgrade by mid July!
Hi
i have exactly the same issue. The smart meters were installed 4 days ago. Worked ok but yesterday I lost the electricity readings in my IHD. Called OVO twice- one agent said wait a few days and the next agent spoke to the “2020” team who have advised to wait 3 months. If these meters are not fit to Ben installed then why did the install go ahead ? 3 months of waiting before they’ll even consider sending an engineer around to fix this is totally unacceptable.
Rob at the helpdesk dropped me a mail today to tell me they are in communication with my meter now. I now see one reading taken 16/08 but nothing since. Daily gas readings stopped 17/08 but we're getting there I think.
Hi
well I hope so mate. What they explained to me is that the electricity meter is not communicating with the toshiba communications hub, but my gas meter is. In other words the electric meter wan connection is ok but it’s dropped out of the Han.
However on the electric meter itself the word HAN is clearly showing above the word IHD.
I would have thought that problems with the wan would not affect the Han (just like when your pc can connect to your WiFi router but the router has lost connection to the ISP).
Last electric reading they got from me was midnight, so the wan is working.
Frankly I don’t think they know what the problem is.
Keep me posted ! 🙂
Just checked my gas meter. You can find several menus on there and I found the one that said Han status. This reads as connected.
So my IHD must also be Han connected as it shows the gas.
So if my electricity smart meter shows HAN and IHD then maybe the comms function on the electric meter has stalled somehow ? Isn’t there some way to reset the Han comms on the electric meter ??
So can an OVO person please comment ?
Userlevel 2
Badge
That's very odd, @tonyw707, it may be worth explaining this to the team if you haven't already, so that they can use this to make sure they'll be moving in the right direction.

If it's easier, you could just ping us an email at hello@ovoenergy.com, you should hear back from us within 3 working days.

Thanks,
Ed
Hi Ed,
Thanks for getting back to me. However this has already been explained during my recent call with OVO.
Since yesterday however my electricity and gas now both show but the gas cost is outrageously incorrect.
This morning I checked the last few days of gas and it was showing exactly £1 per kWh. £17 yesterday, £13 the day before, £16 the day before that. I wasn’t even at home yesterday !! Every day showed exactly the same amount of kWh ie 17, 13, and 16. I’ve posted this in another thread though as it seems I’m not the only one with this issue. I just wish these IHD units were properly tested before release, or if the firmware is an issue it should be fixed or rolled back if the previous version was working okay.
Userlevel 5
Badge
Glad to hear you've been in touch, @tonyw707, there is a firmware update due, this should rectify all issues as I'm sure you were advised.

Thanks for your continued patience!
Hi
LOL.
Actually I wasn’t advised which is why I’ve been posting on this forum !!
Userlevel 5
Badge
Ah OK, sorry, @tonyw707, I assumed the agent would have explained this to you when you called in. Things should be sorted soon!
Hi
Well it’s happened again. No electricity showing in the IHD , only gas.
And the readings are way out.
it says my monthly cost is £1.05 for gas and that’s correct but yearly cost is £105. But I’ve had the meters less than a month lol so they should be the same right ?

when is this fix going to be implemented please ?

and will the fix change the historical readings on the IHD ?
the only good news is that the day readings are correct but it doesn’t help budgeting.
Thanks
Userlevel 5
Badge
I'm afraid I can't offer a time frame at the moment, @tonyw707, we are working as quickly as we can on a region by region basis.

Thanks!
Hi
feedback for you - I’ve had the firmware pushed to my IHD and the electric now shows.

However the firmware ware fix doesn’t fix the issue.

My gas gas is still showing as outrageously high and all the previous daylight charge views for electric and gas are still showing me being charged at £1 per kWh.

Can you feed this back please ?






Those prices should be the same because I am still in my first month

thanks
* daylight should read daily
Userlevel 5
That's strange, @tonyw707, it sounds like we need to take a closer look into this. Send us a message on Facebookor Twitter with your name, DoB and account number.

Don't worry if you don't use social media, you can email the team on hello@ovoenergy.com.

Reply