Solved

My OVO isn't showing payment's I've made - why?

  • 4 December 2018
  • 1 reply
  • 105 views

Hi All,

I have recently seen £101 come out of my bank account for my first payable period Oct - Nov just a few days ago. The usage is actually around the £60-£70 mark however On my OVO system it does not appear to show any payments made at all. I should realistically have around £30 extra in credit now. Anyone aware of why this isn't showing?
icon

Best answer by Transparent 4 December 2018, 21:07

Hi @Max Peak and welcome to the Forum.

Are you looking at the My Last Statement page on your My OVO page?

It actually takes a few weeks before this page achieves full functionality, after joining. But if you can get to the 'My Statements section, it means your MyOVO account will be up and running. So any monthly payments should be showing in that section within a few days of the payment date. If it's not, send an email to OVO so they can make sure it reached them: hello@ovoenergy.com.

Tim
View original

1 reply

Userlevel 7
Badge +3
Hi @Max Peak and welcome to the Forum.

Are you looking at the My Last Statement page on your My OVO page?

It actually takes a few weeks before this page achieves full functionality, after joining. But if you can get to the 'My Statements section, it means your MyOVO account will be up and running. So any monthly payments should be showing in that section within a few days of the payment date. If it's not, send an email to OVO so they can make sure it reached them: hello@ovoenergy.com.

Tim

Reply