My V2G charger is not working - kept flashing red and tripped main battery?

  • 24 September 2019
  • 69 replies

V2G charger has not worked since day 1, kept flashing red and tripped main battery and 12 volt battery in car, got harder and harder to turn the car on. Then the fan came on and wouldn’t stop, pressed the emergency stop button 4 times which did nothing, turned it off at the isolator switch in house and haven't dared turn it back on. Sent maybe 10 emails to kaluza reporting every problem but haven’t had reply since I turned it off 4 days ago. I wanted to know if it was safe.

Best answer by Ollie_OVO 30 September 2019, 14:11

View original

69 replies

Userlevel 7
@Sean_OVO and @Ollie_OVO can you guys please step in here and help get @Karlkb15 charger back up and running?

Userlevel 1
@Karlkb15 Hi Karl, thank you for bringing this to our attention and apologies for the delay in getting back to you. I've chased this up with Kaluza Support and they will get back to you today. From our end, your V2G looks safe. We will call you later today and talk you through the reset process.
Userlevel 7
Badge +2
Hi @Karlkb15. I'm not on the V2G Trial, but have been following feedback from participants with interest.

Are you able to give us an update on the fault you've described?
Has it been fixed last week?
Did it require a site visit?

Are you fault-reporting directly to Kaluza technical staff?
I thought your "contract" is via OVO where people like @Ollie_OVO could oversee what's required.

From an outsider's viewpoint, it looks like all the fail-safe systems operated as you would expect. I would be much more concerned if trips and cooling fans didn't operate!

However, it's puzzling that the V2G charger itself didn't automatically send a fault report back to the engineers. Perhaps @Ollie_OVO or @Hari_OVO could tell us if such a feature actually exists?
Still completely not working, not fixed and no engineer planned to come out, they seem very resistant to sending anyone.

Yes I’ve been emailing kaluza directly to fault report, send about a dozen. It’s not worked since day 1.

Still goes solid red and fan comes on and stays on as soon as you turn it on. Unusable. When it did partially work It was tripping the car out and getting harder to turn the car on each day.

Scares the children, they’re young but not stupid, they know red generally means danger, and I’ve turned it off completely for nearly a week. A faulty high voltage box is not something I want to turn on connected to our family home or car.
Userlevel 7
Badge +2
Thanks for the update @Karlkb15 and I'm sorry to hear that things are still not right.

Although I'm sure the Kaluza engineers will be glad to have fault reports to investigate, I'm not sure this would the correct route for a complaint.

Any redress under the Consumer Rights Act relies on who is the other party under the contract. Your energy supply contract will most certainly be with OVO, not Kaluza. So unless those on the V2G Trial have been given a different/new contract with Kaluza, then you'll need to ensure it's OVO Customer Support you contact.

The V2G Product Manager is @Hari_OVO, and he works for OVO in Bristol. That's why I'm tagging him in my responses to you.

As an aside, there are quite a few of us on the Forum here from an engineering background, and we can sometimes help purely from the point of view of being "interested bystanders".

Not all areas of the UK have the same level of mains supply as others. For example, I live in an area where the mains voltage is particularly high. If you filled out your Forum profile, I might be able to glean some background detail from what you say there. As a fellow Forum member, I obviously don't have access to your account details!

I'd also be interested to know where your V2G charger is positioned. Is it outside the house, or within a garage, or inside a heated area?
It’s on an outside wall that gets no sun.

Ive spoke to OVO who told me it’s kaluza I need to deal with.

Its caused a lot of power supply, main battery and 12volt battery faults on the car, which were getting worse until i stopped using the V2G charger, I did ask if it breaks the car or even if I wanted to take it to Nissan to have it checked would anybody pay but got no reply, another reason I’ve stopped using the charger.
Userlevel 1

Updated on 25/05/22 by Jess_OVO


Any issues with a Vehicle to grid (V2G) charger installed by OVO should be raised to our Smart Home team - you can reach them via email: 


Sorry for the delay and I appreciate you may not want to keep turning on the V2G in it's current state, so the likely solution is to send out an engineer who can take a look. If the problem can't be fixed we will look to replace your V2G.

Regarding the red flashing lights, this just means there is a hardware fault. From our end we can assure you the V2G is not unsafe.

Thanks Ollie, it was flashing red everyday 2 weeks ago, but last week it was just solid red.
When i turned it on for an hour at the agreed time last week so it could be monitored, it was briefly green a few seconds, then briefly pink, before going solid red and the fan came on, stayed like that an hour before I turned it off.
Userlevel 7
Badge +2
Thanks @Karlkb15 and @Ollie_OVO; I'm combining what you've both just said so I can better understand how the diagnostics work.

Are we saying that the V2G charger has a main isolator switch to connect/disconnect to the grid?

... and that it's only possible for Kaluza to receive diagnostics across the internet when the isolator is on?

Is that what you refer to as "online", @Ollie_OVO ?

It sounds like the unit needs an intermediate state whereby it's connected to the grid in order to obtain power and feed diagnosis data back to Kaluza, but not in a state where it's expecting to charge an EV. Ie it doesn't need to start up a cooling fan and shout out with a blinking light!

What sort of data can be obtained when @Karlkb15 turned it on for an hour?
Is it insufficient to diagnose the suspected hardware fault?

My interest is not in this particular unit per se. I'm just trying to imagine how such technology would operate in the future when a household might have 3 or 4 Load Control devices which are being handled remotely by the Kaluza Platform.
There is an isolator switch in the house, (a big round red thing in a yellow box), I turned it off there when I got worried.

The kaluza ‘app’ webpage updates in less than a minute and tells me there is a hardware fault ever time I’ve turned it back on, so the charger itself must also update that diagnostic fault to whoever receives the updates from the units? The unit is off now and the kaluza ‘app’ says ‘restore internet connection to continue charging’ if I turned the unit on in less than a minute that message changes to there is a hardware fault.
Userlevel 7
Badge +2
Thanks @Karlkb15 ... that all makes sense to me. Thanks for the clarifications.
Userlevel 7
Hi @Karlkb15 did you get a call yesterday as per @Ollie_OVO message?? Be good to know this has been followed up.

Yes I got a call, they’ve decided they can’t do anything remotely and need to replace it.

Problem is they only work Monday to Friday like me, won’t come in the evening and weekend, my next day off is 23rd December but they can’t book that far in advance.

I work for the NHS and my holidays are pre booked till March next year, I have none left. I took an unpaid day off to get it fitted in the first place but I can’t afford to lose more money.

I suggested I leave it turned off inside so they can replace box on outside but they said no, they said me and car needed to be there, so i then suggested, they come out at 4pm and I’ll be back at 6pm ( because they said it would take 2 hours) but they said they stop work at 5pm, so I then suggested they come out at any time of day and replace it, then come back the next morning at 8am as I don’t leave till 8.40am, but they said no as the engineer was coming from too far away.
That was odd because the 2 guys who fitted it lived less than 10 miles away, but the guy on the phone doesn’t know who they are or where they’ve gone.

so I believe that makes it fitted 1 day, faulty and unable to be repaired for at best the next 96 days.
Userlevel 7
Badge +2
Eh? I don't see how that can be, @Karlkb15

I believe OVO's field engineers work until 6pm. I know I live in a different geographical area to you, but here's a chart (for next week) which I was sent when I recently needed to agree a time-slot for a Smart Meter Engineer to visit:

Never mind what the blue dots refer to, but you can clearly see the final slot is 14:00-16:00

Moreover it is OVO's strategy to have as many of their field-engineers trained as multi-skilled. So instead of just being a "meter installer" they can replace EV chargers, Smart Batteries etc.

@Ollie_OVO - surely you can't afford to have a V2G-charger Test Site offline for all this time?
Wether it’s working or not working, replaced in a timely manner or not, is not important I suppose. It’s a trial, and therefore good experience or bad the information is useful.
No one after the trial would pay to have one of these fitted knowing my experience, I’m sure someone at OVO and kaluza know that.
Going forward they would have to be able to let the charger highlight faults to them immediately, and have people on call outside office hours.
Userlevel 7
Badge +2
Can you provide us with an update @Karlkb15 ?

Have OVO been in touch with you via email or Direct Messaging to find a way to replace/repair your V2G Charger?

Yes, you are absolutely correct to suggest all experience is useful, even if bad. But it would be much more useful if an OVO engineer could now diagnose what's gone wrong!

For example, another V2G Trialist and I have been discussing elsewhere whether the several faults which he's experienced are possibly due to a mains-borne surge/spike.
I was told on Monday in an email from Kaluza, to wait 5 working days for them to get back to me, not had a reply yet.
Haven't had contact from OVO
Still had no contact
Userlevel 6

my install was on Friday 11th unfortunately the unit supplied did not work, have we got a date for a new unit to be installed yet?
Userlevel 7
@Karlkb15 that's not good. Just tagging @Sean_OVO and @Ollie_OVO so they can have a look and see what's going on here....
Userlevel 7
Badge +2

As an interested follower of this Topic @Darran_OVO, when a customer raises an issue like this on the open Forum, does the Social Media Team see stats to tell you how many views this complaint receives?

I’m just wondering how many others are forming an opinion of OVO/Kaluza and your products as a result of @Karlkb15 having posted here?

Userlevel 6

Your going to hate this, but my charger was also none functional from install, just solid red, tried multiple times, still not working. 
I too have had no contact for a replacement from charged EV / Kaluza, I hope I am not having to wait as long as the above, I am really flexible just need the unit changed. 
my unit was fitted 11th October so early days yet , but jumping on the band waggon to push the ball forward before it stagnates. 

Userlevel 7
Badge +2

Hi @D10hul  ; thanks for posting a “me too”.

We don’t “hate it” when things like this get posted on the Forum… but we do like to find answers by pooling our knowledge and experiences.

It would help if you could better define what it is you’ve tried. Little details are going to help here.

For a start, can you please state whether the Installers tested the Charger with your EV on 11th?

And did they leave it charging when they left?

Did you later use the Kaluza App to define your own charge requirements? Or are you just leaving it plugged in and ready for Kaluza to run it remotely?

Do you see any acknowledgement from the EV when you plug the new charger in?

Have you already contacted OVO Customer Services or Kaluza to report the issue?

Don’t assume we’ll all know what you’re referring to, so please avoid being too technical! I don’t have an EV (or a charger!), so I have to guess what you mean by “solid red”. But I assume this is the indicator light on the charger itself - correct?

Finally, please complete your Forum profile. That’s where I look to find out basic stuff like whereabouts you are in the country. Thanks.

Userlevel 6


It wouldn't work out the box, it was declared knackered by the Charged EV fitter, it was never plugged into the car as it never worked, I am just waiting for a new unit, a date is all I am after, I have had no contact but it's early days. 

basicly when the UN but is powered on it boots up but in less than a minute it's solid red with fans running flat out, it's never connected to the internet or Kaluza so I have never had the app. It's just a dead lump on the wall ! 

Userlevel 7
Badge +2

Thanks for confirming that @D10hul

… so I don’t think we’ll spend any more time trying to diagnose that one shall we? :wink:

We’d call that DOA (Dead On Arrival).