Tutorial

How to access your historical statements on the new online account

  • 30 April 2020
  • 3 replies
  • 391 views
How to access your historical statements on the new online account
Userlevel 3

Now you have access to your new online account, you may notice that you don’t see any historical statements showing.

 

Worry not, here’s a quick guide on how to find these!

 

Step 1:

Head over to the ‘Charges’ link on the left hand side of the screen (you’ll find this in the top left menu if you’re viewing the account on your mobile browser).

 

Step 2:

Once you’re on this page, you should see the following ‘migration’ message at the bottom of the screen:

New Upgrade Message

This message will show you the date that you were upgraded to our new online experience and how you’ll see your future statements and charges.

 

Stage 3:

As the message will say, you can find all of your previous statements by choosing the ‘Show my charges and payment history’ option on this page.

 

Like before, you’ll be able to view and download all of your statements in case you want to keep these for your own records.

 

Please be aware that the mobile phone images shown above are what you’d see when using your online account via your device’s internet browser.


3 replies

Userlevel 2

I’ve just been moved over to the new MyOvo. I can only view bills back to February of this year. The migration message doesn’t show at all for me.

How do I get back all my previous bills?

Also in the Usage section I can only see usage for Gas. There is no data available for Electricity.

Userlevel 6

Hey @Jem16, are you looking at your account on the app or on the desktop version?

If the issue is there on the desktop version, please reach out to the team, they’ll take a look into this, if it’s on the app only, it will update in time. 

You can send us a message on FacebookTwitter and our Help centre has online chat! You can reach our team on: 0330 303 5063. Our opening hours are 8am-6pm Monday to Friday.

Thanks! 

 

Userlevel 2

Hi Amy,

The issue is on both desktop and app version. I have been in touch by DM on Twitter and they have acknowledged the issue as they can see it from their end too. I’ve been asked to wait till the 5th in case it’s just taking more time to migrate over.

Reply