Having an issue logging into your online account or app?


Userlevel 7

Updated on 20/10/20: The info in this update box is taken from this tutorial on how to fix login issues with your new online account:

 

Please try this:

If you’re having issues with our app, try deleting and reinstalling - ensuring it’s the latest version. Sometimes this is all it needs to iron out any issues.

And this: 

If you’re on a computer, ensure you’re using Google Chrome as your account is optimised for this browser. Clear your cookies and cache and try login again, here’s how to do that:

  1. On your computer, open Chrome.
  2. At the top right, click More More.
  3. Click More tools and then Clear browsing data.
  4. At the top, choose a time range. To delete everything, select All time.
  5. Next to "Cookies and other site data" and "Cached images and files," check the boxes.
  6. Click Clear data.

 

Still not working? 

If it’s still not letting you in, we’ll need a few details so that we can work out the issue:

 

  1. Are you logging in using your email address or account number?
  2. Are you using the app or the browser version of the site?
  3. Can you send us a screenshot of the issue/error? If not please describe it in as much detail.
  4. How long has this been ongoing for?
  5. What device are you using? I.e iPhone 7, Dell laptop etc.
  6. What software does your device use? This can usually be found in the settings section of your device.

Forward as much of the above info as you can onto the team and they’ll get on it! 

You can reach out to the team on FacebookTwitter and our Help centre has online chat!

 

 


109 replies

I have been an OVO customer since November 2016. Accessing OVO with my Android phone is O/K. Accessing OVO with my laptop via Windows 10 still shows that "onboarding" and that my Electricity supply has been cancelled. (I have had electricity via OVO from Nov' 2016).
I have complained to OVO twice but no progress has been made to improvement to my Windows 10 access via my laptop. One of the main reasons I change to OVO was because of their customer service rating. To date I am not impressed!
Am I the only person with this problem?
Userlevel 5
I have been an OVO customer since November 2016. Accessing OVO with my Android phone is O/K. Accessing OVO with my laptop via Windows 10 still shows that "onboarding" and that my Electricity supply has been cancelled. (I have had electricity via OVO from Nov' 2016).
I have complained to OVO twice but no progress has been made to improvement to my Windows 10 access via my laptop. One of the main reasons I change to OVO was because of their customer service rating. To date I am not impressed!
Am I the only person with this problem?


Sorry to hear that you’re having trouble with this, Patsycamore. The first thing that sprung to mind is that this might update once you’ve received your first bill for both your gas and electricity but it’s odd that this is working on your app but not via your laptop.

This sounds like it’s quite a specific query so it would be best to get one of the Social Team to look into this for you. You can contact them by dropping them a private or direct message via our Facebook or Twitter page.

If any other users have experienced a similar issue, please let us know!

Lucy
I have been with OVO for 6 months now and still get presented with my "Onboarding" screen when I use my laptop to access my account. I have previously contacted OVO by phone more than once about this, but it goes into OVO's black hole, never to be seen again.
Userlevel 7

I have been with OVO for 6 months now and still get presented with my "Onboarding" screen when I use my laptop to access my account. I have previously contacted OVO by phone more than once about this, but it goes into OVO's black hole, never to be seen again.

 


Want me to take a look at this? Send us a message via FacebookTwitter and our Help Centre has online chat. When you do, let me know which internet browser you use, and ideally which version.

Thanks,
Tim

 

The app is not working! Just says Loading and then does not open. I deleted it and re downloaded but its the same. Help would be nice before I run out of credit
Userlevel 5
The app is not working! Just says Loading and then does not open. I deleted it and re downloaded but its the same. Help would be nice before I run out of credit

Ah no! Are you getting a white screen too? I’ve just dropped you a private message so we can get some more information from you to be able to help further.

Lucy
is anyone else experiencing a problem with the app. The balance screen is blank and this is the same when I log in from my home PC.
Userlevel 7
Hi @emceehamster

You will be pleased to know that this issue was resolved over the weekend and a fix put in place on the app to stop this happening.

Hopefully we have now dealt with the route cause of this and we won't see it again. If you are still having issues, please comment below and we will do our best to help.

Darran
Userlevel 7
@gazzoouk Welcome to the forum!

I've moved your topic here as we have already had this reported and I'm pleased to confirm this issue should now be fixed!

Any further problems let us know! Sorry if it caused any inconvenience over the weekend.

Darran
I can not log into the app. It just says loading but doesn't load
I joined OVO on 20 May moved to PAYG smart online straight away and I still cannot view my online account it's really frustrating. I have no idea what my balance is as my smart meter doesn't show anything. Waiting for a callback tomorrow but they promised this would be sorted some time ago so I'm not going to hold my breath!
Userlevel 7
Hey @DanCath

Thanks for signing up to the forum and getting stuck straight in 🙂

We were having issues with the app over the weekend, but I believe that particular issue was resolved a couple of days ago.

Can you try uninstalling and reinstalling the app to see if that removes the issue. If not comment below and we will do our best to help out!

Thanks

Darran
Userlevel 7
Hi @FrustratedKez

Thanks for joining and posting your issue on the forum. Not sure if this is something that other users can help with, but I'm sure @Tim_OVO or @Emily_OVO will be able to support you on this one.

Over to you guys.

Darran
Userlevel 7
I joined OVO on 20 May moved to PAYG smart online straight away and I still cannot view my online account it's really frustrating. I have no idea what my balance is as my smart meter doesn't show anything. Waiting for a callback tomorrow but they promised this would be sorted some time ago so I'm not going to hold my breath!

Hi @FrustratedKez

Thanks for joining and posting your issue on the forum. Not sure if this is something that other users can help with, but I'm sure @Tim_OVO or @Emily_OVO will be able to support you on this one.

Over to you guys.

Darran


Yes I can look into this for you, @FrustratedKez - I'll send you a PM now so I can get started!

Tim
Three days ago I signed up online as I've just moved into a property. The previous owners at the address were with OVO also. I filled out form with meter readings, email and new password etc etc and received the thanks for joining email but it won't let me log in. It says email not recognised. I tried both email and password and also the logging in for first time link. The same.

Regards

Andy
Userlevel 7
Three days ago I signed up online as I've just moved into a property. The previous owners at the address were with OVO also. I filled out form with meter readings, email and new password etc etc and received the thanks for joining email but it won't let me log in. It says email not recognised. I tried both email and password and also the logging in for first time link. The same.

Regards

Andy


HI @andygd

It sounds like we've created an OVO account on our side, but not your online PAYG+ account. The PAYG+ account still might be in the name of the old tenants, which would explain why your email address isn't recognised.

I'll send you a PM now to get some details and get this checked.

Tim
Hi ive been a customer since december and my app has never worked can you look into this for me as ive rung 3 times and been told that its down to technical errors
Hi ive been a customer since december and my app has never worked can you look into this for me as ive rung 3 times and been told that its down to technical errors

I'm sorry to hear you've never been able to use the app, @Scareyvarey

If you send me a PM with your full name, DoB and account number I'd be happy to look into it for you. Could you also let me know what issues you're having when trying to log on/use the app?

Thanks,
Emma
Any one else having problems with OVO app. It won’t accept my email or password ??
Userlevel 5
Have you tried the forgotten password option?

I've just logged in okay so might be a digit wrong.
I can not access the app or going through an online server to top up. Is there an issue today ?
Hi,

Joined OVO a few months ago when I moved into my house. I filled out the switch form thinking I was switching to OVO, the current owners were already OVO users and so my account is stuck in a "Swtich" rountine and both the app and website have me it a "Your switch is on hold" since August 18th. Have spoken to you twice regarding this and was told "technical team" will be looking into this and sending you an email. That was nearly a week ago and no email and no change. Please help.

Regards,
Matt
Userlevel 5
Hi,

Joined OVO a few months ago when I moved into my house. I filled out the switch form thinking I was switching to OVO, the current owners were already OVO users and so my account is stuck in a "Swtich" rountine and both the app and website have me it a "Your switch is on hold" since August 18th. Have spoken to you twice regarding this and was told "technical team" will be looking into this and sending you an email. That was nearly a week ago and no email and no change. Please help.

Regards,
Matt


Hey Matt,

By the sounds of it, the system might have got confused when you tried to sign up your property as OVO are already the suppliers. If you’ve been advised that the Tech guys are looking into this, they will be. 🙂 If if get over 10 working days since you last had an update, I’d advised contacting our Care team (https://www.ovoenergy.com/ovo-answers#contactnumbers).

Hope this gets sorted for you!

Lucy
Userlevel 5
I can not access the app or going through an online server to top up. Is there an issue today ?

Hope this has all been resolved for you now!

Lucy
Hello,
I've been with OVO for almost an year now and this happened several times.
When I try to login using ovo id and password (both in app and pc) it just says "switch on hold" and cannot access anything. Please help.
Thank you,
Alina

Reply