Having difficulty logging into My OVO or the app?


Userlevel 7
Badge +2
  • Community Moderator
  • 757 replies
Are you getting an error message when you try and log in? Not seeing the usual homepage info? There’s different reasons and different solutions, so share below and we’ll work this out together!

23 replies

Userlevel 1
The app is not working! Just says Loading and then does not open. I deleted it and re downloaded but its the same. Help would be nice before I run out of credit
Userlevel 6
Badge +2
emceehamster wrote:

The app is not working! Just says Loading and then does not open. I deleted it and re downloaded but its the same. Help would be nice before I run out of credit



Ah no! Are you getting a white screen too? I’ve just dropped you a private message so we can get some more information from you to be able to help further.

Lucy
is anyone else experiencing a problem with the app. The balance screen is blank and this is the same when I log in from my home PC.
Userlevel 6
Badge +2
Hi @emceehamster

You will be pleased to know that this issue was resolved over the weekend and a fix put in place on the app to stop this happening.

Hopefully we have now dealt with the route cause of this and we won't see it again. If you are still having issues, please comment below and we will do our best to help.

Darran
Userlevel 6
Badge +2
@gazzoouk Welcome to the forum!

I've moved your topic here as we have already had this reported and I'm pleased to confirm this issue should now be fixed!

Any further problems let us know! Sorry if it caused any inconvenience over the weekend.

Darran
I can not log into the app. It just says loading but doesn't load
I joined OVO on 20 May moved to PAYG smart online straight away and I still cannot view my online account it's really frustrating. I have no idea what my balance is as my smart meter doesn't show anything. Waiting for a callback tomorrow but they promised this would be sorted some time ago so I'm not going to hold my breath!
Userlevel 6
Badge +2
Hey @DanCath

Thanks for signing up to the forum and getting stuck straight in :)

We were having issues with the app over the weekend, but I believe that particular issue was resolved a couple of days ago.

Can you try uninstalling and reinstalling the app to see if that removes the issue. If not comment below and we will do our best to help out!

Thanks

Darran
Userlevel 6
Badge +2
Hi @FrustratedKez

Thanks for joining and posting your issue on the forum. Not sure if this is something that other users can help with, but I'm sure @Tim_OVO or @Emily_OVO will be able to support you on this one.

Over to you guys.

Darran
Userlevel 7
Badge +2
FrustratedKez wrote:

I joined OVO on 20 May moved to PAYG smart online straight away and I still cannot view my online account it's really frustrating. I have no idea what my balance is as my smart meter doesn't show anything. Waiting for a callback tomorrow but they promised this would be sorted some time ago so I'm not going to hold my breath!



Darran_OVO wrote:

Hi @FrustratedKez

Thanks for joining and posting your issue on the forum. Not sure if this is something that other users can help with, but I'm sure @Tim_OVO or @Emily_OVO will be able to support you on this one.

Over to you guys.

Darran



Yes I can look into this for you, @FrustratedKez - I'll send you a PM now so I can get started!

Tim
Userlevel 1
Three days ago I signed up online as I've just moved into a property. The previous owners at the address were with OVO also. I filled out form with meter readings, email and new password etc etc and received the thanks for joining email but it won't let me log in. It says email not recognised. I tried both email and password and also the logging in for first time link. The same.

Regards

Andy
Userlevel 7
Badge +2
andygd wrote:

Three days ago I signed up online as I've just moved into a property. The previous owners at the address were with OVO also. I filled out form with meter readings, email and new password etc etc and received the thanks for joining email but it won't let me log in. It says email not recognised. I tried both email and password and also the logging in for first time link. The same.

Regards

Andy



HI @andygd

It sounds like we've created an OVO account on our side, but not your online PAYG+ account. The PAYG+ account still might be in the name of the old tenants, which would explain why your email address isn't recognised.

I'll send you a PM now to get some details and get this checked.

Tim
Hi ive been a customer since december and my app has never worked can you look into this for me as ive rung 3 times and been told that its down to technical errors
Userlevel 5
Badge +2
Scareyvarey wrote:

Hi ive been a customer since december and my app has never worked can you look into this for me as ive rung 3 times and been told that its down to technical errors



I'm sorry to hear you've never been able to use the app, @Scareyvarey

If you send me a PM with your full name, DoB and account number I'd be happy to look into it for you. Could you also let me know what issues you're having when trying to log on/use the app?

Thanks,
Emma
Userlevel 1
Any one else having problems with OVO app. It won’t accept my email or password ??
Userlevel 6
Badge +3
Have you tried the forgotten password option?

I've just logged in okay so might be a digit wrong.
I can not access the app or going through an online server to top up. Is there an issue today ?
Userlevel 1
Hi,

Joined OVO a few months ago when I moved into my house. I filled out the switch form thinking I was switching to OVO, the current owners were already OVO users and so my account is stuck in a "Swtich" rountine and both the app and website have me it a "Your switch is on hold" since August 18th. Have spoken to you twice regarding this and was told "technical team" will be looking into this and sending you an email. That was nearly a week ago and no email and no change. Please help.

Regards,
Matt
Userlevel 6
Badge +2
mat_hoc wrote:

Hi,

Joined OVO a few months ago when I moved into my house. I filled out the switch form thinking I was switching to OVO, the current owners were already OVO users and so my account is stuck in a "Swtich" rountine and both the app and website have me it a "Your switch is on hold" since August 18th. Have spoken to you twice regarding this and was told "technical team" will be looking into this and sending you an email. That was nearly a week ago and no email and no change. Please help.

Regards,
Matt



Hey Matt,

By the sounds of it, the system might have got confused when you tried to sign up your property as OVO are already the suppliers. If you’ve been advised that the Tech guys are looking into this, they will be. :) If if get over 10 working days since you last had an update, I’d advised contacting our Care team (https://www.ovoenergy.com/ovo-answers#contactnumbers).

Hope this gets sorted for you!

Lucy
Userlevel 6
Badge +2
Kay321 wrote:

I can not access the app or going through an online server to top up. Is there an issue today ?



Hope this has all been resolved for you now!

Lucy
Userlevel 1
Can't access yesterday's usage on app, only shows up to Monday, is there a problem or is it me
Hi,

This is not my first message, maybe I'll get some help. I can log into my OVO account, using username and password but it says "Your switch is on hold"(And it's not the first time happening, Tim helped me last time - it seems to be on and off, without any changes on my side). And I've been with Ovo for 1 year now. It's frustrating cause I cannot see my usage (I have smart meter but cannot read it inside the house), I cannot change direct debit if needed, cannot do anything.
Could you help me, please? "I'm in the dark here!"
Userlevel 7
Badge +2
Crystal1296 wrote:

I can log into my OVO account, using username and password but it says "Your switch is on hold"(And it's not the first time happening, Tim helped me last time - it seems to be on and off, without any changes on my side).



There's usually a root cause of some sort if you see this 'Onboarding' timeline after logging in. From what you describe, it seems to be intermittent. Very strange. Can you send us a message via Facebook, Twitter or email (hello@ovoenergy.com) so we can look into it?

Tim

Reply

    • :D
    • :?
    • :cool:
    • :S
    • :(
    • :@
    • :$
    • :8
    • :)
    • :P
    • ;)
    Like most websites OVO Energy uses cookies to ensure that we give you the best experience on our website. If you continue without changing your settings, we'll assume that you are happy to receive all cookies on this site. Accept and Close