Solved

Why am I experiencing MyOvo web page errors?

  • 13 July 2019
  • 4 replies
  • 230 views

Signed up to Ovo 25th May. On the 31st May I received a phone call and an email stating that my details had been shared with another customer, and that my existing account would have to be recreated, that was less than ideal and a great data breach within the first week.

Ovo are now supplying my energy, but logging into MyOvo account page, most of them display this:

"No identifiers.paym in session. Please try again later."

Tried a couple of different web browsers, incase its a Firefox thing, same on all of them.

I've been advised that until the account is recreated this may be the cause, and that I need to make a payment, and set up a new direct debit.

Both of these actions have been completed, two payments were made in one hit, and the DD setup at the same time.

Received an email stating that my latest statement is available (same account number) but this is still what greets me on the page.

If anyone is able to assist, that would be great.

Rob.
icon

Best answer by Nancy_OVO 15 July 2019, 16:34

Hi @RobM357,

First of all I'm sorry to hear about this experience, it's not a great start and we'd really like to put things right.

It certainly seems to me like the issue is pertaining to the DPA breach and the creation of a new account (for which we're also sorry, it's a rare occurrence and a shame this has happened to you). I get the impression they both have the same email address registered to them.

Unfortunately as the Forum is a public space, we can't look into it on here. If you send me a PM with your account number, full name and email address, I can look into it personally for you.

Cheers
View original

4 replies

Hello

This sounds like very poor service from OVO. Have they explained the data breach any more?

As regards your current problem logging in, I assume you have a second, new My OVO ID. Have you tried logging in with this, rather than using your email address ?

Based on what you have said here and if these issues are still not resolved, there are good grounds here to make a formal complaint to OVO if you wanted to.

See:-

https://www.ovoenergy.com/feedback

This may help focus minds at OVO and resolve the issues more quickly.
Hi Phil_H,

Thanks for the response. With regards to the breach, not really; a lot of half answers, and assurances it wont happen again. The fact that it happened at all seems to be being ignored.

I've yet to receive a new customer number, all correspondence I get still refers to the original account and customer reference. I was hoping Ovo would sort this out, but its looking more likely that I'll have to go down the formal route.
Hi

See also this:-

https://www.gov.uk/data-protection/make-a-complaint
Userlevel 6
Badge +4
Hi @RobM357,

First of all I'm sorry to hear about this experience, it's not a great start and we'd really like to put things right.

It certainly seems to me like the issue is pertaining to the DPA breach and the creation of a new account (for which we're also sorry, it's a rare occurrence and a shame this has happened to you). I get the impression they both have the same email address registered to them.

Unfortunately as the Forum is a public space, we can't look into it on here. If you send me a PM with your account number, full name and email address, I can look into it personally for you.

Cheers

Reply