Solved

Why is there no smart half hourly gas usage data on Daily usage section of online account when it was fine before?


Userlevel 5
Badge

Daily usage says “No gas data available”. Monthly usage shows values for each day.  Just starting to analyse gas usage again, against Hive schedule and temperature monitoring before having more energy efficiency work done.

 

 

icon

Best answer by Tim_OVO 14 October 2020, 17:34

Updated on 12/03/21: Missing smart meter readings or usage data on the online account are usually due to a temporary smart meter communication drop out.  See this topic to diagnose meter comm issues with your Aclara or Honeywell/Elster (SMETS2) smart meter, and this topic for your Secure Liberty smart meter. 

Half Hourly usage data missing (daily chart)

These section (which isn’t used in any of your billing or charges) is vulnerable to communication drop outs if something happens to prevent the meter sending your reading for that half hour period. For any missed half hourly periods, the usage will be averaged out once comms has been restored. This shows as a number of bars being the same size. Please be advised that there is a known issue effecting some customers, where half hourly usage information is not populating onto online usage graphs, despite good smart meter comms, and a populated monthly chart. 

Daily usage data missing (monthly chart)

This section can also see communication drop outs, even if there’s half hourly data available that day. It needs a reading at around midnight to be able to populate that day’s usage. If you’re seeing missing usage on either meter for that day, see if any of the half hourly bars are missing for the end of the day. Communication is usually restored by itself, and any missed daily periods will be averaged out when this happens. This shows as a number of bars being the same size. 

You can access your online account via your browser or via our OVO App! Download for Android or iOS

 

Hi @SianiAnni and @Jequinlan 

 

Please be advised that there is a known issue effecting some customers, where half hourly usage information is not populating onto online usage graphs, despite good smart meter comms, and a populated monthly chart. 

 

If you haven’t already, we’d appreciated it if you could make our Support team aware of this, so a ‘case’ can be raised, helping us to identify the volumes of those effected. 

View original

112 replies

Userlevel 7
Badge +2

Hi @SianiAnni  can you see daily usage? It will help us diagnose the issue.

Userlevel 5
Badge

Hi @Jequinlan, as I said, the Month tab shows daily breakdown for gas, but Day tab just says “No gas data available”. I have to go back to 18th August to see half hourly gas data. Half hourly electricity usage is displayed. I have a SMETS1 meter which has been ‘upgraded’, and have been tracking Ovo data for several years, including when we were being shown those lovely graphs with, I think, 5 minute data.  Am I correct in thinking that half hourly granularity of data comes from DCC?  

Userlevel 7
Badge +2

 

Interestingly I think I have the same issue. I think @Tim_OVO is aware of this but i cannot locate the right thread.

Userlevel 7

@SianiAnni can you see the addition I added to @Jequinlan’s answer and let me know the results of that smart meter health check, and also if there’s any daily usage (monthly chart). 

 

Any change with you and half hourly usage @Jequinlan

Userlevel 5
Badge

@Tim_OVO  My SMETS1 Secure Smart Meter Health Check:

  1. MPAN number of meter still matches that in my Ovo account.
  2. WAN connection - 2 to 3 flashes
  3. The HAN is not connected. It was not useful after the first week, so it has been put away.
  4. The meter was commissioned and was working as expected until 18 August 2020.
  5. Gas meter showing a reading. 
Userlevel 7
Badge +5

Hi @SianiAnni - you’ve been ever so quiet for a long time. Hope you’re OK?

@Tim_OVO- do you see the problem with the SMETS1 meter health-check not stating what flash-rates are “normal”? I mentioned this just an hour ago over here. SianiAnni has quite properly reported “2 to 3 flashes” whilst none of us know what this means!

We don’t even know over what period the reported flashes occur.

 

The HAN is not connected.

That’s the IHD not connected.

The HAN is still operational because the gas meter is using it! :slight_smile:

 

And @SianiAnni we’re discussing the anomalies of the Usage-data here on the Topic about Online account daily usage feature.

Just because the histograms sometimes report “No gas data available” in the Half-Hour sub-page doesn’t mean that a reading hasn’t been collected for the daily total - and vice versa.

It seems that these readings are held separately within the Comms Hub memory, and retrieved independently by the uSmart software which delivers them to OVO.

Userlevel 5
Badge

Hi @Transparent, yes I’m fine thanks, just got incredibly frustrated that I couldn’t  access my Ovo usage data and feed in to other monitoring streams (a csv file would be better than nothing, but an api to automatically log would be preferable!), so decided to forget about it all for a while.

But I’m hoping to have some more retrofit done on my house soon, and was really hoping that I could pick up the monitoring, to get an idea of before and after performance. But when I went to have a look at my gas usage, now that heating is on every day, I found nothing in the Day display since August 18th. So my problem isn’t that there are gaps, but that it stopped mid August and never restarted. Something along the food chain needs a restart, but what? You 

The health check for my Liberty meter says WAN flash rate of 1 flash every period is a poor signal, while 5 flashes in a period is as good as it gets. And the period is around 5 seconds. If you get more than one flash then a gap, it’s easy enough to deduce the period. So although my signal’s not great, there is definitely a signal.

You mention “held separately within the Comms Hub memory, and retrieved independently by the uSmart software”.  Can @Tim_OVO  or someone check whether my half hourly gas usage is reaching Ovo at all? 

Userlevel 7
Badge +2

@Tim_OVO sadly. Its not working!

 

.. still.

 

Interesting its ALSO stopping my ability tonsee the energy apotlights on the app!

Userlevel 7
Badge +2

@SianiAnni i have great news about being able to download data. I am about to publish in a day or so a windows app that allows you to download ALL the account data usage for gas and electricity into an easy file!!!

 

 

Userlevel 5
Badge

Thanks! Sounds promising. Will certainly take a look at it.   

Userlevel 7
Badge +5

@SianiAnni wrote:

You mention “held separately within the Comms Hub memory, and retrieved independently by the uSmart software”.  Can @Tim_OVO  or someone check whether my half hourly gas usage is reaching Ovo at all? 

I’ve found a way to check this for myself.

Go to the Month-histogram and click on a vertical bar to open up the Day-graph with its HH readings.

Click the forward arrow to take yourself forward a day at a time.

Quite often you will find that there are days where there’s a lot of HH data, but no bar on the Month histogram for that day.

Once on the Day-graph you can switch between elec and gas too. You don’t need to return back to the Month histogram to do so.

Userlevel 5
Badge

I’m getting the opposite. Bars on the Month histograms for each day in August, September and October (up until yesterday). Paging through the Day histograms, there is gas HH data up to August 19th. Checked each day since then and no gas HH data. That’s no gas HH data for 50+ consecutive days. It’s not intermittent, it’s not the odd day’s worth or few hours missing. It has stopped! 

Userlevel 7

@SianiAnni i have great news about being able to download data. I am about to publish in a day or so a windows app that allows you to download ALL the account data usage for gas and electricity into an easy file!!!

 

Wowza @Jequinlan keen to hear how this lands in the vast API topic…. you might be a popular guy by the end of the week :stuck_out_tongue_winking_eye:

 

I’m getting the opposite. Bars on the Month histograms for each day in August, September and October (up until yesterday). Paging through the Day histograms, there is gas HH data up to August 19th. Checked each day since then and no gas HH data. That’s no gas HH data for 50+ consecutive days. It’s not intermittent, it’s not the odd day’s worth or few hours missing. It has stopped! 

 

Thanks @SianiAnni this is really helpful. You seem to be in the same camp as @Jequinlan - meters communicating but HH readings not possible. 

 

Let me raise this scenario with our developers to see if it's a known issue with a known solution. I WILL BE BACK as they say 

Userlevel 7

Updated on 12/03/21: Missing smart meter readings or usage data on the online account are usually due to a temporary smart meter communication drop out.  See this topic to diagnose meter comm issues with your Aclara or Honeywell/Elster (SMETS2) smart meter, and this topic for your Secure Liberty smart meter. 

Half Hourly usage data missing (daily chart)

These section (which isn’t used in any of your billing or charges) is vulnerable to communication drop outs if something happens to prevent the meter sending your reading for that half hour period. For any missed half hourly periods, the usage will be averaged out once comms has been restored. This shows as a number of bars being the same size. Please be advised that there is a known issue effecting some customers, where half hourly usage information is not populating onto online usage graphs, despite good smart meter comms, and a populated monthly chart. 

Daily usage data missing (monthly chart)

This section can also see communication drop outs, even if there’s half hourly data available that day. It needs a reading at around midnight to be able to populate that day’s usage. If you’re seeing missing usage on either meter for that day, see if any of the half hourly bars are missing for the end of the day. Communication is usually restored by itself, and any missed daily periods will be averaged out when this happens. This shows as a number of bars being the same size. 

You can access your online account via your browser or via our OVO App! Download for Android or iOS

 

Hi @SianiAnni and @Jequinlan 

 

Please be advised that there is a known issue effecting some customers, where half hourly usage information is not populating onto online usage graphs, despite good smart meter comms, and a populated monthly chart. 

 

If you haven’t already, we’d appreciated it if you could make our Support team aware of this, so a ‘case’ can be raised, helping us to identify the volumes of those effected. 

Userlevel 5
Badge

I’ve logged it with the support team @Tim_OVO .

 

Userlevel 7

I just posted this comment (below) on a related topic and wanted to share here:

 

 

“I had a meeting with @Transparent yesterday (I still need to see your latest post on your usage graph, it’s on my list), where we discussed the online account usage graphs, changes being made by developers, forum members providing examples of issues, and the disconnect between the two. I will do my best (either today or early next week) to propose closer cooperation to allow issues, changes and causes to be linked together more effectively. 

 

In the meantime, we have an update for users of the online account on their mobile:

 

 

 

 

Billing platform mobile usage display

 

Members on our latest platform (90% of members) accessing online accounts via mobile phone will now see one vertical chart displaying their consumption on the Usage page. This has replaced tables and graphs. You can switch between gas/elec and kWh/£ on the chart with the Energy Settings toggles

 

You’ll still be able to view comparisons between months and years as a table using comparison buttons below the chart.

 

This is being rolled out gradually so some members may still see the old version. 

 

Userlevel 5
Badge

@Tim_OVO I still have no half hourly gas usage data since Wednesday 19 August. It’s 26 days since I first posted this issue on this forum,  and 20 days since I raised it with support, and I haven’t heard anything after acknowledging receipt of my issue. I’m guessing that no-one at Ovo as managed to understand the problem yet, let alone been able to fix it. 

Userlevel 7
Badge +5

Hi @SianiAnni - I was pondering this issue with @Tim_OVO yesterday afternoon.

I’ve concluded that there is more than one technical issue which causes so many of us to have faulty gas-usage data.

However, these issues could be in different places and may be interacting

  • software in the gas meter
  • software in the Comms Hub
  • the uSmart software which OVO licenses to communicate with DCC
  • the new Billing System software

So there seems little point in just having the Orion Dev-Team trying to analyse what we’re reporting. They have no idea when the meter manufacturer or OVO’s own Smart Meter engineers make changes to our on-site firmware of course.

This means we’re all working in the dark.

I have again asked @Tim_OVO if we can have a small symbol somewhere on our online Usage-pages which can be clicked to show us the current software version numbers and the date of the last upgrade to that version. This must be done for all the relevant locations where the gas data might be getting blocked/mangled.

Userlevel 5
Badge

Thanks for the update @Transparent.

I don’t know if I mentioned this before, but it’s possible that it’s relevant.

I have given Carbon Co-op permission to access my energy usage data, via 3nergy. The Carbon Co-op graph (below) and download also show no gas data after Wednesday 19 August.

 

I’ve kind of lost track of the communication path between my meter and OVO although I know that it’s different for half hourly data v daily.

Through another Carbon Co-op project I am also logging electricity usage directly from the meter into an emoncms database.  Unfortunately gas data couldn’t be collected and logged in the same way (pulse meter?).  

I’m guessing that this only indicates that the problem is unlikely to be internal to Ovo, but that still leaves meter, uSmart interface. I’m not sure I know where the Comms Hub sits in the communications path.

Userlevel 7
Badge +5

And from where do Carbon Co-op pick up this information?

From the Data Communications Company?

Or from the Energy Supplier (OVO)?

I believe this should have been stated in the agreement you’ve made with them.

Userlevel 5
Badge

Carbon Co-op get data via 3nergy from DCC. The agreement is with 3nergy.

Userlevel 7
Badge +5

Thanks @SianiAnni - are you on SMETS1 or SMETS2 meters?

@Tim_OVO- this is hugely significant information. Please notify both Ben S and the Orion Dev-Team of what @SianiAnni has just posted here.

If something is occurring on-site which prevents gas data getting to DCC, then this needs checking first. Note also that she’s in Northern Territory . This may or may not be significant, but we need to amass all possible evidence on the table before starting to build the jigsaw.

Userlevel 5
Badge

SMETS1 Liberty EG4v 10 SECURE. I can’t remember when the SMETS1 software upgrade took place, but I have half hourly data going back to April 2018.

Userlevel 7
Badge +5

Great. Thanks. It was installed as a SMETS1

So @Tim_OVO the date of 19aug20 needs checking with Ben. This is very soon after the start of the migration process for Secure meters (30july20). I thought OVO were going to do all the customers on PSR first.

When did Secure themselves download the SMETS2 firmware into this meter?

When did OVO start the migration to the National Smart Meter Network?

Userlevel 2

Hi Guys,

Our hh readings have also dropped off since 19th August. I spoke with the support team over a week ago who said that someone would be in touch by email which hasn’t happened yet. 
 

I’m fairly sure we’ve got a Secure smart meter too. 
 

I miss the live usage data but the hh usage was just about enough to check on the heating/hot water usage.

 

whilst I’m sure adding to an existing post probably isn’t the most ‘correct’ way of adding this I’m hoping this might be able to add information to the existing issue in the one place. 
 

Is there any idea when the hh data might start to re-appear?

 

here’s in hope and many thanks in advance!

 

Rich

Reply