Solved

Why have I lost the yearly view and comparisons on my online usage graphs?


Userlevel 1
  • Carbon Cutter***
  • 4 replies

From day one with OVO I have been able to see annual data and comparisons, rather than daily useage.
It would appear that this functionality has been removed in preference for daily data returned by smart metres. I for one am not intending to micro-manage my energy consumption and am happy to check long term deviations and so spot increasing annual costs so I can budget accordingly.

When questioned I am told this is probably due to issues at my end - wrong browser, clogged cache, and so on. Nonsense.

 

You tell me that by clicking on usage that the options to see year on year comparisons should appear - they do not.

 

When I go to the help centre and ask for my annual statement there is a check your yearly energy use box, which when clicked on re-routes me back to my monthly energy use in and endless loop.

 

So broken links?
Update issues?

Is this something other folk are having issues with?

What was a first rate site seems to be having issues with the latest update and basic functions either broken or deliberately removed … 

 

icon

Best answer by Jess_OVO 2 June 2021, 13:04

View original

47 replies

Userlevel 7

Great work - @Blastoise186. Knew you’d figure this one out! :slight_smile:

 

And some very fair feedback on the availability of the comparison feature when logging in to the OVO app rather than the browser version of your online account@Hongkongandy - I’ve passed this one on to the team as we’re always working on these features so any feedback is really valuable as we make improvements in future.

 

Have you had a chance to check out the Greenlight feature yet?

Yep your right! Was expecting the app to give comparisons!  ( why not) 

logged into the Ovo www and comparisons available. 

Userlevel 7
Badge +4

Howdy!

I’m afraid I can’t reproduce this issue myself with Raichu set to Half-Hourly Mode and the following browsers:

  • Google Chrome 94 (Windows 10 using Stunfisk)
  • Mozilla Firefox 92 (Windows 10 using Stunfisk)
  • Microsoft Edge Chromium 94 (Windows 10 using Stunfisk)
  • Google Chrome 94 (Android 11 using Oshawott)
  • Chromium 93 (Ubuntu 21.04 using Magnetmite)
  • Mozilla Firefox 92 (Ubuntu 21.04 using Magnetmite)

Please can you tell me what web browser you’re using by any chance? If you’re using Internet Explorer, then I’m afraid that browser is unsupported. Please make sure you’re using either Google Chrome (recommended as it’s the most tested by OVO), Mozilla Firefox, Opera Chromium, Safari or Microsoft Edge Chromium. If you’re using one of these browsers, then I can definitely try to help you dig deeper, but if you’re not using them then I’m afraid it might not be possible to fix.

The only side note is that the OVO Energy app doesn’t currently support usage comparisons at this time. It’s definitely something that can be suggested though if you’d like to see that in the future.

I have smets2 and cannot see any toggle to get comparisons on previous months/years?

Userlevel 7

Hi @Hongkongandy and welcome to the OVO online community,

 

Great question to ask about the features available on the usage pages of your online account. I’m wondering if you’ve noticed a change to this feature recently as there was a related discussion we had on this a few months ago, which I’ve now moved your comment over to.

 

As the best answer above advises the expected features available do depend on your meter type:

 

Smart users (with exclusively smart meters) will see tabs to toggle between views - they can view daily, monthly and yearly usage.

 

Traditional users (with exclusively traditional meters) will not see the tabs as they can only view yearly usage.

 

Mixed meter users (with both types) will not see tabs, but they do see the drop down (within the navigation menu on the left) - they can view yearly and monthly.

 

Does this reflect what you’re seeing there?

 

I’m sure our resident bug-hunter @Blastoise186 would love to help get to the bottom of this if not….

I do not appear to have the comparison function anymore, has this been removed? 

Userlevel 6
Badge +1

Sorry for the delay in getting back to you on this one, @Jeffus - something strange certainly seems to be going on here.

 

I’ve checked in with the team to see if there are any known bugs which could be causing the inconsistencies you’re seeing between the different views of your usage pages and it looks like this could be a new one. 

 

In order to get to the root of the cause it would be best to contact our Support Team, who’ll have full access to your account and can raise this one to the tech team if it’s not something they’re able to resolve.

 

Let us know how you get on - we’d love to hear if you notice these corrections rectify themselves. :slight_smile:

July sorted itself out in August.

April still the same issue.

It is not a big issue as the bills were fine.

Perhaps it is the system assuming some average reading for the days prior to me joining OVO when calculating the costs on the electricity yearly view?

August seems OK.

On a separate point the Direct Debit Calculator is useful. Adding the Kwh figures as well as the costs i think would be useful, either on the Direct Debit Calculator or elsewhere to see a forward view of Kwh. I think for us the Direct Debit calculator is assuming too high a usage in summer and too low in winter. Of course every house is different. Be interesting to see after 12 months

Userlevel 7

Sorry for the delay in getting back to you on this one, @Jeffus - something strange certainly seems to be going on here.

 

I’ve checked in with the team to see if there are any known bugs which could be causing the inconsistencies you’re seeing between the different views of your usage pages and it looks like this could be a new one. 

 

In order to get to the root of the cause it would be best to contact our Support Team, who’ll have full access to your account and can raise this one to the tech team if it’s not something they’re able to resolve.

 

Let us know how you get on - we’d love to hear if you notice these corrections rectify themselves. :slight_smile:

Userlevel 6
Badge +1

For me.

For electricity the Kwh and cost figures dont align on the Usage page.

Impacts April and July. The cost figure is too high for April and too low for July. 

April was low for kwh as we joined that month. 

Kwh for electricity used is fine for all months. It is the costs that seem to have got confused, including the total cost for the year on the usage page which is high. 650.8kwh doesn't cost £131.35

Same issue on website and app. 

 

Ah…

If I look on the monthly page the July costs look fine... 

​​​​​​

​​​​​​And here is the April costs on the monthly tab

​​​

Userlevel 5
Badge +1

@Jess_OVO Any reference to an invalid date has now been resolved & it now populates with the correct data, i also still have the comparison tab 👍 yey 

All good & no issues across both my accounts now 👌

 

Tom…

Userlevel 7

So just a heads-up - The team thinks they’ve sorted the ‘Invalid Dates’ bug now, @TomThumb

 

Have you checked your usage graphs yet today? - Hoping this is the final fix!:fingers_crossed:

Userlevel 7

Thanks for updating us on the remaining bug, @TomThumb.

 

Just wanted to let you know I’ve passed this one on to the team and will pop back here to update you when I hear more. :ok_hand:

 

Userlevel 5
Badge +1

Unfortunately @Jess_OVO the invalid date issue has not cleared after a browser refresh 🙈

Running a clean instance of Firefox & cache cleared on chrome,

I’m still getting the invalid date for the year view on both accounts.

 

The good news is, the previous missing date for my last meter reading on my traditional gas meter account has been resolved, the info box under the graph chart, now has no reference for this data.

The line of

your last meter reading was submitted on ?? 
has now been removed completely 👍 

Tom…

 

 

Userlevel 7

Thanks for letting us know the ‘Invalid Date’ bug is still not sorted, @TomThumb

 

The team have recommended that you should restart your browser or do a force refresh, as they hope that should resolve the issue. If not keep us posted as we can look into this one further. :thumbsup:

Userlevel 5
Badge +1

Morning all @Blastoise186  @Jess_OVO  @knight @darkness 

For confirmation, both my accounts are showing invalid date on the year tab view.

The comparison tab is up & running with no issues across both accounts.

As knight has mentioned, my traditional gas meter account now has the ability to show the date of the last meter reading in 2 locations, but the info box under the graph has no entry.

 

On a side note @Blastoise186  the usage on my gas only account hasn’t changed over the last 8 months, although my monthly bill reflects the zero usage & even the graph dose drop back to zero eventually, it doesn’t stop Orion from taking a wild guess every month 😀😀😀

 

Tom…

 

Userlevel 7
Badge +4

Excellent!

If it’s fixed for us, then there’s a good chance it’s fixed for everyone. Let me ask @Simond to see if he can check as well, along with the ultimate test… @TomThumb could you take a look when you’re free?

I’m late replying to this :cry: but I get the same as @knight. I don’t have a smart meter either and am now seeing the yearly by month figures, which is what I wanted.

Thanks to @Blastoise for pushing Ovo so hard on this.

Userlevel 7
Badge +4

Nice. That’s good to see then. Admittedly it’s not quite been the smoothest rollout for this type of change but I know from experience that this forum gets used as part of the telemetry that helps to flag up these sorts of issues (alongside all the other stuff). And the teams are usually pretty quick at realising something messed up!

This is probably another good thing about how MyOVO is built in-house as well in a way. If OVO had bought the system in from a third-party, we’d have to wait for that third-party to not only fix the bug, but also wait for OVO to get the fix which can take a while. I’ve been there.

I’m not seeing any other obvious bugs right now so I suspect the showstoppers are gone for now. But yeah, I’ll be giving this thing a really heavy stress test or two overnight, just in case.

Userlevel 4
Badge

Thanks to all. As mentioned, I don’t have a smart meter yet and so should have only been seeing the yearly by month figures. Happy to report that I’m back to seeing those again.

Though I note that the page no longer knows when I submitted my last reading (which was at the weekend).

Userlevel 7
Badge +4

I’ve actually just had a Private Message from someone at OVO a few minutes ago.

They asked me not to reveal themselves which is understandable, but they have allowed me to share an update on this bug. Naturally however, rules don’t apply to this AI SkyNet Blastoise and I smash them up just like I smash up everything else! So, there’s only one person at OVO who would have asked to remain hidden and can totally trust me to keep it that way. Isn’t that right… @Jess_OVO ? :rofl:

I couldn’t possibly know who this anonymous @Jess_OVO is! :innocent:

I’ve had confirmation that this entire bug is definitely on the radar to be fixed and that this thread is indeed being monitored actively by the team who’s been working on these upgrades recently. They actually managed to fix the fix that I broke almost as fast as I broke it. If anyone manages to break it again, please let us know here and the team will be notified if needed.

Userlevel 7
Badge +4

No worries! It’s definitely better than leaving you totally stuck with no access!

I’m only a forum volunteer myself and other than helping out on this forum as a volunteer, I don’t work for OVO myself. I wouldn’t be surprised if a job offer gets sent my way some day though. XD

However, I can say that I have built up a reputation for smashing up OVO’s stuff and in some cases actually helping to fix them. But most of my fixes end up breaking more stuff. Sorry! :stuck_out_tongue:

It’s not technically possible for one person to turn off every smart meter at once - DCC just acts like a network but they can’t actually control meters once they’re commissioned, since control gets passed to the active supplier. If the network went down, all smart meters would continue to work, they just won’t be able to use smart features for a while.

Do you definitely have smart meters? If you don’t have smart meters at all, or have a smart electric meter and a traditional gas meter, you might not see the tabs at all, but the sidebar options should work - and those are THE most critical factor. I suspect the Tech Team are probably actively monitoring this thread because Jess hadn’t reacted by the time the latest sub-bug got fixed. This is why it’ll probably help to keep everything related to this particular bug in the same thread for now, just to make it easier.

I also wonder what happens if your smart meters are in either Half-Hourly, Daily and Monthly mode. That could also be relevant in some way...

Userlevel 1

Delighted to report a partial success: I have now got back annual comparisons as default, but there is still is no sign of the three options - Year, Month, Day - that you show earlier at the very top.

 

Must say I’m most impressed by the work you guys are doing on this … and hope the next rewrite will finally let you move on.

Computing and functionality and naughty games played by the giant corporations has become such a complicated matter - I’m just waiting for some malevolent operator to turn off all the smart meters!

Ho hum.

Userlevel 7
Badge +4

Ah ha! Perfect. That bug has been fixed as well. Nice. XD

Could you double check that everything’s working as well please @knight @darkness and @MBA ? If things are still broken, please give us a shout and I’ll ask for this to be flagged up again.

But if it’s all working fine now, it would be great to get a thumbs up as well, so that we know it’s not just fixed for me.

Sorry it took a while to get these pesky critters squashed!

Userlevel 7
Badge +4

Takes a look and smashes the fix to pieces in under 10 seconds flat!

Unfortunately @Jess_OVO that fix may have made it even more broken than before! I’m not sure if it’s just because the fix is still being implemented via multiple Commits and the latest Deployment to MyOVO is based on one of those Commits where the full fix hasn’t been implemented yet but…

Neither of the buttons works right now - Monthly or Yearly. However, going to just /usage without /monthly or /yearly on the end does work as per the previous behaviour - so this seems like a possible regression.

Could you ask someone to flip the switch again please?

On the plus side, the buttons do now at least lead to /monthly and /yearly as intended, so at least that existing bug is technically squashed. But in doing so, caused the HTTP 404 bug. Sounds like they don’t redirect properly!

Userlevel 7

Back with an update from the team on this one - they have been working on this feature so sounds like a bug crept in there whilst they were making the changes (hopefully this should have already been fixed).

 

They did also explain that the usage views available do depend on your meter type - 

 

Smart users (with exclusively smart meters) will see tabs to toggle between views - they can view daily, monthly and yearly usage.

 

Traditional users (with exclusively traditional meters) will not see the tabs as they can only view yearly usage.

 

Mixed meter users (with both types) will not see tabs, but they do see the drop down (within the navigation menu on the left) - they can view yearly and monthly.

 

 

Anyway, great to see a community forum being well used and hopefully the problem will be easy to fix.

 

A good community forum goes a long way towards customer satisfaction. Though I should say that I’ve never joined before because I’ve never needed any support before - that doubtless says something important about Ovo. :smile:

 

And we whole-heartedly agree with this one - so nice to have so many active community members here to help us improve our online features. Bringing all your technical expertise to the table, we really are incredibly grateful to have you here to share your knowledge and ultimately play a really important role in our journey to Plan Zero - we couldn’t do it without you! :relaxed:

Reply