Solved

Why have I lost my daily cost data on my OVO usage pages since starting a new plan? BUG FIXED

  • 26 January 2022
  • 44 replies
  • 651 views


Hi all,

My fixed term plan was renewed for a further 12 months starting on 20th January 2022. 
 

Since then, my OVO app shows me the usage data on a daily basis in terms of kWh for gas and electricity but will no longer show me the daily cost as it did before 20th Jan, the bar charts are blank for those days. 
 

I’ve never had this happen before in previous years when my plan remewed, my IHD is still working and my smart meter is still sending data to OVO so I’m at a loss as to why the cost data is missing. With prices having shot up, it’s really important that I can keep track of the daily cost of the energy I’m using.


Has anyone else experienced the same issue?

 

thanks

Sarah

icon

Best answer by Jess_OVO 7 March 2022, 13:06

View original

44 replies

Userlevel 7
Badge +1

Hiya @SarahD !

That’s a bit strange. What phone do you have, and what version of Android or iOS are you on? If you could also go into the app and tell me the App Version and CodePush Version under Account > App Info, that would be great.

I’ll see what I can figure out from there.

Thanks - I’m on IOS 15.1.2, iPhone xs 

The OVO app is version 14.1.0,  and codepush v319

 

Everything is working as normal on the app, it’s just cost data from the date my plan renewed that’s missing. Strange!

Userlevel 7
Badge +1

No worries. Let’s try the easiest fix first.

Your app is actually behind a bit on the CodePush Version, but updating it is easy. While you can update the app itself from the App Store, CodePush updates work differently. I did a blog a while ago that explains more.

Let’s try to force a refresh. Could you quit the OVO Energy app using the recent apps switcher (swipe the app away so that it’s gone from the list) and then relaunch. It should force a refresh and might fix the issue.

See how that goes. If it still doesn’t work out, I’ve got more options yet.

Thanks for the suggestion!

I have quit the app completely and rebooted my phone but the codepush version is the same and nothing has changed.

I should mention that the same issue with the missing cost data also appears when I log into my OVO account from a browser and not just on the phone based app. 

Userlevel 7
Badge +1

Gotcha!

I think I know the problem now. Daily costs are actually shown in the Monthly tab, rather than the Daily tab.

Daily shows Half-Hourly, Monthly shows Daily and Yearly shows Monthly. Please also make sure your Smart Meter is in either Daily or Half-Hourly mode to view these levels of usage data. If you’d like to change that setting, the Support Team can give you a hand.

Does this work for you? If not, then this might suggest a completely different issue.

Thank you, yes I know that daily costs are shown in the monthly tab, that’s where I have always found them. I just have blanks for every day since 20th Jan as in screenshot…  None of my meter settings has been changed to prevent the data showing. So frustrating!

 

Userlevel 7
Badge +1

Hmm… Sounds to me like some additional diagnostics are needed on your account, which goes beyond what I’m able to do on the forum. Could you have a chat with the Support Team about this? They’ll probably need to go through some other steps with you and it may take a while to get this sorted out. But it sounds like a good MOT of your entire account should get things fixed up.

Thanks for trying anyway.

 

My thought is that this is a simple account issue - the fact that the lack of cost data has happened since the day I switched over to a new fixed term plan suggests that OVO has not put the details of my new plan into its system. So, whilst my app/browser can register kWh as this is not affected by cost, it can’t register cost because it hasn’t been ‘told’ by OVO what unit price to apply to my energy use on the new plan.

Userlevel 7

Sorry to hear that you’ve noticed some missing usage cost data since your renewal, @SarahD.

 

Sounds like a similar issue which was raised by @CinderKona over here:
 

 

We’d recommend forwarding that screenshot over to the Support team, which should help them investigate and resolve any technical issues. Are you still able to see you daily usage costs being deducted from your account balance?

Userlevel 2

Yea, the same as me. Not sure why it is so difficult to resolve. Mine is not showing in the app (iOS, Android), or web.

Kw/h are meaningless unless I know the £ value, especially with fluctuations in prices.

I agree @CinderKona, I have been round the houses with support this morning who told me it was an issue with my IHD despite me being clear that the IHD was working fine. It seems to be to be an account issue that is preventing the usage in kWh being converted into costs. And in my case, I don’t think it is a coincidence that the issue started on the day my account moved over to the new 12 month plan where unit costs are much increased from the last 12 months (as they are for everyone!)

 

Thanks @Jess_OVO yes I am still seeing my balance go down every day, it’s just the bar graphs of daily costs I’m missing. I keep a close eye on my energy costs so not having this data available is really frustrating.

Userlevel 2

I was a new user since March 2021 then after moving to a plan the £ data was , no longer available. 

I work in IT so I don't understand why 4 weeks and before that 8 months since reporting it it is still not fixed. IHD working fine.

Userlevel 7

 

Thanks @Jess_OVO yes I am still seeing my balance go down every day, it’s just the bar graphs of daily costs I’m missing. I keep a close eye on my energy costs so not having this data available is really frustrating.

 

I totally appreciate the frustration, @SarahD and @CinderKona.

 

It’s not what we’d expect to happen even given a change in tariff information and we understand the importance of closely monitoring your usage costs. As this one might require account-specific fixes we’d encourage you both to contact our Support Team to report the issue. By providing a screenshot (which can be attached to an email to hello@ovoenergy.com) our Support Team should have all the information needed to raise the issue to our tech team.

 

I’m hoping this helps get things resolved for you both.

Userlevel 2

I have contacted support a dozen times now. 

I have same problem since going onto a new plan.

Userlevel 7
Badge +1

Hmm… This is starting to sound more like a bug that’s not just an account specific one. While I still echo the advice Jess has given in a previous comment, I’ll summon @Tim_OVO and @Jess_OVO again for you, just in case they can help further.

Userlevel 2

It's not related to the a specific media (iOS, Android, Chrome, MS Edge) etc as I use all of them, the ,£ is missing as a calculation of kWh figure. And has been since I changed to direct debit.

Yes, same here. I’ve gone back to support who say they have raised an issue with the tech team but not looking too hopeful so far, I seem to be struggling to get across that it’s nothing to do with whether my account works and it’s not a log in issue, and that the same thing happens on app/browser whether I log in from phone, iPad, mac or windows computer…

Not sure why this thread is now showing as solved - the issue that several of us have raised has very much not been solved…

Tech support have not fixed the issue, they seem to have given up! 

Userlevel 2

Not solved as far as I'm concerned. I sit here in my home office staring at my IHD which has both £ and kWh values but is never displayed on my account.

Really, how hard can it be for the technical team to correct this. 

Definitely not solved I’m still only getting kw usage on my app web login on various devices through different types of browser.

the alternative app called bright does give me costs though.

Userlevel 7
Badge +1

Question threads are marked as solved on this forum when there’s a good answer to the original question that helps both the OP and anyone who stops by. It does not reflect whether the original issue is actually solved or not, since that’s a different matter.

Either way, threads are generally kept unlocked anyway so please feel free to disregard the status and keep the discussion going. Best Answers can always be updated or re-assigned later by a moderator if needed.

Blastoise186

Was there a resolution to this issue? My new contract started 2 weeks ago, and ever since I can see kwh, but no charges are showing online or through the app.

No, I haven’t had a resolution, the tech team seemed unwilling to engage with it and said it was an account specific issue that had no timeline for resolution. It’s clear from this forum that there are a number of us experiencing exactly the same thing so the lack of appetite from support to get this resolved is pretty disappointing…

Ok, thanks for that, I'll try raising the problem officially to see if that can get it resolved.

Reply