Solved

Why can't the OVO app Fingerprint login be switched on?


Userlevel 1

Hi

I’m using the Ovo app on Android, on a Pixel 4a.  I have fingerprint unlock enabled on the device, and it works for other apps, eg banking.  When I try to enable it in the Ovo app (Account, Login preferences, Fingerprint), I get taken to the screen with a slider to turn it on.  This slider doesn’t work, when I tap it or slide it, it just pops back to the left (Off) position.  App version 14.0.0, CodePush version v319.

Please can you fix this? Logging in with a fingerprint would be so much easier than typing my long complex password with fat fingers.

Thank you.

 

 

icon

Best answer by Jess_OVO 19 January 2022, 11:37

View original

12 replies

Userlevel 7
Badge +3

Heya @FunkyFerret55 !

Thanks for that one! It sounds to me like it might be an issue specific to Google Pixel devices, as it’s working fine for Oshawott, my Samsung Galaxy A52s.

However, I think you’re probably right, so I’ll ask @Tim_OVO and @Jess_OVO to flag this up with the Tech Team.

To make it a little easier for them, I’m going to re-format your bug report. Please could you verify this is correct? If I’ve made a mistake, please feel free to let me know and I can edit the details below. :)

What’s the problem?

Fingerprint Login for the OVO Energy app isn’t working on Google Pixel 4a

How can I make it happen?

  1. Use a Google Pixel device, such as the Google Pixel 4a
  2. Attempt to set up Fingerprint Login under Account > Login preferences > Fingerprint > On

What should happen when I do this?

My device should prompt me to touch the fingerprint sensor to enable biometrics and approve setup

What happens instead?

The slider doesn’t work and just pops to the left “Off” position instead

What’s the device/app combo?

Google Pixel 4a, Android 12, OVO Energy for Android App Version 14.0.0, CodePush Version v319

Is there anything else useful for me to know?

Yes. This report comes from a forum thread by @FunkyFerret55 . The original thread link is https://forum.ovoenergy.com/my-account-140/fingerprint-can-t-be-switched-on-10001 . @Blastoise186 reformatted the report on the users behalf. Please check the forum for further details. This also appears to be device-specific as Blastoise’s own devices Oshawott and Totodile could not reproduce the issue.

Userlevel 1

Yes, looks good to me.  I’m on Android 12., if you’d like to add that in.

Thanks for your help.

Userlevel 7
Badge +3

Sure, that’s all done. Tim and Jess should be able to get this sent off once they stop by. There’s no guarantee as to when it will be fixed, but they’ll most likely keep an eye on things and we’ll try to let you know when it gets fixed.

Userlevel 7

Great team effort on getting another tip-top bug report raised, @Blastoise186 and @FunkyFerret55!

 

I’ve forwarded this one on to the team so fingers crossed we can get a fix in place to get this fixed ASAP. :fingers_crossed:

Userlevel 7

So back with a super-speedy update on this one - The team have suggested you attempt to uninstall and reinstall the app, @FunkyFerret55

 

There’s been a few issues reported with other Android 12 users and reinstalling sometimes does the trick. Give it a try and let us know if you’re still not able to activate the fingerprint login… :slight_smile:

 

Userlevel 1

Thanks Jess

Sorry to say that after uninstalling and reinstalling, the issue persists. 

Thanks again.

Userlevel 7
Badge +3

I had a feeling it was Android 12 related. My phones are Android 11, so an Android 12 specific bug wouldn’t apply to them.

I think I may have a clue however. Apparently, Android 12 made changes to the biometrics stuff and I found a discussion on Reddit which talks about them here. The stuff in that thread is probably more useful to developers (which I’m definitely not one!) than anyone else, but somehow… I think I’m onto something here. It seems to differ a little from the official documentation too. Some more digging found this other content on the official docs too. this extra content appears to match what that Reddit thread is saying! And finally, the release notes for Android 12 seem to tell me some interesting stuff.

I might not quite be on the right track as I’m not a developer, but I might be lucky… Maybe?

Userlevel 7

Thanks Jess

Sorry to say that after uninstalling and reinstalling, the issue persists. 

Thanks again.

 

Just wanted to pop back to let you know I’ve passed this one back to the tech team, @FunkyFerret55. Sounds like they may have to do a bit more of a fix to get the fingerprint login option back for you. 

 

Keep us posted here if you notice any changes :slight_smile:

Userlevel 7

So our app team have got another suggestion to try, @FunkyFerret55.

 

Apparently by clearing the app storage (which is different to uninstalling) some bugs are resolved. To do this:

1. Press and hold the app icon
2. Tap “App Info”
3. Scroll down and tap “Storage”
4. Tap “Clear storage”

 

Let us know if this manages to sort that pesky fingerprint login issue. If not we may have to do some account-specific investigating. :spy:

Userlevel 1

Thank you Jess.  I have done the Clear storage, re-logged in to the app, and Fingerprint is enabled.  Many thanks, now I don’t need to look up my password every time I submit a meter reading.

Userlevel 7
Badge +3

Nice one!

Glad to hear that’s all sorted for you. If you ever need a hand again, feel free to stop by. We especially love getting bug reports here too!

Userlevel 7

Great to hear this one can be marked as ‘Resolved’, @FunkyFerret55.

 

Our tech team has also mentioned that they are working on improving this process so thanks again for spotting this pesky bug! :bug:

Reply