Solved

Why am I still being asked for opening meter readings, I've already submitted them!

  • 28 June 2022
  • 5 replies
  • 89 views

First post as a new customer. As requested I created my Ovo account and logged in to enter my first meter readings. Entered Electricity then Gas and then the page went back to ask me to enter the Electricity reading again. I have absolutely no idea whether the readings have been logged, no confirmation on the web page and no email. Maybe someone can help before I form a queue for customer service and start off our new relationship with a complaint!

icon

Best answer by Jess_OVO 28 June 2022, 15:53

View original

5 replies

Userlevel 7

Hi @Electric_Twit and welcome to the OVO online community,

 

Sorry to hear about the confusion you’ve had when trying to submit some opening meter readings. Sounds like there could be a technical bug about as we wouldn’t expect you to be able to see this submission page once the readings have already been entered.

 

To double-check everything’s as it should be and we’ve received the readings you’ve submitted it might be worth getting in touch with our Support Team. They can be reached fairly quickly via webchat which you can access here.

 

Hope this helps.

Thanks for the reply, however, I have tried web chat. The bot says it can take my readings but when I give them it says there is an error and when I ask to speak to a Human I am told, after entering my details, that they are too busy and try in another two hours. I have emailed your help address but I must say, having left a certain very large “British gas” supplier whose customer service was nigh on non existent I was hoping for a smooth transfer!

Userlevel 7

I’m so sorry to hear of the difficulty you’ve had getting those readings confirmed, @Electric_Twit.

 

Have you heard back from the team yet? Let us know if not and we’ll see what we can do here to help. 🙂

I believe I have resolved the issue of giving my opening readings as I used every option available to contact your company. Richard, in response to Twitter appears to have come up trumps and says he has added the readings and confirms my smart meter readings are being taken. BUT (there is always a but), other unresolved issues are:

  1. My web portal is still not displaying any information and is asking for my first meter readings. I cannot view any account information.
  2. I installed the Ovo App and that is not working either. All I get is a long error message summarised as follows “We’re waiting for some switch information from industry (a third party involved in all energy switches) …… take up to 6 weeks … As soon as the switch is complete, we can finish setting up your account …. Thanks for your patience!”. Who is this third party? There is nothing about a third party on the OFGEM site. I also thought my switch has happened, why up to a 6 week wait?
  3. You have indeed adopted my smart meter, but you appear to have loaded the incorrect tariff for Gas. My tariff is 11.130p per unit yet you have loaded 11.686p which is 5% higher. Strange, but the 11.130p includes VAT so have you added VAT to the charge? Can this be sorted.

Just an observation, but I am not impressed at how the switching process has progressed and it has fallen far short of the standards I was expecting as set out on the OFGEM website. Please sort out my web portal, my app access and the incorrect tariff and we can all go back to the quiet life!

Userlevel 7

Thanks for the update, @Electric_Twit - I’m glad to hear we were able to get that meter reading submitted for you. 

 

As you’re within the first 6 weeks of your switch to OVO, it’s expected that you will not have access to all the features of your online account:

 

 

I’d be interested to see if the unit rates on your smart meters remain out of synch by the end of this period of setting up the account. Things can take a bit of time to get the right tariffs and settings set up on the meters as well as all the info needed to have your online account up and running. 


Can you keep an eye on this over the next few weeks? I think it’s going to fix itself!

 

Reply