Solved

My OVO account has been moved to "new online system" - Why can't I confirm my email to login to my online account?

  • 7 November 2021
  • 6 replies
  • 81 views

When I try to login to my account now it says “We've moved your account to our new online system. Now we just need you to confirm your email to get you started.”

I put in my email address and hit submit, but just get an error message saying “Sorry, something went wrong. Please try again later.”

icon

Best answer by Jess_OVO 8 November 2021, 12:39

View original

6 replies

Userlevel 7
Badge +5

Hi @JohnBye !

Sorry for the wait. I just got back after being out all day.

This sounds a bit strange, but it might just be down to your account still being migrated over to the new billing platform. You might want to try again in the morning and see if it works then. If it still doesn’t work for you and the password reset feature isn’t getting you any luck, please let the Support Team know as they’ll need to dig deeper into your account to diagnose the issue.

Hopefully that gets you in! Please let us know if you’re still struggling after that.

Userlevel 7

Hi @JohnBye and Welcome to the OVO online community,

 

See you’ve already met one of our top volunteers here, @Blastoise186, who’s given some great advice on what might be causing the login issues:

 

 

This sounds a bit strange, but it might just be down to your account still being migrated over to the new billing platform. You might want to try again in the morning and see if it works then. If it still doesn’t work for you and the password reset feature isn’t getting you any luck, please let the Support Team know as they’ll need to dig deeper into your account to diagnose the issue.

 

We’ve also got a great trouble-shooting guide which might help figure things out:

 

 

Hoping this will be able to get things resolved but if not it might be worth reaching out to the Support team. Quickest way to get in touch is via our webchat which you can find here.

 

Let us know how you get on and what you think of the new online account once you get in! :slight_smile:

Thanks for the suggestions. It's still giving the error message when I try to login, and when I tried resetting my password it said "Your password reset link is invalid or expired".

I'll try contacting the support team...

Userlevel 7

What’s the latest on this one, @JohnBye? Did you ‘speak’ to (or message with) the Support team in the end? 

I talked to someone through the web chat, but they weren't able to fully fix the issue and had to pass it on to someone else. I'm expecting an email in the next few days.

For future reference, using my account ID instead of my email address to login got me past the first error, but then it needed to reset my password to access the new system, and it's still giving me the "Your password reset link is invalid or expired" error when I try to do that.

Userlevel 7
Badge +5

Hmm… That makes it sound like your account might be stuck between the legacy billing system and the new billing platform, sorry about that!

Hopefully one of the team can get it manually migrated over properly for you. Keep in contact with the Support Team if you still have issues after that. They’ll keep working on it if needs be.

Reply