Having an issue logging into your online account or app?


Userlevel 7

Updated on 18/05/21 by Jess_OVO

 

If you’ve just joined OVO, your online account  or OVO app (download for Android or iOS) won’t be fully accessible until you’ve received your opening statement (around six weeks after your switch date).

If you are having issues after this point, see the advice below which has been taken from our tutorial to login issues:

 

For App (Android or iOS) users:

 

If you’re having issues with our app, try deleting and reinstalling - ensuring it’s the latest version. Sometimes this is all it needs to iron out any issues.

 

And if you’re on a laptop/desktop: 

 

If you’re on a computer, ensure you’re using Google Chrome as your account is optimised for this browser. Clear your cookies and cache and try login again, here’s how to do that:

  1. On your computer, open Chrome.
  2. At the top right, click More More.
  3. Click More tools and then Clear browsing data.
  4. At the top, choose a time range. To delete everything, select All time.
  5. Next to "Cookies and other site data" and "Cached images and files," check the boxes.
  6. Click Clear data.

 

Still not working? 

If it’s still not letting you in, we’ll need a few details so that we can work out the issue:

 

  1. Are you logging in using your email address or account number?
  2. Are you using the app or the browser version of the site?
  3. Can you send us a screenshot of the issue/error? If not please describe it in as much detail.
  4. How long has this been ongoing for?
  5. What device are you using? I.e iPhone 7, Dell laptop etc.
  6. What software does your device use? This can usually be found in the settings section of your device.

 

Forward as much of the above info as you can onto the Support team and they’ll get on it! 

 


109 replies

@PJDen check out the best answer in this thread! :slight_smile:

Thanks Amy,

Issue resolved - forum is fantastic!

Any one else having problems with OVO app. It won’t accept my email or password ??

You should be able to, @Oh Dear, it sounds like you need to reset your password, check out the best answer on how to do this. 

If that doesn’t help reach out to the team. You can send us a message on FacebookTwitter or our Help Centre has online chat!

:slight_smile:

 

Thanks Amy - I had changed my e-mail address! So I was able to access and downloaded all my energy statements - so no problem now

Userlevel 5
Have you tried the forgotten password option?

I've just logged in okay so might be a digit wrong.
Userlevel 2
Saying that, it just magically started working on Firefox.
Userlevel 2
Can confirm its working across the board now. When I first got in most of the older data was missing etc... Gradually over the weekend it started appearing.

At a guess the acceptance and resetting passwords process kicked off a data transfer behind the scenes that didnt make immediate progress meaning I couldn't get in. All sorted now though. 🙂
The app is not working! Just says Loading and then does not open. I deleted it and re downloaded but its the same. Help would be nice before I run out of credit
Three days ago I signed up online as I've just moved into a property. The previous owners at the address were with OVO also. I filled out form with meter readings, email and new password etc etc and received the thanks for joining email but it won't let me log in. It says email not recognised. I tried both email and password and also the logging in for first time link. The same.

Regards

Andy
Hi,

Joined OVO a few months ago when I moved into my house. I filled out the switch form thinking I was switching to OVO, the current owners were already OVO users and so my account is stuck in a "Swtich" rountine and both the app and website have me it a "Your switch is on hold" since August 18th. Have spoken to you twice regarding this and was told "technical team" will be looking into this and sending you an email. That was nearly a week ago and no email and no change. Please help.

Regards,
Matt
Been with Ovo for 6 weeks since moving into new home, and still getting a "switch on hold" message. I did have a couple of emails back that basically told me to clear my cache. Surprisingly, I'd tried "turn it off and on again" already. Anyway, since that didn't work, support seem to have gone very quiet - no response to my last email after two weeks waiting. I thought staying with Ovo would make things easier, what with all the other stress around moving house, but think I'll switch to someone cheaper and more technically competent.
Hi @pmw75, when I had the same issue, Ovo's advice was to move to another provider. Hope this helps you as much as it did me.
Userlevel 6

You should be able to, @Oh Dear, it sounds like you need to reset your password, check out the best answer on how to do this. 

If that doesn’t help reach out to the team. You can send us a message on FacebookTwitter or our Help Centre has online chat!

:slight_smile:

 

Userlevel 7
Badge +2
I am having access my OVO account online or app. It constantly says incorrect email or password. I havn't changed them. No matter how many times I hit the "reset password" button, I get nothing. I hit it five times in the last ten minutes and NO reset email has turned up. Yes, it's the correct email address. This has been going on for weeks and the telephone help is bloody useless, less than. Does ANYBODY know how to fix this or me and OVO will definately part ways

Hmm, Have you checked your SPAM or Junk? I use gmail and for some reason password reset appeared in my junk.

Hope this helps. let me know. We will get to the bottom of this!
Userlevel 7
Badge +2

I've moved house and taken OVO with me, but logging in with Google Chrome takes me to old account. How do I get to use my new account? I tried putting my new OVO id but it doesn't work.
This had happened last time I moved too and I remember it was quite an effort to change this. I can't remember how to get this changed.
Also OVO makes it very difficult to mail or call for some support. No phone number or email id displayed easily. Can't understand why they make it so difficult.
Regards
Vivek

 


Hello @Vivek

If you message us on FacebookTwitter or our Help Centre has online chat, we should be able to assist you further.

 

Userlevel 6

@PJDen check out the best answer in this thread! :slight_smile:

Hi ive been a customer since december and my app has never worked can you look into this for me as ive rung 3 times and been told that its down to technical errors

I'm sorry to hear you've never been able to use the app, @Scareyvarey

If you send me a PM with your full name, DoB and account number I'd be happy to look into it for you. Could you also let me know what issues you're having when trying to log on/use the app?

Thanks,
Emma
I'm not sure how many ways I should have to contact Ovo before they actually sort this out. I've sent yet another email, so maybe that will help.

Any luck, @ply ? If not, send us a PM on Facebook and we'll get this looked into.

Thanks,
Emma
Hey @Jade134

I've just moved your query over to an existing topic on online account issues. Are you still getting this error message when you try to visit the payment screen?

If yes, please could you send us a PM on our Facebook page? Including a screenshot of this error message, your full name, account number and DoB.

Thanks,
Emily
That's not good to hear, @liquidshadow

Send a PM to the Facebook team with your full name, DoB and account number so they can help - https://www.facebook.com/ovoenergy.

Cheers,
Emma

Hey @KMac @MGMawby - thanks for getting involved on the forum.

Sorry to hear you're having trouble with the app. If you're still experiencing these log in issues, I'd recommend dropping us a message via FacebookTwitter or our Help Centre has online chat!

Userlevel 7
Hi @emceehamster

You will be pleased to know that this issue was resolved over the weekend and a fix put in place on the app to stop this happening.

Hopefully we have now dealt with the route cause of this and we won't see it again. If you are still having issues, please comment below and we will do our best to help.

Darran
Userlevel 7
@gazzoouk Welcome to the forum!

I've moved your topic here as we have already had this reported and I'm pleased to confirm this issue should now be fixed!

Any further problems let us know! Sorry if it caused any inconvenience over the weekend.

Darran
Userlevel 7
Hey @DanCath

Thanks for signing up to the forum and getting stuck straight in 🙂

We were having issues with the app over the weekend, but I believe that particular issue was resolved a couple of days ago.

Can you try uninstalling and reinstalling the app to see if that removes the issue. If not comment below and we will do our best to help out!

Thanks

Darran
Userlevel 7
Hi @FrustratedKez

Thanks for joining and posting your issue on the forum. Not sure if this is something that other users can help with, but I'm sure @Tim_OVO or @Emily_OVO will be able to support you on this one.

Over to you guys.

Darran
Userlevel 7
Couple of comments for Ovo admin.
Not keen on the forum layout, having to scroll to bottom to reply to the main post. IMO it would be much better to have a Reply link at the top (along with Like, Quote, Subscribe etc). A first time user may not appreciate that the Reply box is at the bottom of a long page.
I would also prefer the see the latest replies at the top/reverse order, as you would expect them to be most relevant, especially for a long standing post.
Why do the Bold, Italic, Underline formatting buttons in the editing box appear to be greyed out? This is the standard for showing items as being 'unavailable'.


Hi @ChrizK Glad to hear you got the issue with the login sorted (I'm looking at an S9, so good to know I might have to do the same when I upgrade).

With regards to the above, thanks for your feedback. We are always looking at how we can make the forum better and easier to navigate. Some changes we cannot make overnight so will take a bit longer to fix. The order of posts on a topic is set by default to oldest in time/date order. This is to encourage users to read the comments posted before as it will likely resolve their issue or answer there question. If we moved the ask a question box to the top, a lot of users would not bother to read all the information in the thread and just ask the same questions someone else has.

You can as a user use the drop down to change the order to newest first so as a regular visitor you'd probably do that. Having it set as your own default would be ideal, i.e it remembers these settings by user, but we don't have the functionality to do that yet.

In regards to the greyed out options, they can still be used, again this is a default in the design of the forum. Again something we are planning to change in the next few months. We will be moving to a new version of the forum platform which will give you more editing rules and options, it will just take a bit of time to move over but we will keep you posted on that.

Darran

Reply