Having an issue logging into your online account or app?


Userlevel 7

Updated on 18/05/21 by Jess_OVO

 

If you’ve just joined OVO, your online account  or OVO app (download for Android or iOS) won’t be fully accessible until you’ve received your opening statement (around six weeks after your switch date).

If you are having issues after this point, see the advice below which has been taken from our tutorial to login issues:

 

For App (Android or iOS) users:

 

If you’re having issues with our app, try deleting and reinstalling - ensuring it’s the latest version. Sometimes this is all it needs to iron out any issues.

 

And if you’re on a laptop/desktop: 

 

If you’re on a computer, ensure you’re using Google Chrome as your account is optimised for this browser. Clear your cookies and cache and try login again, here’s how to do that:

  1. On your computer, open Chrome.
  2. At the top right, click More More.
  3. Click More tools and then Clear browsing data.
  4. At the top, choose a time range. To delete everything, select All time.
  5. Next to "Cookies and other site data" and "Cached images and files," check the boxes.
  6. Click Clear data.

 

Still not working? 

If it’s still not letting you in, we’ll need a few details so that we can work out the issue:

 

  1. Are you logging in using your email address or account number?
  2. Are you using the app or the browser version of the site?
  3. Can you send us a screenshot of the issue/error? If not please describe it in as much detail.
  4. How long has this been ongoing for?
  5. What device are you using? I.e iPhone 7, Dell laptop etc.
  6. What software does your device use? This can usually be found in the settings section of your device.

 

Forward as much of the above info as you can onto the Support team and they’ll get on it! 

 


109 replies

@PJDen check out the best answer in this thread! :slight_smile:

Thanks Amy,

Issue resolved - forum is fantastic!

Userlevel 6

@PJDen check out the best answer in this thread! :slight_smile:

In the My Plan section of My OVO instead of my contract and tariff details I have a blank screen!

You should be able to, @Oh Dear, it sounds like you need to reset your password, check out the best answer on how to do this. 

If that doesn’t help reach out to the team. You can send us a message on FacebookTwitter or our Help Centre has online chat!

:slight_smile:

 

Thanks Amy - I had changed my e-mail address! So I was able to access and downloaded all my energy statements - so no problem now

Userlevel 6

You should be able to, @Oh Dear, it sounds like you need to reset your password, check out the best answer on how to do this. 

If that doesn’t help reach out to the team. You can send us a message on FacebookTwitter or our Help Centre has online chat!

:slight_smile:

 

Apologies - I thought I was adding a post not replying to one

Hi @Eva_OVO ,

yes, somehow it seems to be working again, I have no idea what happened.

Thanks :)

Userlevel 6

Sorry we missed this, @Stephen_B, have you managed to get this sorted now? If not, please send us a screenshot of what you can see and we’ll try to help with this! :)

Hi,

I’ve been a customer for years, but cannot log in anymore, it tells me the site redirects too many times. I’ve cleared all my cookies and other cache data, I’ve successfully reset my password, I’ve tried on a different browser… impossible to log in.

Any idea of what I can do?

 

Cheers,

 

Stephen

Userlevel 6
Hey @Graham Burley - I've moved your post over here where customers have been troubleshooting app issues with us!
Me too. The App just sends me round in circles. It doesn't recognize my password so I have to reset it each time. But I reset to the same then I can get in!
Userlevel 7

Have my Ovo ID but it is impossible to set up the account. If you click "First time logging in" it takes you to the password reset page. I have never logged in before so how can I reset my password?

Stick your email address in that 'password reset' section to get an email - this will let you assign a password which you can use along with your OVO ID to log in!

Let us know how it goes @Brickhouse
Have my Ovo ID but it is impossible to set up the account. If you click "First time logging in" it takes you to the password reset page. I have never logged in before so how can I reset my password? There's no way for me to do anything.

Tried calling but impossibly long queues and there is no way to contact anyone directly via this website except for this forum.
Userlevel 7
Badge +2

I've moved house and taken OVO with me, but logging in with Google Chrome takes me to old account. How do I get to use my new account? I tried putting my new OVO id but it doesn't work.
This had happened last time I moved too and I remember it was quite an effort to change this. I can't remember how to get this changed.
Also OVO makes it very difficult to mail or call for some support. No phone number or email id displayed easily. Can't understand why they make it so difficult.
Regards
Vivek

 


Hello @Vivek

If you message us on FacebookTwitter or our Help Centre has online chat, we should be able to assist you further.

 

I've moved house and taken OVO with me, but logging in with Google Chrome takes me to old account. How do I get to use my new account? I tried putting my new OVO id but it doesn't work.
This had happened last time I moved too and I remember it was quite an effort to change this. I can't remember how to get this changed.
Also OVO makes it very difficult to mail or call for some support. No phone number or email id displayed easily. Can't understand why they make it so difficult.
Regards
Vivek
Userlevel 7

@Henry

Eva has moved your comments to this topics (another topic to the one you created), on the same issue - that's what she meant. There's loads of comments on this topic thread, and others on this forum. But this looks like something we need to look at. Pop us a message on FacebookTwitter or our Help Centre has online chat!

Userlevel 7
Badge +2

Hi @j.jasonmitchell,

Hmmm how odd.

How long ago did you sign up? I believe OVO support team have to create your account associated with the email address you provided. I cannot remember if this takes a few days, My best guess would be check if OVO sent an email when you registered and see if they mention anything about creating an account on their end.

Maybe add some screenshots to this topic of the error you're seeing and the Mods can take a look to see if it's anything they need to raise to their Tech team.

Thanks

06/05/2020

Also, what on earth do I do to be able to "look through the comments for more advice on this"
How is one supposed to send a PM?

What does "I moved your query" mean?

I use Safari -

Why do I get this error message?

All I want is a hassle free login and see my statements. I it is not possible, please send me my statements by post as in the past. At least that does not require me spending hours trying to figure out how this forum works. Not user friendly at all.
Grrr

Hi, I'm fairly new to MyOVO. When I joined, I signed up for the online account and entered my meter readings. 

I'm receiving OVO account emails, have an OVO ID and an OVO account number.

However, I suddenly can't log into MyOVO online account. Even if I ask for a password reset, MyOVO doesn't email me one, essentially not recognising my email address...which is the one I am currently receiving OVO emails and account statements on.

Does anyone have any ideas? Many thanks in advance.

Jason

Userlevel 6
I sign in using email and password (also reset the password but instead of going into the site I get this error message: "No Identifiers.paym in sessio, please try again later.

What's going on, I tried yesterday with the same result and now reset my password but still same result ?!?

So frustrating
What's wrong?



@Henry Take a look through the comments for more advice on this.

If you're still unable to login send us a PM with your full name, account number and DoB so we can take a look into this!
Userlevel 6
I've moved your query over here, @marshalldouglas123, as we already had a topic on this. Take a look through the comments, I'm sure they'll help to resolve this issue.
I sign in using email and password (also reset the password but instead of going into the site I get this error message: "No Identifiers.paym in sessio, please try again later.

What's going on, I tried yesterday with the same result and now reset my password but still same result ?!?

So frustrating
What's wrong?
I CANNOT ACCESS MY ACCOUNT
I cannot access my account User name and password not recognised

Reply