Having an issue logging into your online account or app?



Show first post

109 replies

Hi,

This is not my first message, maybe I'll get some help. I can log into my OVO account, using username and password but it says "Your switch is on hold"(And it's not the first time happening, Tim helped me last time - it seems to be on and off, without any changes on my side). And I've been with Ovo for 1 year now. It's frustrating cause I cannot see my usage (I have smart meter but cannot read it inside the house), I cannot change direct debit if needed, cannot do anything.
Could you help me, please? "I'm in the dark here!"
Userlevel 7

I can log into my OVO account, using username and password but it says "Your switch is on hold"(And it's not the first time happening, Tim helped me last time - it seems to be on and off, without any changes on my side).

 


There's usually a root cause of some sort if you see this 'Onboarding' timeline after logging in. From what you describe, it seems to be intermittent. Very strange. Can you send us a message FacebookTwitter or our Help Centre has online chat, and we can look into it?

Tim

 

Been with Ovo for 6 weeks since moving into new home, and still getting a "switch on hold" message. I did have a couple of emails back that basically told me to clear my cache. Surprisingly, I'd tried "turn it off and on again" already. Anyway, since that didn't work, support seem to have gone very quiet - no response to my last email after two weeks waiting. I thought staying with Ovo would make things easier, what with all the other stress around moving house, but think I'll switch to someone cheaper and more technically competent.
I'm in the same situation. Still waiting for the tech support for some real support.
Userlevel 7
Let's get the OVO team to chase up these My OVO log in issues @ply @Crystal1296

Send a message to OVO via Facebook or Twitter for a reply today!

Tim
I'm not sure how many ways I should have to contact Ovo before they actually sort this out. I've sent yet another email, so maybe that will help.
I'm not sure how many ways I should have to contact Ovo before they actually sort this out. I've sent yet another email, so maybe that will help.

Any luck, @ply ? If not, send us a PM on Facebook and we'll get this looked into.

Thanks,
Emma
I'm still waiting;)
I'm not sure how many ways I should have to contact Ovo before they actually sort this out. I've sent yet another email, so maybe that will help.

Any luck, @ply ? If not, send us a PM on Facebook and we'll get this looked into.

Thanks,
Emma


I called Ovo on Saturday, and the person I spoke to couldn't work out the problem, so apparently it has been passed on to the tech team. Haven't heard anything since, but one of the email support people also passed on my problem to the tech team a few weeks ago, and I never heard anything, so I don't hold out much hope.
Same here.
Userlevel 7

@ply

 @Crystal1296 the Care team can chase this up if you drop them a message via FacebookTwitter or our Help Centre has online chat!

I hope this gets sorted quickly!

Tim

I've already done it. A while ago. Should I write them again?

@ply

 @Crystal1296 the Care team can chase this up if you drop them a message via FacebookTwitter or our Help Centre has online chat!.

I hope this gets sorted quickly!

Tim

 


Hi @Tim_OVO , I realise you're trying to be helpful here, but I've mentioned a few times now that I have been in contact a number of times with the "Care team" already, through multiple channels of communication. After lots of back and forth, my issue has been passed to the tech team on two occasions, at which point I hear nothing. It seems @Crystal1296 has been having the same issue for even longer, with no resolution, so I guess it can't/won't be fixed.

 

You've said it better than I would @ply. Thanks.
Userlevel 5
If this has been raised to the the Tech guys already @ply then I imagine you’ve already had your query picked up and investigated by either the Customer Care team or via our Social Team.

As this is with the Tech guys, they’ll be working hard to get this resolved for you. If you haven’t had an update within 10 working days, please get in touch with the Social Team so they can speak to the Tech guys and get an update for you.

If this is the same situation for you @Crystal1296 then I’d recommend following the above information. If your issue hasn’t been raised to the team yet, then please drop the Social Team a private message so they can get this investigated.

Lucy
It was raised and its been more than 10 working days.
I have called 4 times and get told works on there end. Over 4months and can't keep track on account. Tryed different devices,and deleted app lots off times. I think it can't be fixed time to move on!
Userlevel 6
Hey @Colzo,

I've moved your question over here where other users are discussing similar issues. You should be able to find the info you need!

Nancy
Hi. Just to update. I had a call from someone at Ovo last week.

They've told me they don't know what is causing the problem, and that it is with the tech team. However, as it's not causing me to lose my gas/electricity supply, it's not a priority issue, and as such, there is no timescale as to when it might be fixed.
Yeah, we don't lose BUT I really like to keep track of my usage and be able to make any changes in my online account without having to call them. Simple as that.
With me it happend the same in the past, Tim wad on it, after a few days he told me to log in using a different password. And all of the sudden, it worked.
Hello on my ovo account when I go to the payment screen I receive this message “No meter found for: ELECTRICITY... Cannot get costed rates. Please try again later.”

Any ideas on what could be causing this?
Hey @Jade134

I've just moved your query over to an existing topic on online account issues. Are you still getting this error message when you try to visit the payment screen?

If yes, please could you send us a PM on our Facebook page? Including a screenshot of this error message, your full name, account number and DoB.

Thanks,
Emily
Userlevel 5
@Crystal1296 If you're not having much luck with the Customer Care teams can you send me a private message with your name, DoB and account number so I can look into this further for you?

Lucy
I am new to Ovo and cannot access My Ovo via the website or the App. I have received emails from Ovo welcoming me, so the email address should not be a problem.

I have tried to create a My Ovo account (using "First time logging in?" link) and also logging as normal but I get the message "wrong email or password".

I have tried to reset my password but I do not receive an email with a link. I have checked junk and inbox folders.

Should I have received an activation link or can someone tell me what I have to do?

Thanks
Jumping into this thread rather than create another, haven't had any issues with the smart metering since it was all sorted out last year, but now I do actually have a problem, I can't log in to My OVO on the app to top up (annoying considering two of us use it on two different phones)!!!

It says I'm an OVO Communities Member (This forum? Or something else??) and I must log in via the website (see attached screenshot), it's been this way since a fix was applied to sort the white screen issue, so, I think someone male chickened up, or something's been applied to my account without my knowledge. I can still top up via the OVO website, so not all is lost, but it is a right PITA when it's all meant to be smart!!

And one more thing, in this state, on pressing the back button, the app refuses to close so I have to open the task manager to force the process to end, otherwise it sits there on my screen like a green lemon!

Reply