Forum posts - 'Ask our members', 'Create' and feedback about the confusing user interface

  • 14 March 2022
  • 4 replies
  • 50 views

Userlevel 2

(Apologies for putting this post here, I’m not sure quite where else this would go in these forums nowadays?)

I’m posting about an issue with forum user-interface which I think is rather counter-intuitive and could do with updating.  Specifically, this page, for creating a new topic post-

https://forum.ovoenergy.com/topic/new

Noting this from that page-

I just spent an hour typing out a long and detailed post for the Smart Meters forum, complete with tidy formatting and images to make for easy reading and a useful future reference.

Then I clicked this-

Unfortunately, it appears that the button at the bottom of the screen marked “Post your question” doesn’t actually “post your question”; instead, it just takes you back to the webpage you were on, to create a new post, sans all the lovely detailed information you just typed in, with no posibility of recovering it (back button didn’t help - Windows 10 + Google Chrome.)

It didn’t just catch me once: I tried creating a new post at least three or four times (remembering to copy all the text first - just in case) before I realised what was going on!

Due to its placement, directly under the section for adding tags, I though the small “Create” button was for creating a new tag; however, I now gather this is the button we should use to post our question-

 

How completely unintuitive and confusing is this?!

I’m previously frequent flyer here in the forums with 40 years of technical and computer experience; if I’ve been caught out by this issue, I wonder how many other people have been?!

Could one of the OVO reps please feed this UI concern back to the relevant section?

 

EDIT:  In order to successfully reproduce this, zoom in on your browser (I saw it on Windows 10 Google Chrome at 150% Zoom on a 1080p screen) or reduce the browser window width until it forces a change in the responsive layout and panel on the right disappears.  Then the layout should look something like this-

 


4 replies

Userlevel 7
Badge +1

Hi @jewelie ,

I’m Blastoise186, one of the forum volunteers here. I’m not usually up at this very late hour, but lets just say I got woken up by a disco machine just now so I thought I’d stop by anyway. I also just so happen to be a resident bug blaster as well.

Thanks for bringing this one up. It’s a possible bug so I’ll chat with the moderators about it and if needed, we’ll be happy to submit a bug report to inSided for you.

This may take me a few days to try and reproduce reliably, but I’ll let you know how I get on.

Userlevel 7

That must be so frustrating, @jewelie - losing your topic after writing everything out because of how the buttons are laid out and worded. I’m sorry to hear this. 

 

I think it’s really good feedback and I can totally understand how this could’ve happened. I’ll be making some changes today and I’d love to hear back from you after, to see if you think the UI has improved in that ‘Ask our members’ section. 

 

I’ll update this topic when I’ve made the changes :) 

Userlevel 7

I think it’s really good feedback and I can totally understand how this could’ve happened. I’ll be making some changes today and I’d love to hear back from you after, to see if you think the UI has improved in that ‘Ask our members’ section. 

 

I’ll update this topic when I’ve made the changes :) 

 

Me again, @jewelie

 

I hated the idea of others getting caught out like you did, so I went ahead and made the changes already. Please view the ‘Ask our members’ section and let me know what you think!

 

Screenshot here for a mobile device:

 

We’ve re-worded the ‘publish’ button and moved the ‘Need advice from other members’ widget further down the page

 

Userlevel 7
Badge +1

Looks fixed to me on Oshawott and Samurott. :)

Admittedly, I don’t have Samurott set to the same configuration because I tend to use 100% DPI Scaling and 100% zoom on a 1440p display but it’s close enough.

As for how that bug got there originally though… I think I’ve solved that mystery too, didn’t I Tim? XD

Oh, and I should probably explain something actually. Oshawott and Samurott are the names of two of my personal devices. I prefer not to have to keep typing out the full details of them every time and there’s unique circumstances surrounding them both which means I prefer to anonymise them a little. Tim and Jess both know what’s behind the names of all my devices though, so they substitute them for bug reports that go onto internal teams… Usually… :D

Reply