Solved

Why has my in home display stopped working?

  • 15 February 2020
  • 2 replies
  • 131 views

smart meter installed two days ago ,all ok.

today it displays “waiting for current data” and looks like its turning itself on and off.

please help.

icon

Best answer by Transparent 15 February 2020, 16:38

Hi @jacjules and welcome to the Forum.

This behaviour is normal for a new installation. I’d have expected the engineer to explain this in the customer briefing.

Anyway, all the information you’re likely to need is over here on the SMETS2 Installation Topic. If you click the link it will take you straight to the item where “Waiting for current data” is first described.

Please scan through the rest of that Topic, and if you have another question which hasn’t already been covered, then ask it over there.

I’m going to tag a Moderator to close this Thread and move your initial comment across where others will find it. @Amy_OVOplease?

View original

2 replies

Userlevel 7
Badge +2

Hi @jacjules and welcome to the Forum.

This behaviour is normal for a new installation. I’d have expected the engineer to explain this in the customer briefing.

Anyway, all the information you’re likely to need is over here on the SMETS2 Installation Topic. If you click the link it will take you straight to the item where “Waiting for current data” is first described.

Please scan through the rest of that Topic, and if you have another question which hasn’t already been covered, then ask it over there.

I’m going to tag a Moderator to close this Thread and move your initial comment across where others will find it. @Amy_OVOplease?

Working ok today. 

Reply