Solved

Why is my smart meter display now showing “waiting for current data”?


and I’ve tried everything and still won’t work. It was fine 2 days ago and only installed a week ago
icon

Best answer by Tim_OVO 15 June 2020, 16:57

Updated on 15/06/20:

 

Here’s some causes of connectivity issues with your In Home Display (IHD) and smart meter:

  • Distance: make sure your In Home Display is near your electricity meter. If it’s not connected or isn't showing usage data, move it closer!
  • Home Area Network (HAN): your smart meter(s) might not be on the HAN, preventing devices from connecting to it. 
  • Firmware: there might be a firmware issue with the IHD or smart meter, that’s causing connectivity issues.   

For HAN or Firmware issues, please reach out to our Support teams for them to diagnose and fix. On Facebook, Twitter, or email: hello@ovoenergy.com

View original

138 replies

Userlevel 6
Badge +1
It can normally take a couple of weeks for the data to display the correct figures although it should be showing something; is it actually the meter displaying the message or the In Home Display?
Its the in home display
was working fine until the 7th day and now it’s just searching for the actual meter and gives no data.
and it’s in the same cupboard!
Userlevel 6
Badge +1
I assume therefore that the meter is giving out readings?

Have you tried the obvious, turning the IHD off, leave for 30 seconds and turn it back on?

Is it a Pipit or Chameleon IHD?
My IHD display worked fine for 5 days after arrival. Now it just shows “waiting for current data” and nothing else.
ive restarted it, reset it and moved it right next to box and still nothing.
so annoying. Nothing on forum but loads on bulbs forum.
does anybody know how to reconnect it to the actual meter. I’m sure there must be a menu on the meter but it’s locked by pin and no instructions on the web.
IHD is a waste of time at present!

Userlevel 6
Badge +4
Hi @Mraprosser,

I've merged this topic with your original.

If nothing has changed, please give us a ring (0330 303 5063), drop us an email (hello@ovoenergy.com) or send us a message on Facebook with your account number, full name and DoB.

Thanks,
Nancy
Smart meters and IHD installed yesterday and working fine up until this morning. Error messages read: "waiting for cost now ..." and "waiting for current data ..."

I've switched the IHD on and off, and moved it closer to the gas and electricity meters.

Still no joy.

Any suggestions?
Userlevel 5
We already had a topic on this, @tatbriz, so I've moved your query over here. Take a look at the best answer for more help with this.
After being fitted and connected successfully on 29/7/19; my IHD is now constantly showing “waiting for current data”
Not exactly useful!!!
Anyone resolved this issue?? Or do I need to contact OVO.
thanks
Userlevel 7
Badge +3
Hi @David Tanner Is this a new Smart Meter installation?

Have a look at the Communications Hub, which sits on top of your electric meter. What lights are flashing and how fast?
All flashing approx every 5 seconds
Are both lights simultaneously flashing at 5 seconds... han and wan? That means all is well, only thing you could try is a reset of the ihd, turn off the ihd (hold on off button for 7 seconds) take it to near to the electric meter turn ihd on (press on off button once) then wait for ihd to power up and connect takes about 30 seconds, if its still not loading info and proper usage then the meters are maybe not commissioned yet which with ovo can be done at a later date after meter install, I'd chase it up with there smart office
If lights are flashing every 5 secs that's the settled signal receiving state meaning its 'birthed' that's how it should be
Userlevel 7
Badge +3
Erm, I think this might be an installation in south or central territories.

@David Tanner how many lights are on your Communications Hub?

Compare the flash rate with the diagrams in this post.
In this case han and wan are the ones he needs to be looking at, whether North South or North Central. If its 5 secs its fine.
Thanks for the replies above...
however, tried the reset and no change to IHD...... still “waiting for current data”
Any other suggestions?
I'd be getting in touch with ovos smart team, to check set up and that they have commissioned the meters and ihd.
Thanks Tufty71. I thought that might be the last resort. What I strange was that it was working fine for about 12 days then just stopped.
ill get in touch with OVO.
So after having my smart meters installed, and then waiting for the IHD to arrive, and then waiting some more for the August update...

Has the August update happened yet (not much of August left)?

Is the "Waiting for current data" still a problem, or should this have been fixed already and I just need to call customer services to do some more magic?

If the "August Update" is a little shy and I just need to wait longer, that's not a problem, I just want to hear about it.

For reference the lights on the comms hub all flash together (including HAN and WAN) once every 5 secs or so, the meters provide data to Ovo as they are supposed to - so far as I can tell, everything apart from the IHD works like it should.

I went though the pairing process with Ovo on the phone to pair the IHD when it arrived, it receives the time from the meters, but nothing else.
Userlevel 3
Badge
Try switching your tv on, wait 2 minutes and put it on standby. Then boil a half filled kettle until it switches off.
Open the fridge door, if the light comes on run upstairs (this won't work in a bungalow) and run the hot tap.
If your IHD is still not displaying correctly then you are in the same boat as me.
Userlevel 1
Tried all that Barnabee. IHD still not working but now tv only receives Dave, kettle won’t switch off, fridge door fell off, need a knee op. since running up stairs and I’ve no hot water. Any more bright ideas? Oh, and the gas metre is not talking to the hub so I have to supply a reading every month. And I thought Brexit was a cock-up!
The bad news is, that didn't help at all, the good news is that I now have a cup of tea, and a sandwich... 🙂
Userlevel 1
Someone suggested putting the IHD in a different place in case the signal was being blocked.

I put it in the recycling box. Still it didn’t work but I feel a lot better now that I can’t see it.
Userlevel 5

Update on 25/2/2020: This fix is currently in the process of being rolled out. Unfortunately, we don’t have a time frame as to when all areas will be updated, but if your IHD hasn’t been fixed yet, rest assured it will be shortly.

 

@AndyTaylor@Barnabee@Actongrumpy, we had a similar topic on this so I moved your posts over here! 👋🏽

If you have SMETS2 meters, there's a known issue affecting them. A fix is being remotely rolled out now so the issue will be resolved soon.

We'd be happy to check this is the case, send us a message on Facebook or Twitter with your name, DoB and account number. If you don't use social media email the team on hello@ovoenergy.com.

If you've got SMETS1 meters this may indicate we're not communicating with them, please reach out to the team. 

 

Userlevel 1
I have a SMETS2 meter. I reported that the gas indicator light on the hub was not winking at me and that the IHD wasn’t working. I completed a smart meter health check as instructed and I’m awaiting the results of an investigation by the smart metering team. If I heard correctly, this takes 5-7weeks. In the meantime I am supplying manual gas readings just like the old days. I don’t think any software update is going to address my problem until the gas meter gets it’s act together.

(My mother told me that it was rude to say Watt)
Userlevel 3
Badge
SMETS2 here Eva. Hopefully the fix will be out before Xmas when I will unwrap my IHD. I don't normally get any presents so if it works on Christmas day I will at least have some festive cheer. Think Mr Bean Xmas and you won't be far wrong.

Reply