Solved

Why is my Chameleon IHD not working?

  • 12 February 2018
  • 14 replies
  • 1650 views

Hi

Since having my new meters fitted the IHD loses its connection, sometime for a month, i think it's faulty, does anyone else have this problem ?
icon

Best answer by Tim_OVO 6 March 2019, 13:27

I hope someone can help me - the IHD was set up Wednesday lunchtime (now Friday eve) and it still is waiting for current data


Still not connected, @reginaldo ?

Make sure it's near the electricity meter, and look for the 'WiFi' symbol top left of the meter screen. If it's not there, we might need to 'pair' the device to the meter, which we need you to call to sort: 0330 303 5063
View original

14 replies

Userlevel 5
Badge +2
Hi

Since having my new meters fitted the IHD loses its connection, sometime for a month, i think it's faulty, does anyone else have this problem ?


Hey Nat995,

Have you tried to move the IHD closer to your electricity meter? It may keep cutting out due to connectivity issues.

Lucy
Hi,

I have tried this and it has no effect at all

Thanks
Hmm - we might need to check the communication strength of your smart meters, @Nat995

Send us a PM on Facebook with your full name, DoB and account number so we can look into this for you - https://www.facebook.com/ovoenergy.

Thanks,
Emma
I've had my smart meter a good six months I think. It has stopped updating when I switch appliances on for example I know my dehumidifier runs at 6p an hour but it displays 2p an hour. It used to update as I turned things off and on as I assumed it was supposed to do. It often shows 0p an hour when I have things on, fridge, freezer etc. I've contacted ovo by email who have told me this is because it is set to send a meter reading once a day not every half hour. I think they have mis understood my question? It definitely used to work, and my understanding was it was a live update to show you what you were using!
Hey @Roxannesiddall - I've moved your query over here. Just check out the 'best answer' at the top.
I hope someone can help me - the IHD was set up Wednesday lunchtime (now Friday eve) and it still is waiting for current data apparently and does not seem to know when i am putting kettle on etc...is this normal or if not what do i have to do to get it fixed without calling someone and losing my Self Service Reward? Thanks in advance!
Userlevel 7
Badge +2
I hope someone can help me - the IHD was set up Wednesday lunchtime (now Friday eve) and it still is waiting for current data


Still not connected, @reginaldo ?

Make sure it's near the electricity meter, and look for the 'WiFi' symbol top left of the meter screen. If it's not there, we might need to 'pair' the device to the meter, which we need you to call to sort: 0330 303 5063
We have had smart meters put in, ihd arrived a week or so later. It was 'switched on' ovo's end but all we've had is 'waiting for current data' for a week. Any ideas?
So, no one knows anything?
Userlevel 3
Badge
Lots of people get this problem, including me. If you have tried the usual switching it off and back on after a minute and moved it closer to the meter then it is unlikely to work for 6 to 8 weeks whilst your accounts are being set up correctly.

It is not just OVO customers experiencing this problem. The energy forums are awash with complaints about IHDs. The energy company Bulb has recently put out a statement apologising and a full explanation of what went wrong. Apparently there is a fix coming out in September for the type of IHD that we have been supplied.

The system appears to have been rushed in without being fully tested.
Nice one, thanks for taking the time to reply.
Userlevel 5
Badge
Thanks for stepping in @Barnabee, we tend not to moderate over the weekend @Adam1968uk, but we will try and get back to you as soon as we can.

@Barnabee's info is bang on, but it may not apply to your meter type. I've moved your posts here, this topic helps cover the answer please check out @Tim_OVO's answer below for your next steps!


I hope someone can help me - the IHD was set up Wednesday lunchtime (now Friday eve) and it still is waiting for current data
Still not connected, @reginaldo ?

Make sure it's near the electricity meter, and look for the 'WiFi' symbol top left of the meter screen. If it's not there, we might need to 'pair' the device to the meter, which we need you to call to sort: 0330 303 5063
Thanks for tip - I was told that a next gen version would be sent to me (apparently the one I have is showing nonsense) which is a known fault (?!) anyway that was a full 3-4 months ago - does anyone know what is the status update for the new gen IHD?
Userlevel 5
Badge
That is a while, @reginaldo, please get in touch with our team.

You can send us a message on Facebook, Twitter or email the team on hello@ovoenergy.com, or give them a call. You can reach our Customer Care team 9-5 Monday-Friday on 0330 30 5063.

😊

Reply