Solved

Why does my In Home Display (IHD) only display 'Waiting for Current Data' ?


Userlevel 1
SMETS2 gas and electricity meters installed on June 29 2019. IHD received two weeks later.
Despite various phone calls and emails, the IHD only displays 'Waiting for Current Data.'
The only info I have received from OVO is that ' there has been some teething problems that we have been working to get fixed.' No indication of when this will be resolved. If there is a known problem with these displays, why are OVO sending out duff kit?
icon

Best answer by Transparent 24 July 2019, 15:07

Hi @101049932 There are two different issues mixed together in what you've posted.

A. There has been a long-term problem with the Chameleon IHDs displaying erroneous costings. This is resolved when new software is installed (remotely) into the Communications Hub.

Have a look at this post here on another Topic and the ensuing clarifications.


B. When an IHD is first supplied to a site, it has to be "paired" with the Communications Hub. So did OVO provide you with instructions to do this?


In either case, there is unlikely to be anything wrong with the IHD itself.
View original

22 replies

Userlevel 7
Badge +3
Hi @101049932 There are two different issues mixed together in what you've posted.

A. There has been a long-term problem with the Chameleon IHDs displaying erroneous costings. This is resolved when new software is installed (remotely) into the Communications Hub.

Have a look at this post here on another Topic and the ensuing clarifications.


B. When an IHD is first supplied to a site, it has to be "paired" with the Communications Hub. So did OVO provide you with instructions to do this?


In either case, there is unlikely to be anything wrong with the IHD itself.
Userlevel 1
Thank you for your reply. OVO did provide the info to do this and that seemed to be successful as I have three bars on the connectivity symbol and the IHD is showing the correct time.
I have the exact same problem...

The IHD is paired up ok, I get the time, and then just "Waiting for current data"
Ovo tell me that there is a software fix coming (over the air) to my meters that will clean this up, it is expected some time in August.

In short, wait it out and one day in August it should magically spring to life.
Userlevel 5
Badge
The firm ware issue is in the process of being fixed, @AndyTaylor and @Kevuk, things should be sorted soon!

Thanks!
Why they didn't fit you an ihd at same time as meter install, god only knows, maybe they were out of stock, because getting an ihd paired with your gas and electric meters means unpicking the scheme and then re sending the scheme, should have someone on site making sure it's gone through and also you need to be offered a run through the operation of it and offered energy saving advice as part of install.
As the engineer explained the rush on SMETS2 meters really did mean the IHDs were out of stock.

in fairness the pairing process from my perspective was painless, sure there are some teething issues that need to be ironed out, but I have every faith that will happen.
I appreciate that and really glad it works the smets2 is literally a smart bit of kit once installed, but it's also important that it's fitted by an engineer to then offer a run through the device answer questions and offer energy saving advice
Userlevel 5
Badge
Thanks for your faith, @AndyTaylor, it's a shame they were out of stock! Our team will run through the set up over the phone, @Tufty71, I appreciate that it is easier to do face to face but sometimes this isn't possible.

☺
Amy it's not just easier, it's a requirement as part of smicop.
Userlevel 3
Badge


For Amy, thanks for the updates
Userlevel 1
So, it is now September 17 and three months on I am no further forward. The only thing the useless IHD displays is 'Waiting for current data'. What is going on? I get the impression, nothing. Amy previously says 'The firm ware issue is in the process of being fixed'. Is that going to be this year next year or when?
Userlevel 3
Badge
Hi @Kevuk
Frustrating I know as I have been there and got annoyed at the whole farce too.

However in defence of OVO they are rolling out IHD updates, by area I think. I had mine 2 weeks ago which got the gas usage displayed and then, after more emails, a nice guy called Rob rang and sorted it remotely. I now have a working IHD.

Once the tech dept are on the case you hopefully will get it sorted. As long as you have contacted OVO directly they should get it fixed. Until then at least you have an extra clock.
Userlevel 1
Barnabee,

Thanks for the reply. Fingers crossed!
Userlevel 1
Just spent about 40 minutes on the phone, mainly on hold, speaking to OVO and delighted to say, I now have a fully working IHD giving sensible results. Intrigued to see zero electricity costs at times during the day when the solar panels are operational.

So finally, thank you OVO. The fingers crossed worked!
Userlevel 6
Badge +4
Glad it's fixed @Kevuk - sorry it took a while on the phone today!
Userlevel 1
Spoke too soon. Like many others, the IHD is now only displaying gas usage. What a farce!
Userlevel 1
Just phoned OVO regarding the IHD problem. The customer service agent could not tell me what the problem was so I asked to be put through to technical services. That was not possible! Customer services contacted technical on my behalf and came back with the surprising comment, 'they do not know. It could be one of many reasons.' Informed the software update should resolve the problem. I assume this is the mythical software update that was going to be released last August!
Userlevel 1
Yesterday the IHD sprung back into sensible life. No one more surprised, or pleased, than me. Today I received an email from OVO telling me they are supplying a replacement IHD. Not sure why!
Userlevel 7
Badge +2

Oh dear, let’s get this new IHD send out cancelled, @Kevuk - can you call us to update the Smart meter team that it’s back up and running: 0330 303 5063

Hi everyone, had a new Smart meter fitted today and IHD was working for the electric, I was told the gas may take up to 2 days to show on screen. Suddenly the gas symbol came on and now I have "waiting for cost now" on the screen and have lost the usage totally, as a newbie to this IHD, is this correct and will it sort itself out?  Hope this makes sense and someone can help. Thanks

Smart meters installed a week ago.  After 36 hours the IHD no longer displayed the current cost of energy being used; an envelope icon appeared at the top, and ‘new message’ and ‘waiting for cost now’ have been scrolling ever since.  How do I open this message?  Will the original display ever return??

 

Userlevel 1

Disappointed this morning to find the IHD had reverted to only showing gas usage. Disconnected the power supply and turned IHD off.  Waited 30 seconds and reconnected power supply.  After a few seconds, pleased to say all back to normal.  Much relief.

Reply