Solved

Why cant I login into my online My OVO , app or send reset password?

  • 21 October 2018
  • 42 replies
  • 1904 views

Having major issues i registered on the forums fine yet when i enter my customer ID and click on

First Time Logging In
or
Reset Password

Nothing is being sent to the email address i registered with..... I know that the Email is correct because ovo send me account updates to it...
icon

Best answer by Mw2870 22 October 2018, 21:42

Hi @wizwych, welcome to the forum.


That sounds really annoying, presumably you are trying to use this reset link:
https://my.ovoenergy.com/password/reset

If it still doesn't work, here’s the topic you want, with a step by step process to follow to sort this. I’ll copy them below:

 

Top tips:

  • Login here.
  • Make sure you’re using the email address you registered with us, or your Customer ID (find this on your welcome email or a bill).
  • Send yourself a password reset email if you’re having issues.
  • Check your spam/junk to see if the email has gone there.
  • If you’ve changed your password and it’s not being accepted, try clearing your browsing history, autofill data, cache and cookies.
View original

42 replies

Userlevel 5
Badge +2

Hi @wizwych, welcome to the forum.


That sounds really annoying, presumably you are trying to use this reset link:
https://my.ovoenergy.com/password/reset

If it still doesn't work, here’s the topic you want, with a step by step process to follow to sort this. I’ll copy them below:

 

Top tips:

  • Login here.
  • Make sure you’re using the email address you registered with us, or your Customer ID (find this on your welcome email or a bill).
  • Send yourself a password reset email if you’re having issues.
  • Check your spam/junk to see if the email has gone there.
  • If you’ve changed your password and it’s not being accepted, try clearing your browsing history, autofill data, cache and cookies.
I’m trying to login for the first time but when I hit the button to log in for the first time, it just takes me to a password reset page. I’ve tried filling it out with my e-mail but I don’t get sent a link.

This is pretty poor from a company that have now asked me twice for meter readings!

Any advice?
I have to sign up to ovo energy as I received a letter however when I try and sign up and put my email address I don’t get sent a password through email ? What am I supposed to do
I have tried to reset my password and I'm not receiving emails back. I have uses both my Ovo ID and the email address you send my emails to I haven't entered either incorrectly and need access to my online account what do I do? Thsnks
there is a hyperlink under the bit that asks for email and password, but at the moment it takes you to password reset page, so you cant register, this is the issue i am having too
Userlevel 7
Badge +2
Hi @Chuck1963

Have you checked your spam/junk folder in your emails. I believe the address used is slightly different so your mailbox may think it's spam. Please do check and let us know how you get on
Yes I've looked in spam and junk and not there I need to be able to get into my account any suggestions other than waiting on the phone for 40 to 50 minutes in a queue?

Thanks
Userlevel 7
Badge +2
Could be a problem with OVO emailing system. Might be best to call them
Userlevel 7
Badge +2
I’m trying to login for the first time but when I hit the button to log in for the first time, it just takes me to a password reset page. I’ve tried filling it out with my e-mail but I don’t get sent a link.


Sounds like a similar situation as the one described above @TheJillymeister - how did you get this sorted in the end @wizwych ?
I never got it fixed i phoned OVO up 5 times and they assured me that the situation was being dealt with and i still cant login cos i dont have a password to login with and nothing from OVO is being sent to my email other than bill reminders and forum posts
Hi,

I signed up with Ovo earlier today and was asked to set a password etc for my portal account, and after completing the sign-up and getting all of my introductory emails I accessed the portal as normal.

About an hour ago I tried to access it again but it has logged me out, and when I tried signing in it said wrong username or password. I tried entering my password I'm sure that I used a few times, and some other passwords for good measure and was getting the instant error message of wrong email or password still. I tried the reset my password option, yet I'm not getting any emails from this what-so-ever, as well as when I select the "first time logging in" option which just directs me to the exact same password reset page anyway. I have tried this ten times and still have nothing in my inbox.

YES - I have checked my spam folder. And I know that the email is correct because I was getting Ovo emails fine earlier, and have done when creating this account just now.

It looks like other users on here have reported this issue - some going back two years - and one in particular saying that months have passed by and Ovo support who they have called over five times, who are just saying it is "being looked in to" yet they still cannot log-in, but if this cannot be resolved for me promptly and if I'm getting the same experience as this other customer I'll be going elsewhere.
Userlevel 6
Badge +4
Hi @wizwych - just to be on the safe side, have you checked any spam or junk mailboxes for the password reset email?
Hi @wizwych - just to be on the safe side, have you checked any spam or junk mailboxes for the password reset email?

I have tried 3 more times since my last post, this is absolute stupidity now no mail sent to spam or even inbox.. ONLY from the forum OR when ovo demand money from me.



As you can see from the images the first shows That i am getting emails from the forum and i am also getting emails for when my bills are due BUT i cant login to my account cos it wont let me create a password which i have tried to do on images 2 and 3 NO email is being sent to my email addy even as spam..
Userlevel 6
Badge +4

Hi @ryan6292

Have you tried using your OVO account ID rather than your email address to log in? You can find this on any communications from us.

Also, when you say you signed up with us a few days ago, do you mean you moved into a property that OVO supplies and set up an account, or you started a switch from another supplier to OVO?

More info about login issues here.


Cheers

Userlevel 6
Badge +4
Hey @wizwych - I'm sorry to hear that. If this is the case there may be a technical issue at the root of this. I'd advise calling the team on 0330 303 5063 to investigate further.
Any ideas why it's impossible to sign in to account after a simple change of name after a bereavement.
There is even a probate dept to help with this but it still went pear shaped!
Cleared cache
Using Chrome
Still can't login though!
This is what i keep getting!

Userlevel 5
That's strange, @paul5412, this is something we'd need to look into. Can you send us a message on Facebook or Twitter please? If you don't use social media, send the team an email on hello@ovoenergy.com.
Won't recognize the e-mail address but will recognize the customer id number.

II have read on here of the difficulty that the system you have recognizing an e-mail that has been previously used but thought you had rectified this problem?
Userlevel 2
Badge
@paul5412 I'd get in contact with us as Eva says, it's most likely that your email address has a typo on one of the systems required for an online account.

Once we've had a look at it, I'm sure we'll be able to sort it.

Thanks,
Ed
Same problem as most i guess, can't log in to ovo app or my ovo on website, it says email \ password wrong, tried requesting new password, doesn't send me new link and it's not in my spam!! Have phoned in the past and tbh am sick of waiting to get response on phone.
Userlevel 2
Badge
Hi @Dannyboy,

I've moved your question to this existing topic as I feel this best answers it for you.

Check out the best answer by @Nancy_OVO!

Hope this helps!
Thankyou
For the last week or so I've been unable to access the Myovo page on my PC because I keep getting a message saying "400 bad request - request header or cookie too large, nginx/1.14.1

How can I fix this please? Preferably without having to delete all the cookies for every website.

Reply