Solved

Why am I getting an error when trying to open new account?

  • 18 August 2018
  • 7 replies
  • 271 views

I have tried several times to open a new account for a new flat I am moving into which is already supplied by OVO. Upon filling out the online form, I get to the page which asks for the meter reading - I put this in as directed, followed by clicking the button "confirm and switch" then after this, a green revolving circle icon appears, and nothing happens.

I have left the browser window open for over 10/15 minutes and nothing happens. I have tried different internet browsers and still have no luck. The photo attached shows the icon I am referring to.

has anyone else had this same problem?

icon

Best answer by Darran_OVO 20 August 2018, 11:02

Hey @mcinc93 welcome to the forum, although not quite the first experience we wanted you to have here!

Sorry to hear you are having issues, I have flagged to the Product team but wondered if you could send me a PM (click on my name and you will have an option to send message), to provide us with a bit more information so we can try and find out what's going wrong here?

If you could PM me with your full address including postcode that would be super helpful.

Darran
Community Manager
View original

7 replies

Userlevel 7
Badge +2
Hey @mcinc93 welcome to the forum, although not quite the first experience we wanted you to have here!

Sorry to hear you are having issues, I have flagged to the Product team but wondered if you could send me a PM (click on my name and you will have an option to send message), to provide us with a bit more information so we can try and find out what's going wrong here?

If you could PM me with your full address including postcode that would be super helpful.

Darran
Community Manager
Userlevel 7
Badge +2
@mcinc93 Also, can I check that you are using this link to complete your move in? The tech team just flagged that you might be trying to use Quote and Switch, rather than the moving home page?

https://www.ovoenergy.com/moving-home

Darran
Userlevel 7
Badge +2
@mcinc93

Thanks for sharing your info via PM. Glad to hear you managed to call in the meantime and get this resolved. The Tech team have identified an issue with this process and are cracking on with a fix as we speak.

Thanks for flagging this!

Darran
Hi,

We've moved in to a property supplied by OVO and have been trying over the last month to register with you but every time we get to the final stage when we click "confirm and switch" nothing happens. I've now entered my direct debit details on 6 separate occasions... I've also tried the logging in for the first time page as i have been sent in the post a letter with an OVO ID on but again when you click on "first time logging in" it goes to a page to enter your email to reset the password - but I have never received an email despite filling this in several times. We have our meter reading and serial number and are keen to set up payment but your website doesn't allow this.
I note from the forum that others have had the same issue.
Please can someone contact me to allow me to register with you as unfortunately i am not able to choose another firm.
thanks
Userlevel 5
Hey @louc,

We already had a topic on this, so I've moved your query over here.

It sound like you're trying to process a switch, which won't work because we're already supplying your home. You'll need to fill in our home move form instead, just use the link in Darran's second message! 🙂

Eva
Hey @louc,

We already had a topic on this, so I've moved your query over here.

It sound like you're trying to process a switch, which won't work because we're already supplying your home. You'll need to fill in our home move form instead, just use the link in Darran's second message! 🙂

Eva

Hi @Eva_OVO

I am using the home move link/form. Both the one on the website and in Darren’s message. Which are slightly different but appear to reach the same page. This does not resolve my issue and will not let me set up the new account.
Louise
Userlevel 7
Badge +2
This does not resolve my issue and will not let me set up the new account.

Thanks for trying @louc

In that case, give us a call so we can create the account from your move in date: 0330 303 5063. Make sure to have the readings that were showing on that day!

Reply